cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1402
Views
5
Helpful
2
Replies

NAT64 - Problem

Hello,

 

In my simple topology (below) I'm trying to achieve translating IPv6 into IPv4 address by Router in middle called "NAT64".

So that R1 (IPv6 only) can ping R2 (IPv4 only).

 

R1 router is configured with IPv6 only:

interface FastEthernet0/0
no ip address
ipv6 address 2001:1111:2222:A::1/64
!
ipv6 route 2001::/16 2001:1111:2222:A::2

NAT64 is configured with this settings:

interface GigabitEthernet0/0
no ip address
nat64 enable
ipv6 address 2001:1111:2222:A::2/64
!
interface GigabitEthernet0/1
ip address 1.1.1.1 255.255.255.0
nat64 enable

!

nat64 prefix stateful 2001:1111:2222:1::/64
nat64 v4 pool MyPool 1.1.1.10 1.1.1.20
nat64 v6v4 list ACL pool MyPool overload
!

ipv6 access-list ACL
permit ipv6 any any

R2 settings:

interface FastEthernet0/1
 ip address 1.1.1.2 255.255.255.0

bXkNeDZ

 

From R1 I'm trying to reach R2 by pinging:

R1#ping 2001:1111:2222:1:0001:0101:0200:000

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 2001:1111:2222:1:1:101:200:0, timeout is 2 seconds:
.....
Success rate is 0 percent (0/5)

R2 gets this ping, and try to answer (without success):

R2#
*Mar  1 00:26:22.043: ICMP: echo reply sent, src 1.1.1.2, dst 1.1.1.11
R2#
*Mar  1 00:26:25.839: ICMP: echo reply sent, src 1.1.1.2, dst 1.1.1.11

I'm thinking that the problem must in NAT64.

NAT64#show nat64 translations 
Proto   Original IPv4           Translated IPv4
        Translated IPv6         Original IPv6
--------------------------------------------------------
icmp    1.1.1.2:2950            [2001:1111:2222:1:1:101:200:0]:2950
        1.1.1.11:2950           [2001:1111:2222:A::1]:2950

Total number of translations: 1



NAT64#show nat64 statistics 
NAT64 Statistics

Number of NAT64 enabled interfaces: 2

Number of packets translated by stateless NAT64:
        Packets translated (IPv4 -> IPv6): 0
        Packets translated (IPv6 -> IPv4): 0

Number of packets translated by stateful NAT64:
        Packets translated (IPv4 -> IPv6): 0
        Packets translated (IPv6 -> IPv4): 15

It looks like NAT64 is not translating responses from R2 to R1 (Packets translated (IPv4 -> IPv6): 0).

 

So my question is, am I missing some commands in the configuration of NAT64?

 

1 ACCEPTED SOLUTION

Accepted Solutions
Harold Ritter
Cisco Employee

Hi Peter,

 

Can you change the following configuration statement and retry:

 

nat64 prefix stateful 2001:1111:2222:1::/96

 You also need to change the way you ping from the IPv6 side to:

R1#ping 2001:1111:2222:1::0101:0102 or ping 2001:1111:2222:1::1.1.1.2

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

2 REPLIES 2
Harold Ritter
Cisco Employee

Hi Peter,

 

Can you change the following configuration statement and retry:

 

nat64 prefix stateful 2001:1111:2222:1::/96

 You also need to change the way you ping from the IPv6 side to:

R1#ping 2001:1111:2222:1::0101:0102 or ping 2001:1111:2222:1::1.1.1.2

 

Regards,

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

View solution in original post

Thanks Harold for your time. I need to apologize, because I forget to mention about one importany detail. I wasn't testing this configuration on real devices, but on IOSv in GNS3. My NAT64 router was IOSv Software (VIOS-ADVENTERPRISEK9-M), Version 15.6(2)T, but when I changed it to CSR100 (virtual as well) it worked fine.

I tested both configurations (Yours and mine) and both worked on CSR.

 

 

Content for Community-Ad
This widget could not be displayed.