cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1633
Views
0
Helpful
2
Replies
Highlighted
Beginner

Problem with NTPv4 over IPv6

Dear All,

When I was doing PoC for IPv6 transition, I had to work with NTPv4 for native IPv6. I am using 3825 running 12.4(24)T  adv enterprise.

As per Cisco documents NTPv4 is supported in 2 modes.

1. Client - Server.

2. Multicast.

I am presently interested in Client Server Mode

In this mode I configured Server with command. 'ntp master 2'

And on the client I configured:

===

ntp update-calendar

ntp server FD00:0:0:60::1 source Loopback0

===

Loopbacks of both server and client are reachable using OSPF.

But NTP remains unsynchronised forever.

Are there any known issues with NTPv4 over native IPv6 ?

2 REPLIES 2
Highlighted
Beginner

Hello Maulik,

I am running a 1921 in a production environment and the NTP config includes:

ntp update-calendar

ntp peer 192.168.128.3

ntp peer 192.168.128.5

ntp peer 192.168.128.10

ntp server 130.159.196.11

ntp server 2001:67C:288::128

(the router is running dual stack)

sh ntp associations

Gives:

  address         ref clock       st   when   poll reach  delay  offset   disp

+~192.168.128.3   158.43.192.66    2    710   1024   377  2.047   0.721 15.742

~192.168.128.5   .STEP.          16      -   1024     0  0.000   0.000 15937.

~192.168.128.10  192.168.128.7    4    862   1024   377  2.006  -1.532 19.759

~130.159.196.11  .STEP.          16      -   1024     0  0.000   0.000 15937.

*~2001:67C:288::128

                  195.220.94.163   2    703   1024   377 97.275   5.325 14.800

* sys.peer, # selected, + candidate, - outlyer, x falseticker, ~ configured

So apparently NTP works over native IPv6. I suppose connectivity (including access lists) is verified between the two devices .... try debug ntp packet and events.

Cheers

Fabio

Highlighted

HI fabios,

Thanks for your reply.

I was able to synchronize NTP when running dual stack. It was just that when i used native IPv6, it didn't work.

Not a single ACL configured.

Strange thing is that when i use IPv6 on server, (i.e. Master) it gets reference clock as some public IPv4 address and says synchronised, whereas I never configured that.

Unfortunaltely we have dismanteled tht setup. If i get a chance again, I will surely post the configs.

Regards,

Maulik

Content for Community-Ad
This widget could not be displayed.