ā02-10-2017 12:28 PM - edited ā03-08-2019 09:17 AM
Hello,
I'm using Cisco Packet Tracer 7.1 and trying to configure a port-channel. I am using two standard switches with two 1GB fiber interfaces on each switch. Here is my configuration:
version 12.1
no service timestamps log datetime msec
no service timestamps debug datetime msec
no service password-encryption
hostname
spanning-tree mode pvst
interface Port-channel 5
switchport mode trunk
interface FastEthernet0/1
interface FastEthernet1/1
interface FastEthernet2/1
interface FastEthernet3/1
interface GigabitEthernet4/1
switchport access vlan 5
switchport mode trunk
channel-protocol lacp
channel-group 5 mode active
interface GigabitEthernet5/1
switchport access vlan 5
switchport mode trunk
channel-protocol lacp
channel-group 5 mode active
interface Vlan1
no ip address
shutdown
line con 0
line vty 0 4
login
line vty 5 15
login
The problems I am having is that I have to manually do a no shut on the port-channel interface for it to show up, otherwise, it shows down. Once it is up it's fine, but if I power cycle the switches, again, it shows down and I have to manually turn it up. Any ideas why it's not coming up automatically?
Thank you!
-Jerry
Solved! Go to Solution.
ā02-10-2017 12:34 PM
Hi
You should remove these lines
interface GigabitEthernet4/1
switchport access vlan 5
switchport mode trunk
channel-protocol lacp
channel-group 5 mode active
interface GigabitEthernet5/1
switchport access vlan 5
switchport mode trunk
channel-protocol lacp
channel-group 5 mode active
A switchport cannot be access mode and trunk mode at the same time. Your port channel config is ok, try removing that.
:-)
ā02-10-2017 12:34 PM
Hi
You should remove these lines
interface GigabitEthernet4/1
switchport access vlan 5
switchport mode trunk
channel-protocol lacp
channel-group 5 mode active
interface GigabitEthernet5/1
switchport access vlan 5
switchport mode trunk
channel-protocol lacp
channel-group 5 mode active
A switchport cannot be access mode and trunk mode at the same time. Your port channel config is ok, try removing that.
:-)
ā02-10-2017 12:34 PM
Hi Julio,
Okay, I will try that Julio and let you know.
Thank you.
-Jerry
ā02-10-2017 12:37 PM
Great, thank you Jerry.
Not sure if on packet tracer can be executed this command to verify the status:
show etherchannel summary
:-)
ā02-10-2017 12:54 PM
I removed those lines, but no change. I did execute that command and it shows down;
po5 (SU)
ā02-10-2017 01:01 PM
I apologize! Typo, it should have read po5 (SD). However, once I rebooted the switches it came up automatically so that was it Julio!!! Thank you very much!
-Jerry
ā02-10-2017 01:06 PM
You are welcome
Have a great day
:-)
ā02-10-2017 01:06 PM
The Etherchannel should be up and running, because the following:
S = Layer 2
U = In Use
Flags:
Flags:
D - down
P - bundled in port-channel
I - stand-alone s - suspended
H - Hot-standby (LACP only)
R - Layer3 S - Layer2
U - in use
N - not in use, no aggregation
f - failed to allocate aggregator
M - not in use, minimum links not met
m - not in use, port not aggregated due to minimum links not met
u - unsuitable for bundling
w - waiting to be aggregated
d - default port
A - formed by Auto LAG
It should be working without any problem, you could remove the channel-protocol LACP because you already saying that you are using LACP when active (or passive) mode is configured.
:-)
ā02-10-2017 01:27 PM
Hi Julio,
Okay. I will do that too. Thank you again my friend for your help!
-Jerry
ā02-10-2017 01:31 PM
You are welcome Jerry, if any doubt arise we are here to assist you.
Have a happy weekend.
:-)
ā02-10-2017 01:36 PM
Everything is working perfectly.
You too Julio :-)
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide