cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

Community Helping Community

500
Views
0
Helpful
3
Replies
Highlighted
Beginner

Create a CTI Remote Device using AXL12.5

Hi Forum,

as I´m stuck, I´m opening this discussion.

 

I´m unable to create a Extend and Connect Device (CTI Remote Device) in CUCM using AXL. I´ve already noticed two discussions:

Here: https://community.cisco.com/t5/management/create-a-cti-remote-device-using-axl11-5/td-p/3587596

and here: https://community.cisco.com/t5/management/create-a-cti-remote-device-using-axl10/td-p/3554848

 

and both refer to this Bug: https://quickview.cloudapps.cisco.com/quickview/bug/CSCvd80348

 

My issue is that according to the bug notes, this issue should have been fixed in 12.0 .. I´m using CUCM 12.5 and it looks as it is still not fixed.

I´m getting the same CUCM error code 500 with:

 

Column specified more than once in the INSERT list.

 

My AXL query for testing with Postman looks like this:

 

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns="http://www.cisco.com/AXL/API/12.5">
   <soapenv:Header/>
   <soapenv:Body>
<ns:addPhone sequence="?">
 <phone>
   <name>CTIJDOE</name>
   <product>CTI Remote Device</product>
   <class>Phone</class>
   <protocol>CTI Remote Device</protocol>
   <protocolSide>User</protocolSide>
   <description>TEST DEVICE for JDOE</description>
 <callingSearchSpaceName>Device_CSS</callingSearchSpaceName>
   <devicePoolName>my_DP</devicePoolName>
   <locationName>my_LOC</locationName>
   <subscribeCallingSearchSpaceName>Subscribe_CSS</subscribeCallingSearchSpaceName>
   <rerouteCallingSearchSpaceName>Line_CSS</rerouteCallingSearchSpaceName>
   <ownerUserName>jdoe</ownerUserName>
   <mobilityUserIdName>jdoe</mobilityUserIdName>
   <lines>
    <line>
         <index>1</index>
         <label>John Doe</label>
     <display>John Doe</display>
     <displayAscii>John Doe</displayAscii>
         <dirn>
          <pattern>\+199996666</pattern>
          <routePartitionName>phones_PT</routePartitionName>
         </dirn>
        </line>
   </lines>
 </phone>
</ns:addPhone>
   </soapenv:Body>
</soapenv:Envelope>

I´ve tried several things .. but still get the same issue.

 

Thanks for any hint in advance.

 

Cheers

Torsten

 

3 REPLIES 3
Beginner

Re: Create a CTI Remote Device using AXL12.5

I tryed to add the Device without anything else than the requiered fields.
Used CUCM 12.5 and got the Error Code 5003 "Invalid value of Class" in return of this phone:

 

<phone>
<name>CTI_TEstAXL</name>
<product>CTI Route Point</product>
<model>CTI Route Point</model>
<class>CTI Route Point</class>
<protocol>SCCP</protocol>
<protocolSide>User</protocolSide>
<devicePoolName>DevPool</devicePoolName>
<commonPhoneConfigName>Standard Common Phone Profile</commonPhoneConfigName>
<locationName>Hub_None</locationName>
<useTrustedRelayPoint>Default</useTrustedRelayPoint>
<phoneTemplateName />
<builtInBridgeStatus>Off</builtInBridgeStatus>
<packetCaptureMode>None</packetCaptureMode>
<certificateOperation>No Pending Operation</certificateOperation>
<deviceMobilityMode>Default</deviceMobilityMode>
<allowMraMode>false</allowMraMode>
</phone>

This are all requiered parameters copyed from an getPhone return and only the name was changed.

It's not working, too.

Beginner

Re: Create a CTI Remote Device using AXL12.5

Hi Thedd,

I finally got it working, see my sample below; 

 

Header:

Content-Type -> text/xml
soapAction     -> CUCM:DB ver=12.5 addPhone

 

Body:

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:ns="http://www.cisco.com/AXL/API/12.5">
    <soapenv:Header/>
    <soapenv:Body>
		<ns:addPhone sequence="?">
		 <phone>
		   <name>CTIMMAUS</name>
		   <product>CTI Remote Device</product>
		   <class>Phone</class>
		   <model>CTI Remote Device</model>
		   <protocol>CTI Remote Device</protocol>
		   <protocolSide>User</protocolSide>
		   <description>FRA / DE / mindi.maus</description>
		   <callingSearchSpaceName>Device_CSS</callingSearchSpaceName>
		   <devicePoolName>FRA_DP</devicePoolName>
		   <locationName>FRA_LOC</locationName>
		   <subscribeCallingSearchSpaceName>Subscribe_CSS</subscribeCallingSearchSpaceName>
		   <rerouteCallingSearchSpaceName>Line_FRA-Intl_CSS</rerouteCallingSearchSpaceName>
		   <ownerUserName>mindi.maus</ownerUserName>
				   <lines>
				    <line>
				         <index>1</index>
				         <label>Mindi Maus</label>
				    	<display>Mindi Maus</display>
				    	<displayAscii>Mindi Maus</displayAscii>
				    	<busyTrigger>1</busyTrigger>
				    	<maxNumCalls>4</maxNumCalls>
				         <dirn>
				          <pattern>\+496999556633</pattern>
				          <routePartitionName>phones_PA</routePartitionName>
				         </dirn>
				        </line>
				   </lines>
		 </phone>
		</ns:addPhone>
    </soapenv:Body>
</soapenv:Envelope>

With that it works to insert the CTIRD.. but CUCM AXL is very picky on this dev-type..

 

Hope it works for you.

 

Cheers

Torsten

Beginner

Re: Create a CTI Remote Device using AXL12.5

Well great that it did work now but i would say this is not how it should be.

Why is the input different than the axl get output?

Strange behavior i did not have in prior AXL Versions.

CreatePlease to create content
Content for Community-Ad
FusionCharts will render here