cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1285
Views
0
Helpful
3
Replies

CUCM 12.5 AXL

Daniov1
Beginner
Beginner

Hi,
I am trying to create a new line using addLine (POST API) , one of the paramenter is enterprise alternate number.

When I create a new line i am using the following XML parameters:

 

<soapenv:Envelopexmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/"xmlns:ns="http://www.cisco.com/AXL/API/12.5">
  <soapenv:Header/>
  <soapenv:Body>
   <ns:addLine sequence="?">
    <line>

      <pattern>1590000</pattern>
      <useEnterpriseAltNum>true</useEnterpriseAltNum>
      <enterpriseAltNum>
      <numMask>XXXXXXX</numMask>
      <isUrgent>false</isUrgent>
      <addLocalRoutePartition>true</addLocalRoutePartition>
      <routePartition uuid="?">Global Learned Enterprise Numbers</routePartition>
      <advertiseGloballyIls>true</advertiseGloballyIls>
      </enterpriseAltNum>

     </line>
    </ns:addLine>
   </soapenv:Body>
</soapenv:Envelope>

 

The line was created successfully but without enterprise alternate number configuration.

I configured it menually and use getLine ,  I tried to use the returned value with addLine but enterprise alternate number was not configured.

image.png

 

Any suggest?

1 Accepted Solution

Accepted Solutions

dstaudt
Cisco Employee
Cisco Employee

Looking at the schema doc, there is a small note that seems to indicate that the *AltNum elements are applicable only on update operations.  Perhaps due to some internal quirk, the line must first be created before an alt num can be defined for  it?

Can you try first adding the line, and then performing a second updateLine operation providing the *AltNum fields?

View solution in original post

3 Replies 3

dstaudt
Cisco Employee
Cisco Employee

Looking at the schema doc, there is a small note that seems to indicate that the *AltNum elements are applicable only on update operations.  Perhaps due to some internal quirk, the line must first be created before an alt num can be defined for  it?

Can you try first adding the line, and then performing a second updateLine operation providing the *AltNum fields?

Hi,
Thanks for your reply.
This is about addLine not addPhone.
Do you mean that I need to create first the line and then update it with *altNum field?

Thanks.

Yes, sorry...I've updated my original comment to reflect line vs phone
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: