cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

Help getting started

haashoward
Beginner
Beginner

We are looking to pull the switchport info out of CER to be able to report on the ERLs.  Does anyone have a sample script for connecting and pulling switchport info our of CER?  We are using version 10.5.

2 REPLIES 2

Adam Pawlowski
VIP Advocate VIP Advocate
VIP Advocate

There's an API which will dump all that information in an XML format.

I have a script which is an utter mess to do some auditing work - but I use the Export function in CER to export Conventional ERL and Switchport data.

I have an external database where I track phone lines and street address data, as well as switchport data. On a linear basis, port-by-port, I go through, check each port, and compare that to my switchport data. If I have an ERL I will make sure an ELIN is assigned, and push that update to the phone line database. Switchport locations that change are noted, as well as new ERLs, and the whole thing batches out a couple of CSVs for me to import to CER.

The problem with this in CER is that it is not an interactive sort of things. You can't change ERL names once they are committed, or remove ELINs from them, only delete and re-import. But this logic lets me look and if I delete from CER I can re-run to audit, and obtain the missing information for import.

More or less I kept running into situations where ELINs were getting juggled around which is a massive pain in CER, as well not every update was being made, but, by funneling an export into this script I can let the computer do a stare and compare.

BTW the ERL name is not limited to 20 or 25 chars that it says when you look at the format information it is 50 characters on import, but, you can't key that much in through the UI, but they are case sensitive. All of these products let you introduce invisible characters to things if you are not careful which is also a good time.

I have absolutely no idea if you're checking this or not, but I came across this as I'm trying to get working on some CER API stuff myself. From the (relatively useless) API guide, the API is working when I run the GET authentication command, but anything else just fails. How are you resolving this? I've tried using curl -user with the username and SHA256 password (required as of 11.5) and then the address I want, but it still fails.

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: