cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
920
Views
5
Helpful
3
Replies

inter as vpnv4

Hello Folks,

In inter AS VPNV4 we will form a egbp vpnv4 neighbor relation ship.

In IOS XR what is the way to achieve it?

Am I correct going this way

route-policy EBGP (in both the routers)

pass

end-policy

commit

R1 (10.10.10.1)------------------------(10.10.10.2) R2

conf t                                                                 conf t

router bgp 1                                                       router bgp 10

neighbor 10.10.10.2                                        neighbor 10.10.10.1

remote-as 10                                                   remote-as 1

address-family vpnv4 uni                                 address-family vpnv4 uni

route-policy EBGP in                                      route-policy EBGP in

route-policy EBGP out                                     route-policy EBGP out                                    

exit-address-family                                           exit-address-family    

commit                                                                commit                                

Is ther any static route necessary here and if so then why?

I Will rate all helpful posts

Regards
Thanveer
"Everybody is genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is a stupid."       

1 Accepted Solution

Accepted Solutions

Mohammed Imran Khan
Cisco Employee
Cisco Employee

Hello Thanveer,

Just to add to Harold's answer, the IOS-XR doesn't automatically learn the directly connected "host" (/32) routes, hence you need a static route defining the "host" prefix. IOS does it automatically, XR doesn't.

In other words, label exchange can happen only if there is /32 route present, thats the reason we need it. :-)

HTH

Regards,

Imran

View solution in original post

3 Replies 3

Harold Ritter
Level 12
Level 12

Hi Thanveer,

Here's a rough working example:

r1 (gi0/0/0/0) <++++++++> (gi0/0/0/0) r2

r1:

!

interface GigabitEthernet0/0/0/0

ipv4 address 192.168.12.1 255.255.255.0

!

route-policy accept-all

  pass

end-policy

!

router static

address-family ipv4 unicast

  192.168.12.2/32 GigabitEthernet0/0/0/0

router bgp 1

mpls activate

  interface GigabitEthernet0/0/0/0

!

address-family vpnv4 unicast

  retain route-target all

!

neighbor 192.168.12.2

  remote-as 2

  address-family vpnv4 unicast

   route-policy accept-all in

   route-policy accept-all out

  !

!

r2:

!

interface GigabitEthernet0/0/0/0

ipv4 address 192.168.12.2 255.255.255.0

!

route-policy accept-all

  pass

end-policy

!

router static

address-family ipv4 unicast

  192.168.12.1/32 GigabitEthernet0/0/0/0

router bgp 2

mpls activate

  interface GigabitEthernet0/0/0/0

!

address-family vpnv4 unicast

  retain route-target all

!

neighbor 192.168.12.1

  remote-as 1

  address-family vpnv4 unicast

   route-policy accept-all in

   route-policy accept-all out

  !

!

Hope this helps

Harold Ritter
Sr Technical Leader
CCIE 4168 (R&S, SP)
harold@cisco.com
México móvil: +52 1 55 8312 4915
Cisco México
Paseo de la Reforma 222
Piso 19
Cuauhtémoc, Juárez
Ciudad de México, 06600
México

Mohammed Imran Khan
Cisco Employee
Cisco Employee

Hello Thanveer,

Just to add to Harold's answer, the IOS-XR doesn't automatically learn the directly connected "host" (/32) routes, hence you need a static route defining the "host" prefix. IOS does it automatically, XR doesn't.

In other words, label exchange can happen only if there is /32 route present, thats the reason we need it. :-)

HTH

Regards,

Imran

Thanks Harold and Imran.

Regards
Thanveer
"Everybody is genius. But if you judge a fish by its ability to climb a tree, it will live its whole life believing that it is a stupid."