cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3606
Views
0
Helpful
11
Replies
yuening liao
Beginner

LDP Error Message

Hello Everyone,

i ran the LDP on OSPF within BGP, both ospf and bgp connections were up. the loopback interfaces between two peers were also pingable each other. but LDP neighbor came never up. With Debug mpls ldp transport connection was following log output showed

*Mar  1 00:16:57.271: ldp: Opening ldp conn; adj 0x6514BEC8, 10.1.1.3 <-> 10.1.1.1; with normal priority
*Mar  1 00:16:57.279: ldp: MD5 setup for neighbor 10.1.1.1; password changed to [nil]
*Mar  1 00:16:57.283: ldp: Registered TCB with LDP TCB database tcb 0x64885614 [key 1017], total 2
*Mar  1 00:16:57.391: ldp: Conn failed (TCP activity)!; adj 0x6514BEC8, 172.14.8.5, tcb state 0x0
*Mar  1 00:16:57.395: ldp: Unregistered from LDP TCB database tcb 0x64885614 [key 1017], total 1
*Mar  1 00:16:57.395: ldp: Closing ldp conn 10.1.1.3:59945 <-> 10.1.1.1:646, adj 0x6514BEC8

anybody familiar with this case?

thank you very much in advance!

11 REPLIES 11
Reza Sharifi
Hall of Fame Expert

Hi,

It seems you have authentication enabled, if yes it has to be enabled on both sides.

disable the authentication and see if the neighbor comes up

post "sh mpls ldp dis"

also, have a look at this doc on how to configure LDP

http://www.cisco.com/en/US/docs/ios/12_4t/12_4t2/ftldp41.html#wp1354703

HTH

Reza

Hi Reza,

thank you for your reply,

R1(config)#do sh mpls ldp dis
Local LDP Identifier:
    10.1.1.1:0
    Discovery Sources:
    Interfaces:
        Ethernet0/0 (ldp): xmit
        Ethernet0/2 (ldp): xmit

R3(config)#do sh mpls ldp dis
Local LDP Identifier:
    10.1.1.3:0
    Discovery Sources:
    Interfaces:
        Ethernet0/0 (ldp): xmit
        Ethernet0/2 (ldp): xmit
R3(config)#

and i find no configuration but following commands concerning ldp on both devices:

ip cef

mpls label protocol ldp

interface Ethernet0/2
mpls ip

mpls ldp router-id Loopback0


R3#p 10.1.1.1 

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 10.1.1.1, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 32/41/60 ms
R3#