05-13-2010 08:01 AM
Hi,
I have to carry many few L2 circuits of same customer with a ME6524 as a uPE device. As SVI based EoMPLS is not possible on this device.
Can I do the following , (if yes, this solves the same purpose as SVI based EoMPLS).
I use vlan 200 for this customer & I assume MuxUNI support works well on Uplink port aswell. ( I know it works on Downlink port -- customer facing port)
int Gig 1
switchport mode access
Switchport access vlan 200
Int Gig 2
switchport mode access
Switchport access vlan 200
Int Gig 25
description << Uplink to MPLS cloud>>
mpls ip
ip address 1.1.1.1 255.255.255.0
Int Gig 25.200
encap dot1q 200
Xconnect 5.0.0.5 2000 encap mpls
Is it possible and any comment..Have anybody done this practically..
Thx,
gaurav
05-13-2010 08:48 AM
You can use port based EoMPLS on the ME6524
See example below..
ME3400a--dot1q--ME6524-A ---EoMPLS ----ME6524-b--dot1q--ME3400b
ME6524-A#sh run (fragments)
interface Loopback0
ip address 10.99.99.15 255.255.255.255
interface GigabitEthernet1/5
mtu 9216
no ip address
logging event link-status
logging event trunk-status
logging event spanning-tree status
logging event subif-link-status
load-interval 30
xconnect 10.99.99.11 15 encapsulation mpls
!
interface GigabitEthernet1/32
mtu 9216
ip address 10.99.98.64 255.255.255.254
logging event link-status
logging event trunk-status
logging event spanning-tree status
logging event subif-link-status
load-interval 30
mpls ip
!
router ospf 1
router-id 10.99.99.10
log-adjacency-changes
area 10 nssa
network 10.99.98.0 0.0.0.255 area 10
network 10.99.99.10 0.0.0.0 area 10
!
mpls ldp router-id Loopback0 force
ME6524-B#sh run (fragments)
interface Loopback0
ip address 10.99.99.11 255.255.255.255
!
interface GigabitEthernet1/5
mtu 9216
no ip address
logging event link-status
logging event trunk-status
logging event spanning-tree status
logging event subif-link-status
load-interval 30
xconnect 10.99.99.15 15 encapsulation mpls
!
interface GigabitEthernet1/32
mtu 9216
ip address 10.99.98.65 255.255.255.254
logging event link-status
logging event trunk-status
logging event spanning-tree status
logging event subif-link-status
load-interval 30
mpls ip
ME6524-A#sh mpls l2transport vc 15 detail
Local interface: Gi1/5 up, line protocol up, Ethernet up
Destination address: 10.99.99.11, VC ID: 15, VC status: up
Output interface: Gi1/32, imposed label stack {16}
Preferred path: not configured
Default path: active
Next hop: 10.99.98.65
Create time: 00:16:27, last status change time: 00:02:57
Signaling protocol: LDP, peer 10.99.99.11:0 up
MPLS VC labels: local 16, remote 16
Group ID: local 0, remote 0
MTU: local 9216, remote 9216
Remote interface description:
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 140, send 163
byte totals: receive 17640, send 21306
packet drops: receive 0, send 0
05-14-2010 03:30 AM
Thx,
But I need to keep the VC ID of the PWs same ( as they belong to same VPLS domain & same customer ), as there are multiple cirucits coming to this uPE, the only way I can do it to make the switchports mode access , and map it with same vlan id ( 200 in this case ).. now to take the traffic into MPLS cloud , I can ( NOT SURE ! ) xconnect the Layer 2 dot1q Subinterface of the uplink . The dot1q vlan id needs to be same as the customer i.e 200 ( in this case )..
I need to check if this idea works or not..
Thx,
Gaurav Prakash
05-14-2010 04:44 AM
In the configuration example above, the VC ID is the same on both sides.
So in your design you should have
CE1 (gi1/0/1 trunk vlan 200) --Gi1/0 subint dot1 V200) PE1 (ME6524)--- Xconnect--MPLS--xconnect--PE2 (ME6524)--- Gi1/0 subint dot1 V200)- (gi1/0/1 trunk vlan 200) CE2.
Hope to help
Francisco.
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide