cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
244
Views
0
Helpful
3
Replies

Migrating From Old 7600 to XR

TrivialPants
Level 1
Level 1

Hi All,

I am doing some testing for a migration from a 7604 MPLS PE with handoffs to a 7604 acting as an edge router. 

Each circuit on the PE router is just an untagged attachment circuit like this:
interface GigabitEthernet2/8
description MPLS Attachment Circuit for Customer
no ip address
no keepalive
xconnect <remote IP>  <vc ID> encapsulation mpls


The Handoff on PE attachment corresponds to a physical link between the MPLS router and the edge router:
They are co-located in the same data center. 

The handoff on the edge 7600 looks like this for the example customer above (it is just an access port into a VLAN). 

interface GigabitEthernet4/8
switchport
switchport mode access

switchport access vlan <vlan #>
end


The 'Edge' 7600 has interface VLANs which are the gateways for their respective subnets. 

There is a static route directed to a directly connected route for it upstream.




I wanted to get some feedback on my process:

I wanted to see about moving off of the transport/PE MPLS router first onto a new router. 
This would uplink to a trunk port on the current edge 7600 router with a different MPLS PE router that is running IOS XR. 

I plan to use subints with l2transport to differentiate traffic by VLANs that are on the trunk and then using an l2vpn bridge group I can have different pw-id pointed back through this one handoff to the edge router and consolidate them on to a single handoff versus a handoff-per circuit.

How does that sound?


The next issue I would need to tackle once I get the transport MPLS router moved is the issue of the int VLANs/gateway residing on the 7600. 

What ideas do you have about a floating gateway to help migrate that?






 

3 Replies 3

filopeter
Level 1
Level 1

I didn't understand the exact topology, but be careful with the bridge-domain/bridge-group usage. It requires "rewrite ingress tag pop 1 symmetric" to be configured under l2transport interface.
So at some point you might won't be able to distinguish traffic from different vlans (as vlan tags are popped before processing by the bridge-group) and you have to use hand-off per circuit.

Best Regards,

P.

TrivialPants
Level 1
Level 1

I will explain a bit more detail of how it is currently set up:

Customer CPE:

Untagged switch (but capable of management). Some customer locations have a management VLAN, but the data VLAN is untagged still. The trunk from the customer CPE uplinks to a remote MPLS PE that has an l2vpn that points back to the transport 7604 we are wanting to get rid of. 

 

[Customer CPE]                                  [Remote PE]
[1] [2] [3] [4 - trunk] <---------->     [Service instance 1 - encapuslation untagged -> xconnect to core transport 7600]
                                                          [Service instance 2 - encapsulation dot1q <management VLAN> rewrite ingress pop 1 symmetric to a local BDI for management]  

 

[Transport 7600 - one we are wanting to remove]

[no service instance, just vanilla xconnect, example below]

description MPLS Attachment Circuit for Customer
no ip address
no keepalive
xconnect <remote IP>  <vc ID> encapsulation mpls

 

[Edge Router - other 7604 which is slated for removal]
access ports that are one-to-one mapped from ports from the other 7604 to specify which VLAN untagged traffic needs to go to:

interface GigabitEthernet4/8
switchport
switchport mode access

switchport access vlan <vlan #>
end

 

 

filopeter
Level 1
Level 1

You can use backup pseudowire on the remote PE, which will be terminated on the new IOS XR router.

xconnect <remote IP> <vc ID> encapsulation mpls
backup peer <remote IP> <vc ID>

On the new IOS XR router you do not need to use bridge-domain/bridge-group, just p2p xconnect

interface TenGigE0/0/2/0.17 l2transport
description towards Edge Router
encapsulation dot1q 17
rewrite ingress tag pop 1 symmetric
!
l2vpn
xconnect group <>
p2p <>
interface TenGigE0/0/2/0.17
neighbor ipv4 <remote IP> pw-id <vc ID>

You can then switchover traffic from active to backup pseudowire and remove the Transport 7600.