cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
12869
Views
10
Helpful
23
Replies
Highlighted
Enthusiast

MPLS LDP Session not coming up

I have an LDP session configured over my P2P interface and it is not coming up . What can be the reason ? I can ping the P2P IP adddress

*************************

interface FastEthernet4/1

ip address 10.10.0.46 255.255.255.252

ip ospf network non-broadcast

ip ospf cost 10

mpls ip

Router #sh mpls ldp neighbor

*****************************************

interface GigabitEthernet3/4.1254

encapsulation dot1Q 1254

ip address 10.10.0.45 255.255.255.252

ip ospf network non-broadcast

ip ospf cost 10

mpls ip

Regards

Haris P

23 REPLIES 23
Highlighted

i reconfigure mpls ldp id ,but nothing happened !!!!!!!!!

no mpls ldp router-id Loopback1

mpls ldp router-id Loopback1

Regards

Highlighted

In the posted solutions i haven't seen where you actually confirmed that MPLS is indeed running on your tunnel interfaces

sh mpls interfaces will show you the current status of the attached interface.

MPLS int Config.png

This is a critical step before verifying any thing else along the path. If your tunnel interface is  displaying no or nothing under IP, run the command under the interface mpls ip  then secondly you can hard code mpls label protocol ldp if you find it fitting.

P.Williams
Highlighted

Harris,

  Replace the word Loopback1 with the IP Address /32 mask

Craig

Highlighted

there is no option to mpls ldp router-id to X.X.X.X with a /32 network mask , i have onkly the options below

Router1(config)#mpls ldp router-id ?

ATM ATM interface

Async Async interface

BVI Bridge-Group Virtual Interface

CDMA-Ix CDMA Ix interface

CTunnel CTunnel interface

Dialer Dialer interface

FastEthernet FastEthernet IEEE 802.3

Group-Async Async Group interface

Lex Lex interface

Loopback Loopback interface

MFR Multilink Frame Relay bundle interface

Multilink Multilink-group interface

Null Null interface

Port-channel Ethernet Channel of interfaces

Tunnel Tunnel interface

Vif PGM Multicast Host interface

Virtual-PPP Virtual PPP interface

Virtual-Template Virtual Template interface

Virtual-TokenRing Virtual TokenRing

XTagATM Extended Tag ATM interface

Highlighted

Harris,

Thanks, would you also issue sh mpls ldp discovery ?

Craig

Highlighted
Beginner

Harris,

  Please enter sh mpls interface

Craig

Highlighted

#sh mpls interfaces

Interface IP Tunnel Operational

FastEthernet4/1 Yes (ldp) No Yes

#sh mpls interfaces

GigabitEthernet3/4.325 Yes (ldp) No No No Yes

Highlighted

While pinging from R1 with 224.0.0.2 ,from R2 im getting reply but not vice versa

R1#ping 224.0.0.2

Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.0.0.2, timeout is 2 seconds:

Reply to request 0 from 10.10.0.45, 20 ms

SHDSL_GEF3#ping 224.0.0.2

Type escape sequence to abort.

Sending 1, 100-byte ICMP Echos to 224.0.0.2, timeout is 2 seconds:

Highlighted
Beginner

Just disable igmp snooping on the middle switches.

If you are having connection through switches then this solution can help to bring the LDP neighbor ship up immediately.