12-19-2006 04:29 PM
Hi Sir,
I'm doing a lab test on MPLS TE. Please see attached slides.
In Scenario 1, there's only a single link between R1 and R2. The TE tunnel from R3 to R1, traversing thru R2, is up & operational.
In Scenario 2, a new link is added between R1 and R2, with the same bandwidth value as the first link. Thus, producing equal-cost multipath between R1 and R2. On R3, I modify the ip explicit-path next-address to point to R1's TE router-id instead. And the TE tunnel goes down. Theoretically, I understand that we can point to either next-hop address or next-hop TE router-id.
Please advise what's the correct config for Scenario 2.
Thank you.
B.Rgds,
Lim TS
Solved! Go to Solution.
12-20-2006 06:25 PM
That seems to be right. Try it and let me know if it works for you.
Hope this helps,
12-19-2006 09:55 PM
Hi ,
When configuring the explicit path with next-hop as Router-id , use the loose option
next-address loose 172.18.255.2
If ur ios doesnt support , no other go , u need to go with the interface ip only.
Hope this helps
regards
vanesh k
12-19-2006 10:49 PM
Hi Vanesh,
Should I modify my config as follows:
!
ip explicit-path name path_to_R1 enable
next-address 172.18.253.5
next-address loose 172.18.255.2
!
Thank you.
B.Rgds,
Lim TS
12-19-2006 10:53 PM
Hi Lim,
Yes , pls do the same and let us know the result
regards
vanesh k
12-20-2006 02:38 AM
Hi Vanesh,
My problem description is not complete. In actual scenario, R3 has an alternative path to R1. And I'm implementing FRR link protection for the interface Fas0/0 on R3.
Back to my Scenario 2, if I were to implement FRR, would the following config work?
-----------------------------------------------------------------
!
hostname R3
!
interface Tunnel2
description *** TE Tunnel to R1 ***
ip unnumbered Loopback0
tag-switching ip
tunnel destination 172.18.255.2
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng autoroute announce
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng path-option 1 explicit name path_to_R1
tunnel mpls traffic-eng record-route
!
interface Tunnel20
description *** Backup TE Tunnel to R1 ***
ip unnumbered Loopback0
tag-switching ip
tunnel destination 172.18.255.2
tunnel mode mpls traffic-eng
tunnel mpls traffic-eng priority 1 1
tunnel mpls traffic-eng path-option 1 explicit name path_to_R1_backup
tunnel mpls traffic-eng record-route
!
interface FastEthernet0/0
mpls traffic-eng backup-path Tunnel20
!
ip explicit-path name path_to_R1 enable
next-address 172.18.253.5
next-address loose 172.18.255.2
!
ip explicit-path name path_to_R1_backup enable
exclude-address 172.18.253.5
exclude-address 172.18.255.2
!
-----------------------------------------------------------------
I'm not very sure about the configuration of the "exclude-address".
Please advise.
Thank you.
B.Rgds,
Lim TS
12-20-2006 03:58 AM
Hi Lim,
Iam not sure abt your complete topolgy , but if you want the TE tunnel to be made up on Loopback address , you need to give the loose option .
ip explicit-path name path_to_R1_backup enable
next-address loose 172.18.255.2
and ur igp running on the second link from R3 to R1 would take care .
Hope this helps
regards
vanesh k
12-20-2006 04:39 AM
Vanesh,
Just as a precision, the loose option only needs to be used if the next-address does not belong to a directly connected router. You could use all loopback addresses in your explicit path without using the loose option.
Hope this helps,
12-20-2006 03:02 PM
Hi Varesh,
For e.g. in Scenario 1, my usual practice of configuring TE with FRR is as follows:
---------------------------------------------------------------------
!
hostname R3
!
interface Tunnel2
description *** Primary TE Tunnel to R1 ***
tunnel destination 172.18.255.2
tunnel mpls traffic-eng path-option 1 explicit name path_to_R1
tunnel mpls traffic-eng fast-reroute
.
!
interface Tunnel20
description *** Backup TE Tunnel to R1 ***
tunnel destination 172.18.255.2
tunnel mpls traffic-eng path-option 1 explicit name path_to_R1_backup
.
!
ip explicit-path name path_to_R1 enable
next-address 172.18.253.5
next-address 172.18.253.14
!
ip explicit-path name path_to_R1_backup enable
exclude-address 172.18.253.5
exclude-address 172.18.253.14
!
---------------------------------------------------------------------
In the case of Scenario 2, if I have the following explicit-path config for the primary tunnel:
!
ip explicit-path name path_to_R1 enable
next-address 172.18.253.5
next-address loose 172.18.255.2
!
or what Harold suggested:
!
ip explicit-path name path_to_R1 enable
next-address 172.18.255.1
next-address 172.18.255.2
!
Then, how should I configure the explicit-path for the backup tunnel using the exclude-address command?
Please help.
Thank you.
B.Rgds,
Lim TS
12-20-2006 03:29 PM
Hi Varesh, Harold -
Attached is the complete network diagram. Please look at Scenario 3.
I'm building a primary TE tunnel from R3 to R1 via R2. The backup tunnel will go via R4.
I'm unsure about the configuration of the explicit-path for both primary & backup tunnels. From the info you all provided, the explicit-path for primary tunnel will be either one of the following config:
!
ip explicit-path name path_to_R1 enable ---> Suggested by Varesh
next-address 172.18.253.5
next-address loose 172.18.255.2
!
or
!
ip explicit-path name path_to_R1 enable ---> Suggested by Harold
next-address 172.18.255.1
next-address 172.18.255.2
!
I'm concerned about how to configure the explicit-path for backup tunnel, if I were to use exclude-address.
Please advise.
Thank you.
B.Rgds,
Lim TS
12-20-2006 05:24 PM
Lim,
My two other comments are still valid:
1- If you want tun2 to use FRR, you need to configure it specifically as follow:
interface Tunnel2
tunn mpls traffic-eng fast-reroute
2- For the FRR backup tunnel, the only thing you need to make sure is that you don't set it up using the physical link you are protecting as follow.
ip explicit-path name path_to_R1_backup enable
exclude-address 172.18.253.5
Hope this helps,
12-20-2006 06:00 PM
Hi Harold,
I do have the command "tunnel mpls traffic-eng fast-reroute" under interface Tunnel2 on the actual router. Somehow I forgot to include it in my post. Please excuse me.
So, I'll be configuring the following explicit-path on R3:
!
ip explicit-path name path_to_R1 enable
next-address 172.18.255.1
next-address 172.18.255.2
!
ip explicit-path name path_to_R1_backup enable
exclude-address 172.18.253.5
!
Is that right?
Thank you.
B.Rgds,
Lim TS
12-20-2006 06:25 PM
That seems to be right. Try it and let me know if it works for you.
Hope this helps,
12-20-2006 08:49 PM
Hi Harold,
I'm trying the config on some C3640 routers in a lab. Your suggestion for explicit-path configuration for the primary tunnel works; tunnel2 comes up. I can't test FRR because it's not supported on the C3640.
--------------------------------------------------
R3#sh mpls tra tu tu 2
Name: *** Primary TE Tunnel to R1... (Tunnel2) Destination: 172.18.255.2
Status:
Admin: up Oper: up Path: valid Signalling: connected
path option 1, type explicit path_to_R1 (Basis for Setup, path weight 65635)
path option 2, type dynamic
Config Parameters:
Bandwidth: 0 kbps (Global) Priority: 1 1 Affinity: 0x0/0xFFFF
Metric Type: TE (default)
AutoRoute: enabled LockDown: disabled Loadshare: 0 bw-based
auto-bw: disabled
InLabel : -
OutLabel : FastEthernet0/0, 19
RSVP Signalling Info:
Src 172.18.255.5, Dst 172.18.255.2, Tun_Id 2, Tun_Instance 5050
RSVP Path Info:
My Address: 172.18.255.5
Explicit Route: 172.18.253.5 172.18.253.54 172.18.255.2
Record Route:
Tspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
RSVP Resv Info:
Record Route: 172.18.253.5 172.18.253.54
Fspec: ave rate=0 kbits, burst=1000 bytes, peak rate=0 kbits
Shortest Unconstrained Path Info:
Path Weight: 65635 (TE)
Explicit Route: 172.18.253.5 172.18.253.54 172.18.255.2
History:
Tunnel:
Time since created: 1 days, 17 hours, 25 minutes
Time since path change: 19 minutes, 41 seconds
Current LSP:
Uptime: 19 minutes, 41 seconds
Selection: reoptimation
Prior LSP:
ID: path option 1 [5049]
Removal Trigger: path error
R3#
--------------------------------------------------
I'm implementing this on my customer network with C7609 routers. Will have to test FRR on the live network then. Will keep you posted.
Thank you.
B.Rgds,
Lim TS
12-21-2006 10:56 PM
Hi Harold,
Referring back to my lab test Scenario 3, a primary TE tunnel (int Tunnel2) is built from R3 to R1 via R2. FRR is used to protect the Fas0/0 link on R3, using backup Tunnel20.
Theoretically, when I execute the following commands on R3:
(1) sh ip route 172.18.255.2 - I should see it points to Tunnel2.
(2) sh mpls tra tu tu 2 - I should see Tunnel2 takes the path R3->R2->R1.
(3) sh mpls tra tu tu 20 - I should see Tunnel20 is pre-signalled and taking the path R3->R4->R1.
Is it right?
Interface Tunnel2 has only one path-option pointing to the explicit-path R2->R1.
If Fas0/0 is down on R3, when I do "sh ip route 172.18.255.2", should I see it points to Tu2 or Tu20?
In actual deployment and testing (with slightly different scenario than the lab), I notice the router still points to its primary tunnel (taking an alternative path this time to reach the tunnel tailend), when the protected link is down.
I'll elaborate on my actual scenario in another post. Hope you can help.
Thank you.
B.Rgds,
Lim TS
12-22-2006 07:16 AM
(1) Correct.
(2) Correct.
(3) Correct.
When Fa0/0 goes down, 172.18.255.2 should still point at Tu2. Tu20 simply provides Node/Link Protection.
Hope this helps,
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide