cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
821
Views
0
Helpful
1
Replies
eduardopozo56
Beginner

MPLS-ttl-disable not hiding link(?)

Hi guys, im reaching you because i have tried everything and nothing is working, here is the situation:

- We have implemented TE on our network, and everything was working fine before, we had Cisco 7600 equipment with Te tunnels using affinity, when we had a traceroute from CE to the internet, all hops were hidden and everything was fine

- In the past weeks, we upgraded our network to Cisco XR eqipment, and changed our TE scheme to work with path-options. We enabled mpls-ttl-disable on all our equipments but now we can see the Penultimate hop before leaving the network when we ping to the internet.

- I have tried disabling PHP outside TE with mpls ldp explicit null, also with mpls traffic-eng signaling explicit-null, and i see the pop labels change to explicit-null-v4 but still, the hop is not hiding.

Our tunnels go from PE to INT and backwards (All this happens inside a vrf which starts on the PE and ends at the INT)

Here i present a summary of the network and the  labels assigned by 1 tunnel:

Tun1.png

Tun2.png

(The 192.168.31.12/30 network  is the one showing on the trace)

LDP is enabled on all interfaces on the path


Example of Tunnel Configuration:

interface tunnel-te666

description OUTGOING

ipv4 unnumbered Loopback0

load-interval 30

autoroute announce

destination X.X.X.X (INT loopback)

record-route

path-option 10 explicit name path1

path-option 20 explicit name path2

!

interface tunnel-te6

description REVERSE

ipv4 unnumbered Loopback0

load-interval 30

autoroute announce

destination X.X.X.X (PE loopback)

record-route

path-option 10 explicit name path1

path-option 20 explicit name path2

!

We have some 7600 equipment and when using it with old configurations connected to new P's, the hop is shown, so i have narrowed it to some new configuration or bug on XR equipment

Any ideas?

Thanks in advance

1 REPLY 1
eduardopozo56
Beginner

Just fixed the issue,

     had to add the command: "icmp ipv4 source vrf" on XR Routers, seems like the ICMP response was being sourced through default vrf. This foreced the ICMP source and reply to be on the same vrf.

Content for Community-Ad