cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1526
Views
0
Helpful
1
Replies

Multicast vrf

eugene.fit
Beginner
Beginner

Good Day! I have got a task to play multicast traffic through mpls (at least between the same vrf). I have 3 switches 3750 ME, sw1, sw2 and sw3. Multicast source host is connected to sw3 int fa1/0/6, receiver host is connected to sw1 int fa 1/0/5, respectively. Both interfaces are in vlan 100 (just the same vlan number). Interface vlan is in vrf green. Switches are connected back to back sw1-sw2-sw3 via gigabit interfaces (dedicated for mpls) like ce1/pe1-p-pe2/ce2. In addition, sw1 and sw3 are rr-clients for sw2. To check multicast traffic I use multicasttest utility (http://www.mikkle.dk/multicasttest/). Multicast group address for test is 224.237.248.237. Multicast traffic walk from host 192.168.1.3 to 192.168.2.2. Also, there are vl 100 interfaces on switches in vrf green created just for check proper connectivity.

http://i071.radikal.ru/1108/08/2aa7112add5c.jpg

Configs:

hostname sw1
!
system mtu routing 1500
ip subnet-zero
ip routing
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.2.1
ip dhcp excluded-address 172.16.1.1
!
ip dhcp pool green1
   network 192.168.2.0 255.255.255.0
   default-router 192.168.2.1
  default-router 172.16.1.1
!
ip vrf green
rd 100:100
route-target export 100:100
route-target import 100:100
mdt default 232.1.1.1
!
ip multicast-routing distributed
ip multicast-routing vrf green distributed
!
interface Loopback0
ip address 10.1.1.1 255.255.255.255
ip pim sparse-dense-mode
ip ospf 1 area 0
!
interface Loopback100
ip vrf forwarding green
ip address 10.0.100.1 255.255.255.255
ip pim sparse-dense-mode
!
!
interface FastEthernet1/0/5
switchport access vlan 100
!
interface GigabitEthernet1/1/2
no switchport
ip address 10.0.1.2 255.255.255.0
ip pim sparse-dense-mode
ip ospf 1 area 0
speed auto 1000
mpls ip
!
interface Vlan100
ip vrf forwarding green
ip address 192.168.2.1 255.255.255.0
ip pim sparse-dense-mode
!
router ospf 1
log-adjacency-changes
!
router bgp 65001
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.2 remote-as 65001
neighbor 10.1.1.2 update-source Loopback0
no auto-summary
!
address-family ipv4 mdt
  neighbor 10.1.1.2 activate
  neighbor 10.1.1.2 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.1.1.2 activate
  neighbor 10.1.1.2 send-community extended
exit-address-family
!
address-family ipv4 vrf green
  no synchronization
  network 10.0.100.1 mask 255.255.255.255
  network 192.168.2.0
exit-address-family
!
ip classless

.........................................................................................

hostname sw2
!
system mtu routing 1500
ip subnet-zero
ip routing
!
ip vrf green
rd 100:100
route-target export 100:100
route-target import 100:100
mdt default 232.1.1.1
!
ip multicast-routing distributed
ip multicast-routing vrf green distributed
vtp mode transparent
!
interface Loopback0
ip address 10.1.1.2 255.255.255.255
ip pim sparse-dense-mode
ip ospf 1 area 0
!
interface GigabitEthernet1/1/1
no switchport
ip address 10.0.2.1 255.255.255.0
ip pim sparse-dense-mode
ip ospf 1 area 0
speed auto 1000
mpls ip
!
interface GigabitEthernet1/1/2
no switchport
ip address 10.0.1.1 255.255.255.0
ip pim sparse-dense-mode
ip ospf 1 area 0
speed auto 1000
mpls ip
!
router ospf 1
log-adjacency-changes
!
router bgp 65001
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.1 remote-as 65001
neighbor 10.1.1.1 update-source Loopback0
neighbor 10.1.1.1 route-reflector-client
neighbor 10.1.1.3 remote-as 65001
neighbor 10.1.1.3 update-source Loopback0
neighbor 10.1.1.3 route-reflector-client
no auto-summary
!
address-family ipv4 mdt
  neighbor 10.1.1.1 activate
  neighbor 10.1.1.1 send-community extended
  neighbor 10.1.1.3 activate
  neighbor 10.1.1.3 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.1.1.1 activate
  neighbor 10.1.1.1 send-community extended
  neighbor 10.1.1.1 route-reflector-client
  neighbor 10.1.1.3 activate
  neighbor 10.1.1.3 send-community extended
  neighbor 10.1.1.3 route-reflector-client
exit-address-family
!
address-family ipv4 vrf green
  no synchronization
exit-address-family
!
ip classless

.........................................................................................

hostname sw3
!
system mtu routing 1500
ip subnet-zero
ip routing
no ip dhcp conflict logging
ip dhcp excluded-address 192.168.1.1
!
ip dhcp pool green2
   network 192.168.1.0 255.255.255.0
   default-router 192.168.1.1
!
ip vrf green
rd 100:100
route-target export 100:100
route-target import 100:100
mdt default 232.1.1.1
!
ip multicast-routing distributed
ip multicast-routing vrf green distributed
vtp mode transparent
!
interface Loopback0
ip address 10.1.1.3 255.255.255.255
ip pim sparse-dense-mode
ip ospf 1 area 0
!
interface Loopback100
ip vrf forwarding green
ip address 10.0.100.3 255.255.255.255
ip pim sparse-dense-mode
!
interface FastEthernet1/0/6
switchport access vlan 100
!
interface GigabitEthernet1/1/1
no switchport
ip address 10.0.2.2 255.255.255.0
ip pim sparse-dense-mode
ip ospf 1 area 0
speed auto 1000
mpls ip
!
interface Vlan100
ip vrf forwarding green
ip address 192.168.1.1 255.255.255.0
ip pim sparse-dense-mode
!
router ospf 1
log-adjacency-changes
!
router bgp 65001
no synchronization
bgp log-neighbor-changes
neighbor 10.1.1.2 remote-as 65001
neighbor 10.1.1.2 update-source Loopback0
no auto-summary
!
address-family ipv4 mdt
  neighbor 10.1.1.2 activate
  neighbor 10.1.1.2 send-community extended
exit-address-family
!
address-family vpnv4
  neighbor 10.1.1.2 activate
  neighbor 10.1.1.2 send-community extended
exit-address-family
!
address-family ipv4 vrf green
  no synchronization
  network 10.0.100.3 mask 255.255.255.255
  network 192.168.1.0
exit-address-family
!
ip classless

-----------------------------------------------------------------------------------------

Пинги везде проходят (как между свитчами, так и между хостами)

sw1#ping vrf green 192.168.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms
sw1#ping vrf green 192.168.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
sw1#ping vrf green 224.237.248.237

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.237.248.237, timeout is 2 seconds:

Reply to request 0 from 192.168.2.1, 1 ms
Reply to request 0 from 10.0.100.1, 1 ms

.........................................................................................

sw3#ping vrf green 192.168.1.3

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.1.3, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/9 ms
sw3#ping vrf green 192.168.2.2

Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 192.168.2.2, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 1/2/8 ms
sw3#ping vrf green 224.237.248.237

Type escape sequence to abort.
Sending 1, 100-byte ICMP Echos to 224.237.248.237, timeout is 2 seconds:

Reply to request 0 from 192.168.1.1, 1 ms
Reply to request 0 from 10.0.100.3, 1 ms

-----------------------------------------------------------------------------------------

I can see I pim neighbors in global table, but cat’s see them in vrf green. I think the problem is here.

sw1#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.0.1.1          GigabitEthernet1/1/2     20:25:44/00:01:43 v2    1 / S P

sw2#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.0.2.2          GigabitEthernet1/1/1     20:25:57/00:01:22 v2    1 / DR S P
10.0.1.2          GigabitEthernet1/1/2     20:25:58/00:01:19 v2    1 / DR S P

sw3#sh ip pim neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
10.0.2.1          GigabitEthernet1/1/1     20:26:13/00:01:35 v2    1 / S P

.........................................................................................

sw1#sh ip pim vrf green neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
sw1#

sw3#sh ip pim vrf green neighbor
PIM Neighbor Table
Mode: B - Bidir Capable, DR - Designated Router, N - Default DR Priority,
      P - Proxy Capable, S - State Refresh Capable
Neighbor          Interface                Uptime/Expires    Ver   DR
Address                                                            Prio/Mode
sw3#

-----------------------------------------------------------------------------------------

mroute in vrf:

sw1#sh ip mroute vrf green 224.237.248.237
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.237.248.237), 02:50:33/00:02:56, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Vlan100, Forward/Sparse-Dense, 02:50:33/00:00:00

sw3#sh ip mroute vrf green 224.237.248.237
IP Multicast Routing Table
Flags: D - Dense, S - Sparse, B - Bidir Group, s - SSM Group, C - Connected,
       L - Local, P - Pruned, R - RP-bit set, F - Register flag,
       T - SPT-bit set, J - Join SPT, M - MSDP created entry,
       X - Proxy Join Timer Running, A - Candidate for MSDP Advertisement,
       U - URD, I - Received Source Specific Host Report,
       Z - Multicast Tunnel, z - MDT-data group sender,
       Y - Joined MDT-data group, y - Sending to MDT-data group
       V - RD & Vector, v - Vector
Outgoing interface flags: H - Hardware switched, A - Assert winner
Timers: Uptime/Expires
Interface state: Interface, Next-Hop or VCD, State/Mode

(*, 224.237.248.237), 02:48:36/00:02:25, RP 0.0.0.0, flags: DCL
  Incoming interface: Null, RPF nbr 0.0.0.0
  Outgoing interface list:
    Vlan100, Forward/Sparse-Dense, 02:48:36/00:00:00

-----------------------------------------------------------------------------------------

sw1#mstat
VRF name: green
Source address or name: 192.168.2.1
Destination address or name: 192.168.1.3
Group address or name: 224.237.248.237
Multicast request TTL [64]:
Response address for mtrace:
Type escape sequence to abort.
Mtrace from 192.168.2.1 to 192.168.1.3 via group 224.237.248.237 in VRF green
From source (?) to destination (?)
Waiting to accumulate statistics....* * *
Timeout on first trace.

sw3#mstat
VRF name: green
Source address or name: 192.168.1.1
Destination address or name: 192.168.1.3
Group address or name: 224.237.248.237
Multicast request TTL [64]:
Response address for mtrace:
Type escape sequence to abort.
Mtrace from 192.168.1.1 to 192.168.1.3 via group 224.237.248.237 in VRF green
From source (?) to destination (?)
Waiting to accumulate statistics......
Results after 10 seconds:

  Source        Response Dest   Packet Statistics For     Only For Traffic
192.168.1.1     192.168.1.1     All Multicast Traffic     From 192.168.1.1
     |       __/  rtt 0    ms   Lost/Sent = Pct  Rate     To 224.237.248.237
     v      /     hop 0    ms   ---------------------     --------------------
192.168.1.1     ?
     |      \__   ttl   0
     v         \  hop 0    ms        0         0 pps           0    0 pps
192.168.1.3     192.168.1.1
  Receiver      Query Source

I hope I have shown all necessary configs, outputs and schemes to make the picture clear. Other outputs I can show on demand. Thanks in advance.

1 Reply 1

mgaitond
Beginner
Beginner

Hi Evgeny

Unfortunately the multicast VPN feature is not supported on the 3750 ME platform even though the commands are present . This is also mentioned in Cisco Feature Navigator. There are no plans to implement this on this platform.

Thanks

Mayuresh

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: