cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
729
Views
0
Helpful
2
Replies

Multiple customers and Central services using a single router.

rahul.narsing
Level 1
Level 1

Dear All,

I have a Single provider router. I have 4 customers with 2 sites each. All sites connect to the internet using a common VRF.

The internet is connected to interface Ethernet 0/0.

Customer 1 -----> Ethernet 1/1-2

Customer 2 -----> Ethernet 2/1-2

Customer 3 -----> Ethernet 3/1-2

Customer 4 -----> Ethernet 4/1-2.

Please refer to the configuration below.

vrf definition group1
rd 1:1
route-target export 1:1
route-target import 1:1
route-target import 1:100
!
address-family ipv4
exit-address-family
!
vrf definition group2
rd 1:2
route-target export 1:2
route-target import 1:2
route-target import 1:100
!
address-family ipv4
exit-address-family
!
vrf definition group3
rd 1:3
route-target export 1:3
route-target import 1:3
route-target import 1:100
!
address-family ipv4
exit-address-family
!
vrf definition group4
rd 1:4
route-target export 1:4
route-target import 1:4
route-target import 1:100
!
address-family ipv4
exit-address-family
!
vrf definition internet
rd 1:100
route-target export 1:100
route-target import 1:100
route-target import 1:1
route-target import 1:2
route-target import 1:3
route-target import 1:4
!
address-family ipv4
exit-address-family

!

interface Ethernet0/0
vrf forwarding internet
ip address dhcp
ip nat outside
!
interface Ethernet1/1
vrf forwarding group1
ip address 192.168.10.254 255.255.255.0
!
interface Ethernet1/2
vrf forwarding group1
ip address 192.168.20.254 255.255.255.0
!
interface Ethernet2/1
vrf forwarding group2
ip address 192.168.10.254 255.255.255.0
!
interface Ethernet2/2
vrf forwarding group2
ip address 192.168.20.254 255.255.255.0
!
interface Ethernet3/1
vrf forwarding group3
ip address 192.168.10.254 255.255.255.0
!
interface Ethernet3/2
vrf forwarding group3
ip address 192.168.20.254 255.255.255.0
!

interface Ethernet4/1
vrf forwarding group4
ip address 192.168.10.254 255.255.255.0
!
interface Ethernet4/2
vrf forwarding group4
ip address 192.168.20.254 255.255.255.0
!

Point is I am not able to route packets from the customer vrf into the internet vrf for internet connectivity.

Router#sh ip route vrf group1

192.168.10.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.10.0/24 is directly connected, Ethernet1/1
L 192.168.10.254/32 is directly connected, Ethernet1/1
192.168.20.0/24 is variably subnetted, 2 subnets, 2 masks
C 192.168.20.0/24 is directly connected, Ethernet1/2
L 192.168.20.254/32 is directly connected, Ethernet1/2

How to I get to display the E0/0 route into the customer rotuing table so that I can provide a default route towards my provider.

Thanks in Advance.

2 Replies 2

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Rahul,

in each vrf definition you need to import the 0/0 route from VRF Internet you can achieve this by addimng the line

route-target import 1:100

under EACH customer VRF definition

Hope to help

Giuseppe

Ever sort this out?