cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2674
Views
0
Helpful
10
Replies
Highlighted
Enthusiast

not able to ping in l2 xconnect

Dears ,

I'm trying to configure an xconnect between two of my PE routers and the VC showing up but i can't ping the hosts in the other side of VLAN .Any Clues ?

#sh mpls l2transport vc detail

Local interface: Gi6/0.23 up, line protocol up, Eth VLAN 23 up

  Destination address: 172.21.15.1, VC ID: 23, VC status: up

    Next hop: 172.21.11.1

    Output interface: Gi6/0.101, imposed label stack {78}

  Create time: 02:41:12, last status change time: 00:25:17

  Signaling protocol: LDP, peer 172.21.15.1:0 up

    MPLS VC labels: local 133, remote 78

    Group ID: local 0, remote 0

    MTU: local 1500, remote 1500

My config is as given below and my ios is slot0:c7200-p-mz.123-24.bin

pseudowire-class test

encapsulation mpls

interface GigabitEthernet6/0.23

encapsulation dot1Q 23

xconnect 172.21.15.1 23 pw-class test

regards

Haris P

10 REPLIES 10
Highlighted
Beginner

- You use the same vlan at both of 2 sites or use vlan rewrite feature ?

- What source ip add did you use to ping the hosts at the other sites ?, were they in the same subnet ?

Highlighted

You use the same vlan at both of 2 sites or use vlan rewrite feature ?

i use both side same vlan ..how do  i use vlan rewrie feature never tried this

- What source ip add did you use to ping the hosts at the other sites ?, were they in the same subnet ?

yes they were in same subnet

Highlighted

hi

please check the config

http://www.mplsvpn.info/2011/12/implementation-of-eompls-ethernet-over.html

vlan rewrite feature is not used by all the platforms. Please let us know which platform you are using.

regards

shivlu jain

Highlighted

Try this

interface GigabitEthernet6/0.23

encapsulation dot1Q 23

xconnect 172.21.15.1 23 encapsulation mpls pw-class test

Highlighted

not working also with the commands you specified , im seeing thatVC is up , but under statitics packets receive 0 ,send 0

pseudowire-class test
encapsulation mpls

interface GigabitEthernet0/3.102
encapsulation dot1Q 102
no cdp enable
xconnect 10.101.0.1 102 encapsulation mpls pw-class test

Output interface: Fa2/0, imposed label stack {298 3502}
Create time: 00:26:06, last status change time: 00:01:06
Signaling protocol: LDP, peer 10.101.0.1:0 up
MPLS VC labels: local 143, remote 3502
Group ID: local 4, remote 5
MTU: local 1500, remote 1500
Remote interface description: test
Sequencing: receive disabled, send disabled
VC statistics:
packet totals: receive 0, send 0
byte totals: receive 0, send 0
packet drops: receive 0, send 0

Highlighted
Beginner

It looks like, you haven't configured right on the Trunk inteface.. X-connect seems to be working just fine but no input packets came through the sub interface..

For test propused, you might x-connect the whole Gigabit Interface by moving the xconnect on the major interface.

Are you trying with a switch connected on the Gi6/0?

Highlighted

In both ends my hosts are connected in acces ports and the PE is connected to trunk port of the switch . it is as shown below

In fact i tried configuring an IP in the same range of the PC on my router dot1Q interface and i was able to ping the host on that side without any problem ,so i dont think that it is not a connectivity issue

PC1...Access vlan 102 ...switch ........trunk......Switch.......trunk.....PE1-------------------PE2....trunk.....switch....trunk....Access switch.

regards

Haris

Highlighted

http://www.cisco.com/en/US/docs/ios/12_0s/feature/guide/fsatom28.html#wp1047206

You xconnect config seems to be just fine.... and for 7200 you don't need to set remote id number for xconnect.

In my opinion it seems strange that dont hane not even one packet in on the subinterface.

You should at least have input packets from you switch ... and dropped after.

Please have in mind that xconnect passthough layer 2 BPDUs in 7200, which means tha CDP should see an VLAN mismatch and PerVlan Spanning Tree most likely to error disable the port, since it receive BPDU with different Vlan ID.

Highlighted
Beginner

Try to check the mtu
I saw that the out interface is fast and the gige interface is ingress

Can you please send us the ldp binding ?

You can also do some debug to see where the problem


Sent from Cisco Technical Support Android App

Highlighted

The below is my debugs .... I'm not seeing any STP passing through the switches thru the l2 xconnect , both side switches as root for the VLANs 102....running me crazy !!

Dec  5 18:27:25.202: AToM MGR [10.101.0.1, 102]: Event ldp down, state changed

from established to local standby

Dec  5 18:27:25.202: AToM MGR [10.101.0.1, 102]: Remote end down, vc is down

Dec  5 18:27:25.202: AToM SMGR [10.101.0.1, 102]: Processing imposition update

, vc_handle 502B2BC0, update_action 0, remote_vc_label 84

Dec  5 18:27:25.202: AToM SMGR [10.101.0.1, 102]: Imposition Disabled

Dec  5 18:27:25.202: AToM SMGR [10.101.0.1, 102]: Processing disposition updat

e, vc_handle 502B2BC0, update_action 0, local_vc_label 172

Dec  5 18:27:25.202: AToM MGR [10.101.0.1, 102]: Event local up, state changed

from local standby to local standby

Dec  5 18:27:25.202: AToM MGR [10.101.0.1, 102]: Take no action

Dec  5 18:27:25.202: AToM SMGR: TFIB scan started

Dec  5 18:27:25.214: AToM SMGR: TFIB scan complete

Dec  5 18:27:28.914: AToM SMGR: Processing TFIB event for 10.101.0.1

Dec  5 18:27:32.066: %LDP-5-NBRCHG: LDP Neighbor 172.16.12.6:0 (1) is UP

Dec  5 18:27:32.142: AToM SMGR: Processing TFIB event for 10.101.0.1

Dec  5 18:27:32.854: %LDP-5-NBRCHG: LDP Neighbor 10.101.0.1:0 (2) is UP

Dec  5 18:27:32.858: AToM MGR [10.101.0.1, 102]: Event ldp up, state changed f

rom local standby to local ready

Dec  5 18:27:32.858: AToM MGR [10.101.0.1, 102]: Advertise local vc label bind

ing

Dec  5 18:27:32.970: AToM MGR [10.101.0.1, 102]: Event remote up, state change

d from local ready to establishing

Dec  5 18:27:32.970: AToM MGR [10.101.0.1, 102]: Remote end up

Dec  5 18:27:32.974: AToM MGR

[10.101.0.1, 102]: Event remote validated, state

changed from establishing to established

Dec  5 18:27:32.974: AToM MGR [10.101.0.1, 102]: Validate vc, activating data

plane

Dec  5 18:27:32.974: AToM SMGR [10.101.0.1, 102]: Processing imposition update

, vc_handle 502B2BC0, update_action 3, remote_vc_label 84

Dec  5 18:27:32.974: AToM SMGR [10.101.0.1, 102]: Imposition Programmed, Outpu

t Interface: Gi0/1

Dec  5 18:27:32.974: AToM SMGR [10.101.0.1, 102]: Processing disposition updat

e, vc_handle 502B2BC0, update_action 3, local_vc_label 172

Dec  5 18:27:32.990: AToM SMGR: Processing TFIB event for 10.101.0.1

Dec  5 18:27:32.990: AToM SMGR [10.101.0.1, 102]: Imposition Programmed, Outpu

t Interface: Gi0/1