cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2749
Views
10
Helpful
7
Replies

PBR with mpls bgp send-label

mila008.is
Beginner
Beginner

Hi

I have problem with transition my network to mpls, PBR doesnt work after I enter the command BGP neighbour send-label.

my configs:

interface Vlanxxx
mtu 1560
ip address 1.1.1.1 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
ip pim sparse-mode
ip policy route-map PBR
load-interval 30
mpls bgp forwarding
mpls label protocol ldp
mpls ip
!

ip access-list extended PRIVATE-NETS-1
permit ip 10.0.0.0 0.255.255.255 2.2.2.2 0.0.1.255
permit ip 3.3.3.3 0.0.31.255 4.4.4.4 0.0.1.255
!

route-map PBR permit 25
match ip address PRIVATE-NETS-1
set ip next-hop 5.5.5.5

Anybody know this problem? Thx.

2 Accepted Solutions

Accepted Solutions

Hi Elena,

there is not enough info to answer this question.

To which BGP neighbor do you send label? Is it reachable via which interface?

A blind guess would be that traffic received on the first vlan comes in labeled therefore cannot match the IP ACL.

But you need to tell us which type of traffic comes in, if IP or MPLS.

Cheers,

Riccardo

View solution in original post

Hi Elena,

Policy based routing (PBR) is not supported for MPLS labeled traffic. The labels prevent the IP lookup to occur.

PBR is supported on VRF interfaces for the IP traffic that comes in through that interface. The support for this

started with CSCdu70318. Perhaps you could move the PBR to a preceeding router, where the traffic is still IP traffic

and not yet labeled?

Best regards,

Luc

View solution in original post

7 Replies 7

Ivan Krimmel
Rising star
Rising star

Hi Elena,

pease add 'set mpls-label' statement under PBR route-map.

interface where this traffic should go not running mpls, traffic doesnt have mpls tags

interface Vlanxxx

ip address 5.5.5.6 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

ip pim sparse-mode

load-interval 30

end

route-map PBR permit 25
match ip address PRIVATE-NETS-1
set ip next-hop 5.5.5.5

nice catch, didn't noticed that.

Hi Elena,

there is not enough info to answer this question.

To which BGP neighbor do you send label? Is it reachable via which interface?

A blind guess would be that traffic received on the first vlan comes in labeled therefore cannot match the IP ACL.

But you need to tell us which type of traffic comes in, if IP or MPLS.

Cheers,

Riccardo

mila008.is
Beginner
Beginner

mpls labels come in via interface

interface Vlanxxx
mtu 1560
ip address 1.1.1.1 255.255.255.252
no ip redirects
no ip unreachables
no ip proxy-arp
ip pim sparse-mode
ip policy route-map PBR
load-interval 30
mpls bgp forwarding
mpls label protocol ldp
mpls ip
!

and interface

interface Vlanxxx

ip address 5.5.5.6 255.255.255.252

no ip redirects

no ip unreachables

no ip proxy-arp

ip pim sparse-mode

load-interval 30

end

doesnt run mpls

how i can change ip routing info with "IP" PBR in mpls-labeled traffic in this case?

Hi Elena,

Policy based routing (PBR) is not supported for MPLS labeled traffic. The labels prevent the IP lookup to occur.

PBR is supported on VRF interfaces for the IP traffic that comes in through that interface. The support for this

started with CSCdu70318. Perhaps you could move the PBR to a preceeding router, where the traffic is still IP traffic

and not yet labeled?

Best regards,

Luc

Thanks for ur reply,  Luc

I think u r right, and i ll try to adapt my network for this feature

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers