cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
959
Views
0
Helpful
1
Replies

PE SVI ports in VPLS needed?

I'm trying to get my head around the exact operation of VPLS configuration on PE routers whereby, according to the MPLS Fundamentals Guide, to add a CE facing port to a given VFI instance you should use an SVI as follows:

hostname VPLS-PE-1
!
mpls label protocol ldp
mpls ldp router-id Loopback0 force
!
l2 vfi cust-one manual
 vpn id 1
 neighbor 10.100.100.2 encapsulation mpls
 neighbor 10.100.100.3 encapsulation mpls
!
interface FastEthernet4/2
 no ip address
 switchport
 switchport access vlan 111
 spanning-tree bpdufilter enable
!
interface POS5/1
 ip address 10.10.1.1 255.255.255.0
 mpls ip
 mls qos trust dscp
!
interface Vlan111
 no ip address
 xconnect vfi cust-one

But is there any reason why this has to be an SVI interface? I am about to lab this but thought I would pose the question, to make sure I am on the right track... is there any reason why I can't do this for Fa4/2 and just forget about using VLAN 111 and its SVI?


interface FastEthernet4/2
 no ip address
 xconnect vfi cust-one

 

1 Reply 1

Giuseppe Larosa
Hall of Fame
Hall of Fame

Hello Steven,

we have just deployed a network for a customer where we used the l2vpn vfi new syntax on ME-3600-X.

We have still a command that connects the SVI to the VFI but it has become member vfi 

modern syntax on ME-3600-X:

mpls label protocol ldp
l2vpn
logging pseudowire status
router-id 192.168.246.25
!
l2vpn vfi context COMPLESSO-CAVALLI-GEOSCENZE
vpn id 100100101
autodiscovery bgp signaling ldp
vpls-id 65001:100100101
rd 65001:100100101
route-target export 65001:100100101
route-target import 65001:100100101
!

interface GigabitEthernet0/1
description *** COMPLESSO CAVALLI - GEOSCENZE ***
switchport trunk allowed vlan none
switchport mode trunk
service instance 10 ethernet
encapsulation default
l2protocol forward
service-policy input SetDSCP
!
!

+

bridge-domain 101
member GigabitEthernet0/1 service-instance 10
!

+

interface Vlan101
no ip address
member vfi COMPLESSO-CAVALLI-GEOSCENZE
!

As you see there is still the need to link the VPLS l2vpn vfi object to the SVI.

So I don't think you will be successful with your tests.

Hope to help

Giuseppe