cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
4963
Views
5
Helpful
6
Replies

setting BGP route preference on a multihomed edge router

Chad Parish
Level 1
Level 1

We are consolidating our two single-homed WAN edge routers into one multi-homed edgerouter.  We currently have a dedicated edge router for each ISP configured for eBGP and EIGRP.  We handle Primary ISP route preference by configuring the bgp to eigrp route redistribution with a lower delay on the edge router going to our preferred ISP.  But when we multihome from a single edge router, how would I do this?

6 Replies 6

thecrev
Level 1
Level 1

I'm not sure what type of edge router you're using, but you'd normally do this with bgp routing policies.

 

To send all of your upload traffic through a preferred ISP, you'd set an inbound policy on the link connected to the preferred ISP, which applies a local preference to a number higher than the default (500 is usually fine).

 

To receive all of your download traffic through a preferred ISP, you'd set an outbound policy on the link connected to the non-preferred ISP, which prepends your AS number at least 1 time.

lresp
Level 1
Level 1
 

lespejel
Level 3
Level 3

Hello @Chad Parish

 

I'd suggest to use weight, if your criteria is just administrative with no other parameters to keep in mind (AS Path or something else), then weight is your option.

 

According to BGP best path selection algorithm weight is the first criteria, the most important and it will override local preference or AS path, so if you apply an inbound policy setting a highest weight for prefixes learned from a particular neighbor, then that prefix will be considered better and it will be a local policy (on this router), different from local preference because if you set a value, it will be advertised to your iBGP peers.

 

Now, from your explanation, you are redistributing both routes right? and then selecting best one from EIGRP best metric. When using one router you will redistribute just one prefix with the highest weight, and if this becomes unavailable, the second NRLI will take its place and it will be advertised into EIGRP domain.

 

This scenario could be similar to have iBGP peering when using 2 routers and redistributing just one route with next hop without changes, there are multiple possibilities.

CCIE 52804

Hello


@Chad Parish wrote:

We are consolidating our two single-homed WAN edge routers into one multi-homed edgerouter.  We currently have a dedicated edge router for each ISP configured for eBGP and EIGRP.  We handle Primary ISP route preference by configuring the bgp to eigrp route redistribution with a lower delay on the edge router going to our preferred ISP.  But when we multihome from a single edge router, how would I do this?


Still a bit vague as to what you are doing now interns of roue preference.
You don't say what routes you are receiving from the each ISP -  If your presently LB between the two ISPs or just using one for a backup?

Are you adverting a default into your IGP or a default and specific routes?

Basically for a single WAN rtr peering with two different ISP rtrs you could for egress traffic utilize bgp weight preference between each ISP and for ingress you could use as-path pre-pending,.

Can you elaborate a bit more on your actual design interms of route manipulation, possibly post some information your currently topology.


Please rate and mark as an accepted solution if you have found any of the information provided useful.
This then could assist others on these forums to find a valuable answer and broadens the community’s global network.

Kind Regards
Paul

Thanks Paul, sorry to have been vague.  As it turns out I think the Dual homed WAN scenario for our MPLS network has been worked out.  We have 2 MPLS networks provided by 2 ISPs for redundancy between our sites.  We use an active/standby approach preferring one ISP's network over the other.  I achieved the desired result using the Weight attribute to prioritize one ISP's network over the other.

 

However, a week later I tried something similar with our DIA (inet) networks, in which we also have two ISP's.  I took an ISR 4331 and confifigured it to multihome out to both DIA providers.  No NAT is required on the router as we simply advertise our public IP subnet with the ASA behind that router handling the NAT chores.  

The problem is that when I configure the BGP portion of the config, I get this message after placing the neighbor IP/ remote-as statement for the second ISP...

 

%BGP-3-BGP_SRTE_FAILURE: BGP SRTE failed to register with TE - Restarting BGP may be required

 

I also had to roll back after my console connection started showing lots of crazy code scrolling across my screen that ultimate locked me out and caused the router to reboot.  I am wondering if this was caused by a routing loop or perhaps had something to do with improperly configure the scheduler allocate command.

 

It looked like prior to the router going nuts, that I did see eBGP to both ISP's establish.  Wondering if the issue is that the ISP's were both advertising too much for the router to handle and maybe I need them to just advertise their PE IP and I then set a pair of static default routes (setting the static pointing to the secondary ISP as a floating static route)?  This would allow me to get rid of the inbound as-path filtering.

 

Below is my config...

 

ip cef
!
interface GigabitEthernet0/0/0
description ISP1
ip address 110.150.100.68 255.255.255.252
media-type rj45
!
interface GigabitEthernet0/0/1
description LAN-SWITCH
ip address 72.111.141.2 255.255.255.0
ip accounting output-packets
speed 1000
duplex full
media-type rj45
!
interface GigabitEthernet0/1/0
description ISP2
ip address 214.16.18.90 255.255.255.252
media-type rj45
!
router bgp 64444
bgp log-neighbor-changes
neighbor 214.16.18.89 remote-as 3356
neighbor 110.150.100.67 remote-as 46887
!
address-family ipv4
neighbor 214.16.18.89 activate
neighbor 214.16.18.89 send-community both
neighbor 214.16.18.89 weight 100
neighbor 214.16.18.89 route-map ISP2localout out
neighbor 214.16.18.89 filter-list 30 in
neighbor 214.16.18.89 soft-reconfiguration inbound
neighbor 110.150.100.67 activate
neighbor 110.150.100.67 send-community both
neighbor 110.150.100.67 remote-as 46887
neighbor 110.150.100.67 weight 200
neighbor 110.150.100.67 route-map ISP1localout out
neighbor 110.150.100.67 filter-list 40 in
neighbor 110.150.100.67 soft-reconfiguration inbound
no auto-summary
no synchronization
network 214.16.18.88 mask 255.255.255.252
network 110.150.100.66 mask 255.255.255.252
exit-address-family
!
address-family nsap
maximum-paths 2
no synchronization
exit-address-family
!
ip bgp-community new-format
!
ip as-path access-list 10 permit ^$
ip as-path access-list 20 permit ^701$
ip as-path access-list 30 deny ^3356_46887_.*
ip as-path access-list 30 permit .*
ip as-path access-list 40 deny ^46887_3356_.*
ip as-path access-list 40 permit .*
!
no ip http server
no ip http secure-server
!
no cdp run
!

ip prefix-list localstat permit 72.111.141.0/24

!

route-map ISP1localout out permit 10
match ip address prefix-list localstat
set community 46887:70

!
route-map ISP2localout out permit 10
match ip address prefix-list localstat
set community 3356:70
!
!
scheduler allocate 20000 1000
!
end

 

 

 

hello @Chad Parish

That error message looks like a next hop issue; anyway, you have to change addressing for one neighbor, /30 goes in 4 IP addresses blocks, so it should go from 110.150.100.64 to .67/30, and from 110.150.100.68 to .71/30; then your interface is using network address and your neighbor is located in a different subnet broadcast address, therefore the next hop issue since it's not directly connected.

!
interface GigabitEthernet0/0/0
description ISP1
ip address 110.150.100.68 255.255.255.252
media-type rj45
!

router bgp 64444
bgp log-neighbor-changes
neighbor 214.16.18.89 remote-as 3356
neighbor 110.150.100.67 remote-as 46887
!

And I still suggest to use weight to influence outbout traffic in a single multihomed router, that's the easiest way.

CCIE 52804
Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: