cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
779
Views
5
Helpful
2
Replies

SR-TE load balancing

sachin30720041
Level 1
Level 1

Hello,

 

I am trying to understand SR-TE load balancing.

 

R1-----R2----R3

 \                      /

    \.             /

       \.     /

         R4

I have created an SR-TE policy on R2 and R4 pointing to each other.

R2 has a loopback 22.22.22.22

R4 has a loopback 44.44.44.44

There is static path on R2 pointing to R4's loopback.

ip route 44.44.44.44 255.255.255.255 segment-routing policy pol1
There is a static path on R4 pointing to R2's loopback
ip route 22.22.22.22 255.255.255.255 segment-routing policy pol1
 
When I ping from R4(44.44.44.44) to R2(22.22.22.22) I expect a few packets should take R4->R1->R2 and a few packets should go through R4->R3->R2 because of the load balancing. But I am seeing all the packets are taking the same path        R4->R1->R2. Is it the expected behavior? How can I see if load balancing is really happening ?
 
R1
---------------------
hostname r1
segment-routing mpls
connected-prefix-sid-map
address-family ipv4
1.1.1.1/32 index 1 range 1
exit

int gi2
ip address 100.10.40.1 255.255.255.0
ip router isis 1
isis network point-to-point
no sh

int gi1
ip address 100.10.20.1 255.255.255.0
ip router isis 1
isis network point-to-point
no sh

int lo0
ip address 1.1.1.1 255.255.255.255

router isis 1
router-id lo0
distribute link level-2
net 49.0001.1111.1111.1111.00
distribute link-state
is-type level-2
metric-style wide
segment-routing mpls
passive-interface lo0
advertise passive-only
mpls traffic-eng router-id lo0
mpls traffic-eng level-2



R2
------------------------
hostname r2
segment-routing mpls
connected-prefix-sid-map
address-family ipv4
2.2.2.2/32 index 2 range 1
exit
exit

int gi1
ip address 100.10.20.2 255.255.255.0
ip router isis 1
isis network point-to-point
no sh

int gi2
ip address 100.20.30.2 255.255.255.0
ip router isis 1
isis network point-to-point
no sh

int lo0
ip address 2.2.2.2 255.255.255.255

int lo1
ip address 22.22.22.22 255.255.255.255

router isis 1
router-id lo0
net 49.0002.2222.2222.2222.00
is-type level-2
metric-style wide
segment-routing mpls
passive-interface lo0
advertise passive-only
mpls traffic-eng router-id lo0
mpls traffic-eng level-2

segment-routing traffic-eng
segment-list name seg1
index 10 mpls label 16001
index 20 mpls label 16004

segment-list name seg2
index 10 mpls label 16003
index 20 mpls label 16004
 
policy pol1
color 20 end-point 4.4.4.4
candidate-paths
preference 100
explicit segment-list seg1 weight 100
 
explicit segment-list seg2 weight 100
 
segment-routing mpls

ip route 44.44.44.44 255.255.255.255 segment-routing policy pol1
R3
------------------------
segment-routing mpls
connected-prefix-sid-map
address-family ipv4
3.3.3.3/32 index 3 range 1
exit
exit

int gi2
ip address 100.20.30.3 255.255.255.0
ip router isis 1
isis network point-to-point
no sh

int gi1
ip address 100.30.40.3 255.255.255.0
ip router isis 1
isis network point-to-point
no sh

int lo0
ip address 3.3.3.3 255.255.255.255

router isis 1
router-id lo0
net 49.0003.3333.3333.3333.00
is-type level-2
metric-style wide
segment-routing mpls
passive-interface lo0
advertise passive-only
mpls traffic-eng router-id lo0
mpls traffic-eng level-2

R4
-----------------------

int gi2
ip address 100.10.40.4 255.255.255.0
ip router isis 1
isis network point-to-point
no sh

segment-routing mpls
connected-prefix-sid-map
address-family ipv4
4.4.4.4/32 index 4 range 1
exit
exit

int gi1
ip address 100.30.40.4 255.255.255.0
ip router isis 1
isis network point-to-point
no sh

int lo0
ip address 4.4.4.4 255.255.255.255

int lo1
ip address 44.44.44.44 255.255.255.255

router isis 1
router-id lo0
net 49.0004.4444.4444.4444.00
is-type level-2
metric-style wide
segment-routing mpls
passive-interface lo0
advertise passive-only
mpls traffic-eng router-id lo0
mpls traffic-eng level-2

segment-routing traffic-eng
segment-list name seg1
index 10 mpls label 16001
index 20 mpls label 16002

segment-list name seg2
index 10 mpls label 16003
index 20 mpls label 16002
 
 

policy pol1
color 20 end-point 2.2.2.2
candidate-paths
preference 100
explicit segment-list seg1 weight 100
 
explicit segment-list seg2 weight 100
 
segment-routing mpls

ip route 22.22.22.22 255.255.255.255 segment-routing policy pol1
1 Accepted Solution

Accepted Solutions

Remember LB 3 or 7 tuple, can you create another loopback or configure a secondary IP address so that you can try ping with several sources. it should be balanced.

View solution in original post

2 Replies 2

follow

Remember LB 3 or 7 tuple, can you create another loopback or configure a secondary IP address so that you can try ping with several sources. it should be balanced.