cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
302
Views
0
Helpful
1
Replies
ChrisGflys3D
Beginner

Trouble testing Single-home EVPN over MPLS on the ASR920

Hi All,

 

I am trying to get a lab working featuring ASR920-12CZ-A's for my work. We have successful deployments of EVPN on IOS-XR based machines in production. I am using the configs off of these as well as the config guide here:

https://www.cisco.com/c/en/us/td/docs/routers/asr920/configuration/guide/mpls/17-1-1/b-mp-l2-vpns-xe-17-1-asr920/b-mp-l2-vpns-xe-17-1-asr920_chapter_01101.html

 

What I want to do is get an EVPN POC lab up so we can use the config that produces good results to deploy PE ASR920's in production that are capable of PE EVPN services. 

 

However I am having trouble getting any traffic to pass... Just trying to get a couple old switches to ping across on their SVIs as a POC.

 

I've done some debugging and found that while the Bridge-Domain's pick up the local MAC addresses just fine and advertise them through to the other side. The ASRs are not picking the MAC routes out of their BGP table and applying them to the Bridge-Domains. I've gone through the config guide many times and just can't figure out what I'm missing.

 

I've attached a photo of my topology diagram as well as my configs. Any help would be greatly appreciated. 

 

920EPVNlabTopology.jpg

 

Thanks!

1 REPLY 1
ChrisGflys3D
Beginner

In case anybody was interested it turns out we are the first people in the world trying to use ASR920's as an EVPN PE, the TAC guy I've been working with has not seen anybody do this and there is nothing in their internal knowledgebase for doing this on the ASR920.

 

This specific issue is a bug the dev team ran into with 17.2, which was never released for the 920 platform, and was supposed to be fixed for 17.3.

 

I'll update the post as we go, hopefully they find a fix soon and this helps others out also.

Content for Community-Ad