Showing results for 
Search instead for 
Did you mean: 

cisco acs version % error reading directory on remote server



I am having problem viewing the contents of our patch repository on an sftp server. I will need to install a cumulative patch from the remote sftp repository at some point.


I patched using the same sftp repository folder back in June and had to recreate the repository and run the command

I've recreated a repository called patch using the command line and also ran:


 Acs/admin# crypto host_key add host  ip_address_of_sftpserver


I see the correct response similar to this from the Cisco 5.5  CLI pdf

host key fingerprint added
# Host acs found: line 1 type RSA
2048 dd:df:e9:2f:4b:6f:cb:95:4e:47:0f:3a:a4:36:43:98 (RSA)


In June this solved my problem and I could read  / install patch files.

But, this time the command is not resolving the problem, I still get      % error reading directory on remote server

Running Acs/admin#show crypto host_keys     shows me that I have a key e.g 2048 dd:df:e9:2f:4b:6f:cb:95:4e:47:0f:3a:a4:36:43:98 (RSA)


Is there another command to try or is it possible the password for our sftp user account has timed out/ ACS box has been denied access to the sftp folder?



3 Replies 3

Level 1
Level 1

Hi Stuart

There is a known bug:

CSCtt47076    ACS fails to validate SFTP credentials if password is longer 16 chars


so, ensure that the SFTP user password is <=16 characters.


Also, use the IP address of SFTP server instead of hostanme in hostname coulumn.


In the Repository that you have created on ACS, Try using Ip address for example:

           sftp://    instead of  s


See if that helps!!



Minakshi(Do rate the helpful post)


The crypto host_key add host  ip_address_of_sftpserver from my original post had worked.

I was using a VM Sphere console to access the CLI on the ACS appliance this time which refuses stfp.

If I use a Putty.exe conncetion from a terminal server (which I must have done in June), then I can read the sftp folder on the terminal server from the ACS command line.

This is a satisfactory work around for now, although I know Putty connections are not used on our other clients, so at some point i will have to use sftp from a VM Sphere console.





i had the same issue

re-adding the host_key did not fix it for me.

i was also using vsphere console

then i used putty per your post and worked. this is very weird but it works


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: