cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements

This community is for technical, feature, configuration and deployment questions.
For production deployment issues, please contact the TAC! We will not comment or assist with your TAC case in these forums.
Please see How to Ask the Community for Help for other best practices.

1306
Views
15
Helpful
2
Replies
bthuer
Beginner

Problem with upgrading ACS 5.1 to 5.2

I upgraded my CSACS 1121 from ACS 5.1 to 5.2 following exactly the official upgrade guides. 

1st step:Backing-up the acs-config using the CLI cmd "acs backup filename repository tftp_server" (filename on TFTP server = acs_hau_02_20101005-101005-0810.tar.gpg ---> successful

2nd step: Reimaging ACS ---> successful

3rd step: Restoring ACS config from TFTP server with "acs restore filename repository tftp_server" ---> successful (the ACS process itself stopped)

4th step: Checking status of ACS services by doing "show application status acs" ---> not successful ---> Status remains "Application initializing..."

When checking the logfile "acsupgrade.log" I get errors like "Error in file "/opt/CSCOacs/view/data/sql/stopdb.sql" at line 2"

I even tried to restore the config on a ACS running ACS 5.1 but unfortunately got exactly the same error.

Any reply is very much appreciated.

Roman   

2 REPLIES 2
Federico Lovison
Cisco Employee

Hi Roman,

The error seems to lead to a DB issue on the "view" data, so the logging database.

Given that you see the problem both in ACS 5.1 and 5.2 it may be that the DB backup is corrupted.

I would not recommend TFTP to backup/restore the ACS DB as I saw in the past problems where a big backup file as the ACS one can be truncated if the TFTP server doesn't support file tranfers bigger than 32MB.

You can confirm if this suspect is correct by checking the size of the file.

If this suspect is confirmed, I'm afraid that you should use a different backup file (if you have a working one).

On the other hand, if that doesn't seem to be the case I would suggest to open a TAC Service Request to further investigate this.

Thank you!

Regards,

Federico

Hi Frederico,

first of all: many thanks for your reply. I found the problem by myself some days ago and you're pointing with your remarks exactly in the same direction. I checked the logfiles - I'm backing up the configs on a scheduled basis via FTP but restored them via TFTP which led to the mentioned problems (ACS processes not starting up again).

I them reoladed the file using FTP and everything was just fine.

So many thanks again and have a nice day

Best regards

Roman

Content for Community-Ad