cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
430
Views
0
Helpful
4
Replies

Basic router configuration

tafa
Beginner
Beginner

Hello I am new in the networking and I am trying to configure my Cisco 888 router with 4xL2 ports. So I need to conect it to my ISPs modem and access internet. I can ping 8.8.8.8 but I am missing something to have an internet access.Thanks in advance.

 

Router#ping 8.8.8.8
Type escape sequence to abort.
Sending 5, 100-byte ICMP Echos to 8.8.8.8, timeout is 2 seconds:
!!!!!
Success rate is 100 percent (5/5), round-trip min/avg/max = 12/14/16 ms
Router#show run
Building configuration...

Current configuration : 2037 bytes
!
! Last configuration change at 18:53:51 UTC Sun Sep 4 2022
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
!
!
!
!
!
!


!
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.2.1
!
ip dhcp pool Vlan 10
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
ip dhcp pool Vlan 20
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 8.8.8.8
!
!
!
ip cef
no ipv6 cef
!
!
!
!
!
multilink bundle-name authenticated
!
!
!
!
!
!
!
!
cts logging verbose
license udi pid C888-K9 sn FCZ222410TN
!
!
!
!
!
!
!
controller SHDSL 0
!
!
!
!
!
!
!
!
!
!
!
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface FastEthernet0
switchport mode trunk
no ip address
!
interface FastEthernet1
switchport access vlan 10
no ip address
!
interface FastEthernet2
switchport access vlan 20
no ip address
!
interface FastEthernet3
no ip address
!
interface Vlan1
ip address dhcp
ip nat outside
ip virtual-reassembly in
!
interface Vlan10
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Vlan20
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
!
ip nat inside source list 1 interface FastEthernet0 overload
!
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
!
control-plane
!
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
!
!
!
!
!
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
!
!
end

2 Accepted Solutions

Accepted Solutions

markanderson
Beginner
Beginner

Hi 
You can watch this video that will help you to set up your router.
https://www.youtube.com/watch?v=FfPJ_dvM_is

View solution in original post

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

make the changes marked in bold:

Current configuration : 2037 bytes
!
! Last configuration change at 18:53:51 UTC Sun Sep 4 2022
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.2.1
!
ip dhcp pool Vlan 10
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
ip dhcp pool Vlan 20
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 8.8.8.8
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
cts logging verbose
license udi pid C888-K9 sn FCZ222410TN
!
controller SHDSL 0
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface FastEthernet0
switchport mode trunk
no ip address
!
interface FastEthernet1
switchport access vlan 10
no ip address
!
interface FastEthernet2
switchport access vlan 20
no ip address
!
interface FastEthernet3
no ip address
!
interface Vlan1
ip address dhcp
ip nat outside
ip virtual-reassembly in
!
interface Vlan10
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Vlan20
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
--> ip nat inside source list 1 interface Vlan1 overload
!
--> ip route 0.0.0.0 0.0.0.0 Vlan1 dhcp
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
!
control-plane
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end

View solution in original post

4 Replies 4

markanderson
Beginner
Beginner

Hi 
You can watch this video that will help you to set up your router.
https://www.youtube.com/watch?v=FfPJ_dvM_is

Kasun Bandara
VIP Advisor VIP Advisor
VIP Advisor

your LAN configuration seems like ok. also you need to configure WAN interface which connecting to your ISP device. configure ISP provided ip address for that interface and configure NAT as @markanderson shared with you.

Please rate this and mark as solution/answer, if this resolved your issue
Good luck
KB

Georg Pauwen
VIP Master VIP Master
VIP Master

Hello,

make the changes marked in bold:

Current configuration : 2037 bytes
!
! Last configuration change at 18:53:51 UTC Sun Sep 4 2022
!
version 15.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname Router
!
boot-start-marker
boot-end-marker
!
no aaa new-model
!
ip dhcp excluded-address 192.168.1.1
ip dhcp excluded-address 192.168.2.1
!
ip dhcp pool Vlan 10
network 192.168.1.0 255.255.255.0
default-router 192.168.1.1
dns-server 8.8.8.8
!
ip dhcp pool Vlan 20
network 192.168.2.0 255.255.255.0
default-router 192.168.2.1
dns-server 8.8.8.8
!
ip cef
no ipv6 cef
!
multilink bundle-name authenticated
!
cts logging verbose
license udi pid C888-K9 sn FCZ222410TN
!
controller SHDSL 0
!
interface BRI0
no ip address
encapsulation hdlc
shutdown
isdn termination multidrop
!
interface FastEthernet0
switchport mode trunk
no ip address
!
interface FastEthernet1
switchport access vlan 10
no ip address
!
interface FastEthernet2
switchport access vlan 20
no ip address
!
interface FastEthernet3
no ip address
!
interface Vlan1
ip address dhcp
ip nat outside
ip virtual-reassembly in
!
interface Vlan10
ip address 192.168.1.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
interface Vlan20
ip address 192.168.2.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
ip forward-protocol nd
no ip http server
no ip http secure-server
!
--> ip nat inside source list 1 interface Vlan1 overload
!
--> ip route 0.0.0.0 0.0.0.0 Vlan1 dhcp
!
access-list 1 permit 192.168.1.0 0.0.0.255
access-list 1 permit 192.168.2.0 0.0.0.255
!
control-plane
!
mgcp behavior rsip-range tgcp-only
mgcp behavior comedia-role none
mgcp behavior comedia-check-media-src disable
mgcp behavior comedia-sdp-force disable
!
mgcp profile default
!
line con 0
no modem enable
line aux 0
line 2
no activation-character
no exec
transport preferred none
transport input all
stopbits 1
line vty 0 4
login
transport input none
!
scheduler allocate 20000 1000
!
end

tafa
Beginner
Beginner

Thank you all. You just saved my day. Thank you!!!

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers