Showing results for 
Search instead for 
Did you mean: 

Change Device Identity Fails

Zoran BKV
Level 1
Level 1

Hello all,

in my LMS 4.1 I have 10 2960S 48 FPS-L switches, which have originally been added into "Cisco Catalyst 2960 Stack" LMS group.

After I try to change identity of those switches in "Add/Import/Manage Devices" and move them into correct device group (Cisco Catalyst 2960S 48 FPS-L Switch) everything looks fine at the first moment. New device group with that name has been added and can be seen.

After couple of minutes this group just dissapears and switches are moved back into "Cisco Catalyst 2960 Stack" device container.

Same thing happens when I move 24 Port switches into corresponding group.

As you can see bellow for example the "Cisco Catalyst 2960S 24 PS-L Switch" device group is missing and "Cisco Catalyst 2960S 48 FPS-L Switch" device group contains only 1 instead of 10 devices.

Kind Regards2013-07-04_10h03_47.png

1 Accepted Solution

Accepted Solutions

On 2960/3750 switches by default the returned sysobjectid type is a stack-OID (.1208). To return the OID corresponding to the specific switch type enter the configuration command "no snmp-server sysobjectid type stack-oid", then the switch will use its per-device sysObjectID (e.g. the sysObjectID for a 2960-48FPS-L).  When this happens, LMS will recognize the switch as exactly what it is.


-Thanks Vinod **Rating Encourages contributors, and its really free. **

View solution in original post

14 Replies 14

Vinod Arya
Cisco Employee
Cisco Employee

When you go to "Add/Import/Manage Devices"select the device and click on edit identity. There on top-right you would see the product platform and name, click on select and correct it from there and apply.

Than the device should come to correct Family group automatically.


-Thanks Vinod **Rating Encourages contributors, and its really free. **

Dear Vinod Arya,

thank you for your fast reply.

That is exactly what I have been doing. After I do that I can see my device in the new group. After couple of minutes the group is just missing and device is in it's origin container.

I just did it one more time - added device to new group-device can bee seen on Pic1. Refreshed the page and device is missing - moved to origin container.

Kind Regards

From device centre do a snmpwalk on this device for sysObjectID and share its details. Did you restated the daemons once?

Forget the device having issue, randomly select any device and make changes and see if it persist. Share the output of NMSROOT/bin/pdshow from server as well.


-Thanks Vinod **Rating Encourages contributors, and its really free. **

I have tried this on 15 devices and the problem persists.

Here the SNMP Walk form one device

SNMP Walk Output



. = OID : .

Output of pdshow:

@echo off

if "%1" == "/?" goto usage

if "%1" == "-brief" goto check

if  "%1" == "" goto showall

set target=%1



if "%1"=="" goto last

set target=%target% %1

goto sample1


"pdcmd.exe" -s "%target%"

goto exit


if "%2" == "" goto showbriefall

set mytarget=%2




if "%1"=="" goto end

set mytarget=%mytarget% %1

goto sample


"pdcmd.exe" -i "%mytarget%"

goto exit


"pdcmd.exe" -I

goto exit


"pdcmd.exe" -S

goto exit


echo pdshow -- Display daemons status

echo usage: pdshow [daemon ...]

echo pdshow -brief -- Display brief daemons status

echo usage: pdshow brief [daemon ...]


pdshow is a utlity which gives you output of processes state. so you need to run NMSROOT/bin/pdshow as an executable, than share the output what it produces.

-Thanks Vinod **Rating Encourages contributors, and its really free. **

I'm sorry, I'm not familiar in this part of LMS.

I've run it but the window is being automatically closed. Is output being stored somewhere else?

Thank you for your help

Seems the SysObjectID of this device # is for Cisco Catalyst 2960S Stack Module(WS-C2960S STACK) and hence it is correcting itself to this device.



-Thanks Vinod **Rating Encourages contributors, and its really free. **

I'm not sure why would it be correcting itself? These are standalone devices, not stacked ones.

I have exactly same switch which is in the correct container, not correcting itself.

Is there anyway to change the SysObjectID manually?


SysObjectID is coded into system and can't be changed on device. But ideally once you have selected a device it should not change automatically.

Can you please check for any other random device to confirm if behaves similarly or it stays with the change.

Please restart the daemon manager as well.

-Thanks Vinod **Rating Encourages contributors, and its really free. **

Other devices are functioning without issues.

The problem seems to be with Catalyst 2960S switches.

We have 2960S 48 FPS-L and 2960S 24 PS-L switches and they all have the oid of "stack device" which means they are all being moved into same container.

I have tried changing identities on all of these switches. As already said, new devices containers are being created with devices in it. After refreshing the page containers are gone and devices are back in the "stack" container.

I will restart the server and try it again.

Best Regards and thanks for your kind support

Seems in screenshot you refer to your device # sw_muc2_06. Please share show version from this device as well.

Also, please try to chnage this device not as a Cisco Catalyst 2960S-48FPS-L Switch, but to anything in a different platform say a 2900, 2940 or a 2950 or anything which it is not to see if it changes back to the group and share result of the test.


-Thanks Vinod **Rating Encourages contributors, and its really free. **