02-01-2020 01:38 PM
Hi everybody,
I'm trying to configure my Cisco 1113 to work with italian TIM Vdsl2 FTTC. Unfortunatly it doesn't work and I'm trying to find where the problem is.
First of all, here are the requirements of the ISP (TIM):
- Vdsl2 with spectrum between 8b and 17a. 35b is also adviced.
- Retransmission (ITU-T G.998.4)
- Vectoring ( ITU-T G.993.5)
- SRA (ITU-T G.993.2)
- USERNAME: timadsl
- PASSWORD: timadsl
- PROTOCOL: PPPoE Routed (RFC 2516)
- ENCAPSULATION: PTM
- NAT: active
- VLAN: 835
And here is how I set my running config:
hostname Router
!
boot-start-marker
boot-end-marker
!
!
!
no aaa new-model
!
!
!
!
login on-success log
!
!
!
!
!
!
!
subscriber templating
multilink bundle-name authenticated
!
!
!
!
!
license udi pid C1113-8P sn FCZ2343C2X0
!
diagnostic bootup level minimal
!
spanning-tree extend system-id
!
!
!
redundancy
mode none
!
controller VDSL 0/2/0
!
!
vlan internal allocation policy ascending
!
!
!
!
!
!
interface GigabitEthernet0/0/0
no ip address
negotiation auto
!
interface GigabitEthernet0/1/0
!
interface GigabitEthernet0/1/1
!
interface GigabitEthernet0/1/2
!
interface GigabitEthernet0/1/3
!
interface GigabitEthernet0/1/4
!
interface GigabitEthernet0/1/5
!
interface GigabitEthernet0/1/6
!
interface GigabitEthernet0/1/7
!
interface ATM0/2/0
no ip address
atm oversubscribe factor 2
no atm enable-ilmi-trap
!
interface Ethernet0/2/0
no ip address
no negotiation auto
!
interface Ethernet0/2/0.835
encapsulation dot1Q 835
ip nat inside
pppoe enable group global
pppoe-client dial-pool-number 1
!
interface Vlan1
no ip address
!
interface Dialer1
ip nat outside
encapsulation ppp
dialer pool 1
ppp authentication pap chap callin
ppp chap hostname timadsl
ppp chap password 0 timadsl
ppp pap sent-username timadsl password 0 timadsl
ppp ipcp dns request accept
!
ip forward-protocol nd
no ip http server
ip http secure-server
ip route 0.0.0.0 0.0.0.0 Dialer1
!
!
!
!
!
!
control-plane
!
!
line con 0
transport input none
stopbits 1
line vty 0 4
login
!
!
!
!
!
!
end
It seems the interface goes up and down such as a loop:
%DIALER-6-BIND: Interface Vi2 bound to profile Di1
%LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
%DIALER-6-UNBIND: Interface Vi2 unbound from profile Di1
%LINK-3-UPDOWN: Interface Virtual-Access2, changed state to down
If it could be useful, this is the debug of ppp negotiation:
*Feb 1 21:19:48.817: %DIALER-6-BIND: Interface Vi2 bound to profile Di1
*Feb 1 21:19:48.819: %LINK-3-UPDOWN: Interface Virtual-Access2, changed state to up
*Feb 1 21:19:48.820: Vi2 PPP: Sending cstate UP notification
*Feb 1 21:19:48.820: Vi2 PPP: Processing CstateUp message
*Feb 1 21:19:48.821: PPP: Alloc Context [7F694F53A0]
*Feb 1 21:19:48.821: ppp78 PPP: Phase is ESTABLISHING
*Feb 1 21:19:48.821: Vi2 PPP: Using dialer call direction
*Feb 1 21:19:48.821: Vi2 PPP: Treating connection as a callout
*Feb 1 21:19:48.821: Vi2 PPP: Session handle[1200004F] Session id[78]
*Feb 1 21:19:48.821: Vi2 LCP: Event[OPEN] State[Initial to Starting]
*Feb 1 21:19:48.821: Vi2 PPP: No remote authentication for call-out
*Feb 1 21:19:48.821: Vi2 LCP: O CONFREQ [Starting] id 1 len 14
*Feb 1 21:19:48.821: Vi2 LCP: MRU 1492 (0x010405D4)
*Feb 1 21:19:48.822: Vi2 LCP: MagicNumber 0xF9C09D5D (0x0506F9C09D5D)
*Feb 1 21:19:48.822: Vi2 LCP: Event[UP] State[Starting to REQsent]
*Feb 1 21:19:48.828: Vi2 LCP: I CONFREQ [REQsent] id 202 len 18
*Feb 1 21:19:48.828: Vi2 LCP: MRU 1492 (0x010405D4)
*Feb 1 21:19:48.828: Vi2 LCP: AuthProto PAP (0x0304C023)
*Feb 1 21:19:48.828: Vi2 LCP: MagicNumber 0x5E560A47 (0x05065E560A47)
*Feb 1 21:19:48.828: Vi2 LCP: O CONFACK [REQsent] id 202 len 18
*Feb 1 21:19:48.829: Vi2 LCP: MRU 1492 (0x010405D4)
*Feb 1 21:19:48.829: Vi2 LCP: AuthProto PAP (0x0304C023)
*Feb 1 21:19:48.829: Vi2 LCP: MagicNumber 0x5E560A47 (0x05065E560A47)
*Feb 1 21:19:48.829: Vi2 LCP: Event[Receive ConfReq+] State[REQsent to ACKsent]
*Feb 1 21:19:48.829: Vi2 LCP: I CONFACK [ACKsent] id 1 len 14
*Feb 1 21:19:48.829: Vi2 LCP: MRU 1492 (0x010405D4)
*Feb 1 21:19:48.829: Vi2 LCP: MagicNumber 0xF9C09D5D (0x0506F9C09D5D)
*Feb 1 21:19:48.829: Vi2 LCP: Event[Receive ConfAck] State[ACKsent to Open]
*Feb 1 21:19:48.858: Vi2 PPP: Phase is AUTHENTICATING, by the peer
*Feb 1 21:19:48.858: Vi2 PAP: Using hostname from interface PAP
*Feb 1 21:19:48.858: Vi2 PAP: Using password from interface PAP
*Feb 1 21:19:48.858: Vi2 PAP: O AUTH-REQ id 1 len 20 from "timadsl"
*Feb 1 21:19:48.858: Vi2 LCP: State is Open
*Feb 1 21:19:49.004: Vi2 PAP: I AUTH-ACK id 1 len 5
*Feb 1 21:19:49.004: Vi2 PPP: Phase is FORWARDING, Attempting Forward
*Feb 1 21:19:49.005: Vi2 PPP: Phase is ESTABLISHING, Finish LCP
*Feb 1 21:19:49.005: %LINEPROTO-5-UPDOWN: Line protocol on Interface Virtual-Access2, changed state to up
*Feb 1 21:19:49.007: Vi2 PPP: Phase is UP
*Feb 1 21:19:49.007: Vi2 CDPCP: Protocol configured, start CP. state[Initial]
*Feb 1 21:19:49.007: Vi2 CDPCP: Event[OPEN] State[Initial to Starting]
*Feb 1 21:19:49.007: Vi2 CDPCP: O CONFREQ [Starting] id 1 len 4
*Feb 1 21:19:49.007: Vi2 CDPCP: Event[UP] State[Starting to REQsent]
*Feb 1 21:19:49.012: Vi2 LCP: I PROTREJ [Open] id 203 len 10 protocol CDPCP (0x01010004)
*Feb 1 21:19:49.013: Vi2 CDPCP: Event[Receive CodeRej-] State[REQsent to Stopped]
If anyone could give me some help, it would really appreciate it.
Thanks in advance!
Roberto
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide