cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
Announcements
Popup Hotspot Using ISR 1000 with WiFi/LTE for Teleworkers and Micro Branchesr
3944
Views
0
Helpful
2
Replies
Highlighted
Beginner

Cisco Network Assistant, unable to add a switch

I have a network running some 20 switches, two controllers and many AP's.  All the devices that should be able to connect to cisco network assistant can successfully.  However there is one switch that will show in neighbours but will give the message of “unable to connect to device” when I try and add it to the topology. 

As far as I can see the config is identically to all other similar switches in the network.  I can telnet from a switch (management VLAN) to the switch in question.  However when I try to ping or telnet from the PC running network assistant (different subnet) I am unsuccessful.  However I can ping/telnet to all other cisco device from this PC. 

The switch is a WS-C3560-48TS and I have included the config for firstly the switch in question and another switch of the same model and config that works correctly.  Any help would be greatly appreciated, thank you.    

sho run

Building configuration...

Current configuration : 7363 bytes

!

version 12.2

no service pad

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

!

hostname wc3_switch_1

!

enable secret 5 $1$Fn0U$2rG6DadA8JSUzQzSNmMc4/

enable password 7 1511021F0725

!

username dis privilege 15 secret 5 $1$b3d.$S43CM1xtXyEtO5Rsil6Bn1

username admin privilege 15 password 7 0811185C224C543341

no aaa new-model

ip subnet-zero

ip routing

no ip domain-lookup

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface FastEthernet0/1

description ### Connected to Parkside-AP05 ###

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/2

description ### Connected to Parkside-AP06 ###

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/3

description ### Connected to Parkside-AP07 ###

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/4

description ### Connected to Parkside-AP08 ###

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/5

description ### Connected to Parkside-AP12 ###

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/6

description ### Connected to Parkside-AP13 ###

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/7

description ### Connected to Parkside-AP20 ###

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/8

description ### Connected to Parkside-AP21 ###

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/9

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/10

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/11

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/12

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/13

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/14

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/15

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/16

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/17

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/18

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/19

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/20

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/21

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/22

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/23

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/24

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/25

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/26

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/27

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/28

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/29

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/30

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/31

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/32

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/33

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/34

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/35

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/36

description ### Connected to Parkside-AP36 ###

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/37

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/38

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/39

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/40

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/41

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/42

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/43

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/44

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/45

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/46

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/47

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/48

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface GigabitEthernet0/1

description *** Connected to WC2A_Core_Switch ***

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/2

description *** Connected to wc3_switch_2 ***

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/3

shutdown

!

interface GigabitEthernet0/4

shutdown

!

interface Vlan1

ip address 10.0.0.31 255.255.255.0

!

ip default-gateway 10.0.0.254

ip classless

ip http server

!

!

control-plane

!

!

line con 0

password 7 144711185D07

logging synchronous

login local

line vty 0 4

password 7 144711185D07

logging synchronous

login local

line vty 5 15

password 7 094F471A1A0A

no login

!

!

end

#########################################################################

wc3_switch_2#sho run

Building configuration...

Current configuration : 7239 bytes

!

version 12.2

no service pad

service timestamps debug datetime localtime

service timestamps log datetime localtime

service password-encryption

!

hostname wc3_switch_2

!

enable secret 5 $1$Sfoj$a6AdO7PI0bP8ERhpWl3OP.

!

username dis privilege 15 secret 5 $1$D9c6$16yFzETOxBNHiPdTEqkxQ1

username admin privilege 15 password 7 133543002059550E78

no aaa new-model

ip subnet-zero

no ip domain-lookup

!

!

!

!

no file verify auto

spanning-tree mode pvst

spanning-tree extend system-id

!

vlan internal allocation policy ascending

!

interface FastEthernet0/1

description ### Connected to Parkside-AP24 ###

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/2

description ### Connected to Parkside-AP27 ###

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/3

description ### Connected to Parkside-AP28 ###

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/4

description ### Connected to Parkside-AP30 ###

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/5

description ### Connected to Parkside-AP31 ###

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/6

description ### Connected to Parkside-AP32 ###

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/7

description ### Connected to Parkside-AP33 ###

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/8

description *** Curric4 VLAN Port ***

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface FastEthernet0/9

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/10

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/11

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/12

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/13

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/14

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/15

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/16

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/17

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/18

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/19

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/20

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/21

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/22

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/23

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/24

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/25

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/26

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/27

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/28

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/29

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/30

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/31

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/32

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/33

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/34

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/35

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/36

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/37

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/38

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/39

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/40

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/41

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/42

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/43

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/44

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/45

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/46

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/47

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface FastEthernet0/48

description *** Curric4 VLAN Port ***

switchport access vlan 6

spanning-tree portfast

!

interface GigabitEthernet0/1

description *** Connected to wc3_switch_1 ***

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/2

description *** Connected to wc3_switch_3 ***

switchport trunk encapsulation dot1q

switchport mode trunk

spanning-tree portfast

!

interface GigabitEthernet0/3

shutdown

!

interface GigabitEthernet0/4

shutdown

!

interface Vlan1

ip address 10.0.0.32 255.255.255.0

!

ip default-gateway 10.0.0.254

ip classless

ip http server

!

!

control-plane

!

!

line con 0

password 7 135514015A0F

logging synchronous

login local

line vty 0 4

password 7 135514015A0F

logging synchronous

login local

line vty 5 15

no login

!

!

end

Everyone's tags (1)
1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted
Hall of Fame Guru

Cisco Network Assistant, unable to add a switch

The switch configurations look pretty straightforward and mostly correct.

I notice that the problem switch has "ip routing" global command. Why is that necessary? You are only using it as a L2 switch, yes?  If you use "ip routing" and have no routing process (ospf, eigrp, etc.) running you would need to add a static default route (ip route 0.0.0.0 etc.) and not use the "ip default-gateway" command. Otherwise the switch itself (the SVI) does not know how to leave the management VLAN routing-wise since it is the only L3 interface defined.

(I might also add "ip http authentication local" on each and I'd definitely disable telnet in favor of ssh)

View solution in original post

2 REPLIES 2
Highlighted
Hall of Fame Guru

Cisco Network Assistant, unable to add a switch

The switch configurations look pretty straightforward and mostly correct.

I notice that the problem switch has "ip routing" global command. Why is that necessary? You are only using it as a L2 switch, yes?  If you use "ip routing" and have no routing process (ospf, eigrp, etc.) running you would need to add a static default route (ip route 0.0.0.0 etc.) and not use the "ip default-gateway" command. Otherwise the switch itself (the SVI) does not know how to leave the management VLAN routing-wise since it is the only L3 interface defined.

(I might also add "ip http authentication local" on each and I'd definitely disable telnet in favor of ssh)

View solution in original post

Highlighted
Beginner

Cisco Network Assistant, unable to add a switch

Worked a treat, thank you.

CreatePlease to create content
Content for Community-Ad