cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1215
Views
5
Helpful
6
Replies
NicP
Beginner

Cisco Prime sometimes fails SNMP

Currently I have the problem that Cisco Prime infrastructure sometimes gives the error "SNMPReachability Status is Unreachable" for a switch while this is not the case. It happens always for the same 3 switches. (we have more that 300 switches where this doesn't happen)

Configuration is identical and other switches of the same model en firmware on the same site (even lower in the tree) don't have this problem at all. Manual sync works, and an snmpwalk from the prime server while this error is active is no problem either. 

 

Does anybody have an suggestion what it may be?

 

Current Prime build: 3.8.0.0.310

SNMP config:

snmp-server group GROUP v3 priv write all 
snmp-server view all iso included
snmp-server contact ***@***
snmp-server enable traps storm-control trap-rate 500
snmp-server enable traps cpu threshold
snmp-server enable traps stackwise
snmp-server enable traps power-ethernet police
snmp-server enable traps envmon
snmp-server enable traps errdisable
snmp-server enable traps transceiver all
snmp ifmib ifindex persist

snmp-server user USER GROUP v3 auth sha PASSWORD priv aes 128 PASSWORD access GROUP

Switch models:

WS-C3650-48PD IOS 03.06.06E (stack of 3)

WS-C2960-24PC-L IOS 12.2(55)SE12   (will be replaced soon)

WS-C2960-Plus 24PC-L IOS 15.2(7)E2

 

6 REPLIES 6
marce1000
VIP Advisor

 

 - One thing you may try is to remove these devices from Prime and re-add them again (Press verify credentials first),                             although the latter doesn't seem to be the issue, but it is worth trying anyway.

 M.

NicP
Beginner

Hi Marce1000

Sorry, it took some time to find a moment for me to try it.

But is tried to remove it today, but they refuse to be deleted.

 

 

              - What error are you getting when trying to delete ?

 M.

Ok, I was to hasty. deleting finally worked. Only took half a day to be processed

But it did not solve the SNMP problem. My next step is rebooting the switches itself. This will take some time because production. But keep you informed.

Update:

Reboot didn't work either. I tried to compare credential verification traffic (with tcpdump on the prime server) with another switch of the same model, version and location but couldn't see any problems. show tech doesn't show anything either.

I will leave it at that, because 2 of the 3 switches are planned for a replacement and the last one may be fixed with a firmware update (and i possibly connected with a stackwise bug which is present on it).

renjithg
Cisco Employee

Switch response is slow or getting timed out intermittently might be the issue.  You may increase snmp timeout to 300s (max) for these 3 devices in Prime.

Probably,  plan to upgrade the device to latest recommenced code if available as i do not see issue from Prime perspective.

Content for Community-Ad