cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
441
Views
0
Helpful
3
Replies
Highlighted
Beginner

CiscoWorks LMS & Citrix

I have been having a series of issues with CiscoWorks.  Seems like some services do not start up and I have tried numerous fixes to get them to work properly.  I am wondering if one main problem can be that CiscoWorks is installed on a Cistrix VM.

Here are the specs:

Equipment:     HP ProLiant DL360 G5

Citrix XenServer 5.5.0-15119p

Microsoft Windows Server 2003 R2 Enterprise (x64)

Memory: 8GB

CPU: 2

Hard Drive: 30GB

CiscoWorks LMS 3.1

I started noticing problems when the hard drive got full.  This was due to syslog messages being sent to the server which caused the syslog.log to get quite large.  After scheduling backups and those succeeding, the disk space issue was cleared up but services stopped responding even after restarting those services.  Even after a few restarts those services would never restart.

Has anyone else had problems with the installation of CiscoWorks on a Citrix VM?  I did see in the installation requirements that Citrix was not listed but VMWare and Hyper-V were listed.

I need to get this working ASAP for user-tracking purposes to help determine where devices are located on our network.

Thank you,

Robert

3 REPLIES 3
Highlighted
Rising star

I'm aware of ciscoworks being supported on VMware ESX and now also on UCS. Never saw anything on citrix

Your instalation my be damaged due to the diskfull. I would expect the databases to have run into issues. Maybe one or more are corrupt.

Post a pdshow -brief to what proccesses have not started.

Also installing it on citrix makes me think users may connect to this machine and start the browser locally. That's not a good idea.

Better keep the server and the client appart.

Also the machine supports only terminal services in remote administration mode so make sure it is in that mode.

Cheers,

Michel

Highlighted

I'm still new to CiscoWorks, and I did not do the installation, but this was something that was handed down to me that I have to now manage.

Here is the pdshow - brief:

*****************************************************************************************************

*****************************************************************************************************

C:\Documents and Settings\myusername>pdshow -brief
  Process               State                                     Pid
  *******               *****                                     ***
  UPMDbEngine           Program started - No mgt msgs received    7788
  UPMDbMonitor          Running normally                          9088
  Tomcat                Program started - No mgt msgs received    13536
  TomcatMonitor         Running normally                          13548
  Apache                Program started - No mgt msgs received    14240
  RMEDbEngine           Program started - No mgt msgs received    3192
  qpmDbEngine           Program started - No mgt msgs received    10268
  qpmDbMonitor          Running normally                          5004
  QpmPDP                Program started - No mgt msgs received    3780
  QpmAppServer          Program started - No mgt msgs received    11684
  QpmCollector          Program started - No mgt msgs received    9872
  Proxy                 Program started - No mgt msgs received    10960
  ProcSysBus            Program started - No mgt msgs received    9976
  OpsxmlDbEngine        Program started - No mgt msgs received    10844
  OpsXMLRuntime         Program started - No mgt msgs received    8204
  NameServer            Program started - No mgt msgs received    600
  NameServiceMonitor    Running normally                          12616
  EDS                   Running normally                          4052
  LicenseServer         Program started - No mgt msgs received    14564
  IpmDbEngine           Program started - No mgt msgs received    9044
  INVDbEngine           Program started - No mgt msgs received    8100
  FHPurgeTask           Transient terminated                      0
  FHDbEngine            Program started - No mgt msgs received    6976
  ESS                   Program started - No mgt msgs received    7860
  EssMonitor            Running normally                          3924
  EventFramework        Program started - No mgt msgs received    3572
  PMServer              Running normally                          3748
  SyslogCollector       Program started - No mgt msgs received    9804
  EPMDbEngine           Program started - No mgt msgs received    6228
  EPMServer             Running normally                          3968
  FHServer              Running normally                          8108
  emsDbEngine           Program started - No mgt msgs received    8564
  emsDbMonitor          Running normally                          10664
  diskWatcher           Running normally                          12628
  DFMMultiProcLogger    Program started - No mgt msgs received    11072
  DFMLogServer          Program started - No mgt msgs received    4360
  DFMCTMStartup         Administrator has shut down this server   0
  DfmBroker             Program started - No mgt msgs received    7412
  DfmServer             Running normally                          12032
  DfmServer1            Running normally                          12196
  CSRegistryServer      Running normally                          11556
  CSDiscovery           Transient terminated                      0
  CmfDbEngine           Program started - No mgt msgs received    10352
  CmfDbMonitor          Running normally                          6052
  DCRServer             Running normally                          9240
  CMFOGSServer          Program started - No mgt msgs received    7484
  CampusOGSServer       Program started - No mgt msgs received    12364
  emsServer             Program started - No mgt msgs received    12480
  EssentialsDM          Running normally                          7196
  ConfigMgmtServer      Program started - No mgt msgs received    4196
  ICServer              Running normally                          1600
  RMEOGSServer          Program started - No mgt msgs received    11048
  TISServer             Program started - No mgt msgs received    8964
  DFMOGSServer          Program started - No mgt msgs received    4312
  InventoryCollector    Running normally                          2804
  Interactor            Program started - No mgt msgs received    1376
  InventoryCollector1   Program started - No mgt msgs received    7260
  Interactor1           Program started - No mgt msgs received    8136
  NOSServer             Running normally                          7380
  PTMServer             Running normally                          5680
  UPMProcess            Running normally                          7684
  EDS-GCF               Running normally                          13276
  jrm                   Running normally                          10720
  CTMJrmServer          Running normally                          9788
  ChangeAudit           Program started - No mgt msgs received    4664
  SyslogAnalyzer        Program started - No mgt msgs received    8264
  DataPurge             Administrator has shut down this server   0
  IPMProcess            Program started - No mgt msgs received    10068
  IPMOGSServer          Program started - No mgt msgs received    5984
  ANIDbEngine           Program started - No mgt msgs received    8092
  ANIServer             Failed to run                             0
  UTMajorAcquisition    Never started                             0
  MACUHIC               Running normally                          7136
  UTLITE                Running normally                          12436
  UTManager             Running normally                          5636
  WlseUHIC              Running normally                          4992
  AdapterServer1        Program started - No mgt msgs received    4232
  AdapterServer         Program started - No mgt msgs received    13044
*****************************************************************************************************

*****************************************************************************************************

Thanks,

Robert

Highlighted

So only the ANI server has failed.

Following what is said in this doc https://supportforums.cisco.com/docs/DOC-8798 ani.log and or aniserver.log should provide clues as to what goes wrong.

You may want to post these.

I think you may have a corrupt config file   NMSROOT/campus/etc/cwsi/ANIServer.properties

You can compare your properties file with the attached one

My server is called didata, that part you have to change.

Good luck

Michel

Content for Community-Ad