cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
779
Views
0
Helpful
2
Replies

Config Management Server is repeatedly crashing

marshajr
Beginner
Beginner

Running LMS4.1 - the Config management server process 'crashes' after approximately 5 seconds of starting. The server log is showing the following message:

Exception in thread "ActiveMQ Session Task" java.lang.NoClassDefFoundError: com/cisco/nm/xms/ogs/client/OGSServerProxy

    at com.cisco.core.mice.cam.cmf.CMFDeviceCache.reloadDeviceGrp(CMFDeviceCache.java:159)

    at com.cisco.core.mice.cam.OGSEventListener.onMessage(OGSEventListener.java:141)

    at org.apache.activemq.ActiveMQMessageConsumer.dispatch(ActiveMQMessageConsumer.java:1021)

    at org.apache.activemq.ActiveMQSessionExecutor.dispatch(ActiveMQSessionExecutor.java:122)

    at org.apache.activemq.ActiveMQSessionExecutor.iterate(ActiveMQSessionExecutor.java:192)

    at org.apache.activemq.thread.PooledTaskRunner.runTask(PooledTaskRunner.java:122)

    at org.apache.activemq.thread.PooledTaskRunner$1.run(PooledTaskRunner.java:43)

    at java.util.concurrent.ThreadPoolExecutor$Worker.runTask(ThreadPoolExecutor.java:886)

    at java.util.concurrent.ThreadPoolExecutor$Worker.run(ThreadPoolExecutor.java:908)

    at java.lang.Thread.run(Thread.java:662)

The DCMAService log is showing messages similar to below:

[ Mon Oct 10  11:55:29 CST 2011 ],INFO ,[main],com.cisco.nm.rmeng.dcma.configmanager.DeviceArchiveManager,deleteDevice,1659,Deleted Archive for device 531

[ Mon Oct 10  11:55:29 CST 2011 ],FATAL,[main],com.cisco.nm.rmeng.util.DCRWrapperAPIs,getDCRId,1333,Device ID: 466 NOT in RME

2 Replies 2

AFROJ AHMAD
Cisco Employee
Cisco Employee

Hi,

shutdown dmgtd

then remove ctmregistry* from NMSROOT/MDC/tomcat/webapps/rme/WEB-INF/lib.

Also disable the Anti-virus running on the server ,If applicable

Thenstart dmgtd

Now check the status of the issue. If you still find the same issue then send me the below information:

CTMJrmServer.log

jrm.log

JrmUser.properties  and md.properties (CSCOpx/lib/classpath)

Output of pdshow

ctm_config.txt (CSCOpx\mdc\tomcat\shared\lib)

Is there any 3rd Party application been Installed on the server ?

Thanks

Afroj

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

Afroj - attached are the files you requested. I tried the steps you suggested but they did not resolve the problem (it failed after appromixately 5 seconds).  In answer to your questions:

1. Anti-virus is disabled on the server.

2. We are running the system on a virtual server under Windows Server 2008 R2 - I did patch LMS for this.  There are no other applications running on the server, it is dedicated to LMS.

Jon

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: