11-15-2011 12:27 AM
Hi,
our 6509 is configured as NTP master. Our 4948 is configured as NTP client.
on each of these switches we have configured a management VRF.
The problem is that 4948 can not synchronize its clock with NTP master. Both switches are directly connected.
show cdp neighbor on 4948 switch:
6K5 Fas 1 138 R S I WS-C6509- Gig 2/2/43
interface config on 6509:
interface GigabitEthernet2/2/43
description *** Mgmt Switch Externe 1 ***
switchport
switchport access vlan 1900
switchport mode access
wrr-queue cos-map 1 1 1
wrr-queue cos-map 2 1 0
wrr-queue cos-map 3 1 4
wrr-queue cos-map 3 2 2
wrr-queue cos-map 3 3 3
wrr-queue cos-map 3 4 6
wrr-queue cos-map 3 5 7
udld port
spanning-tree portfast edge
spanning-tree bpduguard enable
end
interface config on 4948:
interface FastEthernet1
description ********** Interface Mgmt **********
ip vrf forwarding mgmtVrf
ip address 10.100.254.32 255.255.255.0
speed auto
duplex auto
end
I activated the following debugs on both switches:
- debug ntp packet
- debug ntp event
debug on 4948:
Nov 15 08:42:16.640: NTP: xmit packet to 10.100.254.1:
Nov 15 08:42:16.640: leap 3, mode 3, version 3, stratum 0, ppoll 64
Nov 15 08:42:16.640: rtdel 0000 (0.000), rtdsp 10001 (1000.015), refid 00000000 (0.0.0.0)
Nov 15 08:42:16.640: ref 00000000.00000000 (01:00:00.000 CET Mon Jan 1 1900)
Nov 15 08:42:16.640: org 00000000.00000000 (01:00:00.000 CET Mon Jan 1 1900)
Nov 15 08:42:16.640: rec 00000000.00000000 (01:00:00.000 CET Mon Jan 1 1900)
Nov 15 08:42:16.640: xmt D26CA468.A40C1B76 (09:42:16.640 CET Tue Nov 15 2011)
debugs on 6509 do not show any packets received or sent to 4948.
any help would be appreciated
11-15-2011 06:40 AM
It sounds like you might be mixing up your Layer 2 (VLAN) and Layer 3 (SVIs and routed interfaces) a bit. Your 6509 interface is a non-routed port. Is the Mgmt VRF you mentioned available over VLAN 1900? e.g., you would need something like:
interface vlan 1900
ip vrf forwarding mgmt
...in your config.
Otherwise the default routing table (RIB) on the 6509 will be servicing layer 3 requests on Vlan 1900.
Hope this helps.
11-18-2011 01:47 AM
on 6509, here's the config of interface vlan 1900:
6K5#sh run int vlan 1900
Building configuration...
Current configuration : 127 bytes
!
interface Vlan1900
ip vrf forwarding VRF_Mgmt
ip address 10.100.254.1 255.255.255.0
no ip redirects
no ip proxy-arp
end
on the 4948, there is no interface vlan1900.
for other devices, NTP packets are sent and exchanged on vlan1900. But there's trouble only with this 4948, which now I think it's due to the presence of VRF.
Update: problem solved:
On the 4948, I replaced "ntp server 10.100.254.1" with "ntp server vrf mgmtVrf 10.100.254.1" and added "ntp source Fa1" to specify the interface that issues NTP packets
Thanks for the guidance
Message was edited by: Wassim Aouadi
Discover and save your favorite ideas. Come back to expert answers, step-by-step guides, recent topics, and more.
New here? Get started with these tips. How to use Community New member guide