cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3428
Views
0
Helpful
10
Replies
Highlighted
Beginner

DB-15 for console connection?

I have a DB-15 port on the back of my laptop.  Can I use this to console into a router?  What cables and adaptors do I need to make this work?

1 ACCEPTED SOLUTION

Accepted Solutions
Highlighted

You're welcome. Please rate and mark your question as answered so as to help the forum.

View solution in original post

10 REPLIES 10
Highlighted
Hall of Fame Guru

The "standard" console cable that ships with many Cisco products is a serial DB-9 to RJ-45 type. If your laptop has a DB-15 RS-232 serial port I suppose your COULD purchase a DB-15 to DB-9 adapater and then plug in a standard Cisco console cable to that.

Personally I'd strongly prefer getting a USB-Serial adapter and using that from your PC to the standard Cisco console cable. I use a TRENDnet TU-S9 Serial adapter - USB. you can get them for about US$11 at Amazon.com. With one of those, you can use it with any PC with a USB connection - much more common than one with a DB-15 serial port.

While you're at it, if you use any of the newer switches like the 3750X series that have the mini-USB console you might want to order one of those for your toolkit. They cost a bit more at about $23 but it's nice to have that cable since the newere console ports are on the front of the switch and typically more accessible. Search for "Cisco Type A T0 Mini Type B USB Cable (6 feet)".

Highlighted

Thanks Marvin.

Any special settings/ configs needed for the USB port on my laptop? Will Hyperterm need to be set up differently?

Highlighted

The TRENDnet adapter comes with its own USB driver on a disk. Once you've installed that, it will map your USB port to a COM (serial) port - typically something like COM8 or COM9. It varies per PC and per physical port on a given PC.

You just need to ascertain which one is used on your system (via trial and error or via Windows Device Manager - see below) and tell Hyperterm (or whatever terminal emulation program you use) to use that COM port.

(Oh and FYI a DB-15 port on a laptop is typically a VGA video port for an external monitor - not a serial port.)

Highlighted

Thanks! I’ll be going with the USB solution.

Highlighted

You're welcome. Please rate and mark your question as answered so as to help the forum.

View solution in original post

Highlighted

Hi Marvin,

I am trying to use the Teraterm with the cable that you indicated but it does not work.

The COM port assigned by default to the cable was 8, I changed it using the DEVICE MANAGER --- > Ports (COM & LPT) --- > Rigth Button over: Prolific USB to Serial........ (COM8 - initial value by default) --- > Properties ----- > Port settings ---- > Advanced ---- > COM PORT NUMBER SCROLL (I selected COM 2 which has not had (in use) condition) (COM PORTS from 4 to 7 show " in use" condition).

Now in the DEVICE MANAGER appears:

Ports (COM & LPT) --- > Prolific USB to Serial..... (COM2)

Then when I tried to open TERATERM:

I made some research on the web and apparently this trendnet cable is not the best but unfortunately I purchased it based on your post.

Thank you in advance for your orientation

Highlighted

What's your reason for using other than the default assigned COM8? I've used that setting without issue to connect to dozens of various Cisco devices - routers, switches, ASAs, Pix, etc.

For my terminal emulation I use Xshell, a very nice licensed program that's worth the cost. A free evaulation or home/personal use license is available. See http://www.netsarang.com/products/xsh_overview.html

Highlighted

I am using a free software (teraterm) which only offers 4 COM Ports (from 1 to 4) for connecting to the Cisco Device. For that reason, I had to change the Prolific COM Port from default COM Port = 8 to 2,3 or 4 but it does not work. I will try to solve this situation without having to spend much money on differents SSH, Telnet, etc emulators.

regards

Highlighted

Trying the free evaluation copy of a Xshell would be a reasonable troubleshooting step as it would isolate the problem to teraterm vs. the Prolific adapter.

I believe Putty (free) also lets one specify any valid COM port.

Highlighted

Thanks Marvin, I will try the free evaluation Xshell. However, I already tried with Putty with the same results (it does not work).

On the other hand, apparently there is something with the COM Ports Management on Win7 that keep them permanently on state "IN USE" so I am planning to modify the COM NAME Arbiter in order to reset all the COM Ports (not physical).

I will let you know what happened before trying the Xshell.

regards

Content for Community-Ad