Showing results for 
Search instead for 
Did you mean: 

DCR Server Down Error Message LMS 4.0.1



I have a problem with my LMS 4.0.1! It was working fine till a couple of days ago. When I started it, all my equipment were missing and when i tried doing a Discovery Seach it launched a message saying that the DCR Server is Down.

I checked under Services in my Server and everything involving CiscoWorks is running. Ive Restarted the Deamon and still no luck. DCHP Service is disabled.

Have anyone had the same problem?? How can I fix it??

I have LMS 4.0.1 in a Windows 2008 R2 Server.

Ill be looking forward to a repply!

Thank you!!



10 Replies 10

Nael Mohammad

What has changed on the server?

Have you recently patched the server?

Check your event viewer for any errors.

Post the logs from CSCOpx/log/dcr.log, CSCOpx/log/DCRServer.log, SYSTEMINFO, TASKLIST /svc, and CSCOpx/bin/pdshow output.


Yes actually i actualized the licence for the Windows 2k8. And since then Ive been having the problems mentioned.

I checked the Event Viewer On Windows and there are 26 errors in the last hour and around 80 errors around 24 hours.

Ok i ran what you asked and ive attached it.

still the LMS is not working :S

What is weird is that in pdshow dcrserver is says is shut down but when i go to services, its up.

i would appriciate if you could help me out!

Thank you!



Your services have been changed from the default settings.

Only the following services should be set to automatic:

1. CiscoWorks Daemon Manager

2. CWCS rsh/rcp services

3. CWCS syslog service

4. CWCS tftp service

These should be manual and never changed as they are controlled by Ciscoworks Daemon Manager:


CiscoWorks ANI database engine

CiscoWorks RME NG database engine

CiscoWorks Tomcat Servlet Engine

CiscoWorks WebServer

CiscoWorks CMF database engine

DFM dfmEpm database engine

DFM dfmFh database engine

DFM dfmInv database engine

IPM NG Database Engine

After you update the services to the correct state, reboot the server and it should come up fine.


I changed everything but when i started it again i didnt have access to LMS via web so I had to start the services Manually.

Was I to do that?

But still, when i run the LMS it doesnt show me anything. On the monitoring dashboard theres nothing and it says "You have no devices for which you are authorized to view data" and under High Severity Faults it says "An error occurred.  Check the AAD.log file for details"

when i do a Discovery Seach it keeps saying that the DCR Server is down.


what should i do next?

Updating my Windows licence could have modified something else?



You are not suppose to start the services manually. You need to wait a good 15 minutes or so before all the services are up and running.  Go to CSCOpx/objects/dmgt/ready directory and ensure its empty after 15 minutes starting the CiscoWorks daemon manager. If data is in this directory, that means the services have not completely started and must wait.

Disable all security applications like virus scanning, stop the services you started, and restart just CiscoWorks Daemon Manager only.


Ok I did that and theres nothing inside the directory you mentioned.

However, when i try accessing via Web, I cant. The CiscoWork Web Server that i put in Manual mode is not running. shouldnt i start that?



Post the content from the CLI and type "SYSTEMINFO", CSCOpx/MDC/Apache/log content, and the CiscoWorks install logs from C:\ called CiscoWorks_Install_xxx.log.


Ok here you go



In the apache logs, I do see a Terminating on signal SIGTERM(15) and [warn] (OS 64)The specified network name is no longer available.  : winnt_accept: Asynchronous AcceptEx failed.

1. Disable DEP (Windows Data Exectution Protection)

2. Disable SSL if in use, stop LMS Daemon Manager then

going to CSCOpx/MDC/Apache directory. Run the command from the CLI "CSCOpx/bin/perl.exe CSCOpx/bin/Apache/Config -disable".

3. Ensure that you have enough resources allocated for the server, I did notice that you did not meet the system requirement for the hard drive space according to CiscoWorks Install logs.

4. Run the hostname change script as well from "CSCOpx/bin/perl.exe CSCOpx/bin/" and reboot the server after gracefully shutting down the LMS daemon manager.

5. Post the updated screenshot of the services and pdshow after you have done the above steps along with the CSCOpx/log/syslog.log and CSCOpx/bin/pdshow output again.


I did everything. However when i run the perl.exe, -disable and on the CLI nothing happened. It didnt show anything, the command line just stayed the same and didnt show any output whatsoever, sort of like freezes.

I tried again but still not working.

I attach the print screens

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: