Showing results for 
Search instead for 
Did you mean: 

eem: server has no available thread

Level 1
Level 1

Hi all,

I ve been using a small eem script to get config changes via email,
lately i noticed that i dont get any email when config changed.
When i debugged the eem i have seen the following error;

"EEM: server has no available thread to service the policy class=default policy_type=applet."

my eem script is attached,

I ve checked the net a little but couldnt find any similar issue.
I could use a little help :)


7 Replies 7

Joe Clarke
Cisco Employee
Cisco Employee

You probably have five instances of EEM applets running, and can no longer service a new instance.  Check the output of "show event manager policy pending" and "show event manager policy active".  If the policies are stuck, you may have to reload to effectively kill them.  Else you can try "event manager scheduler clear all"

Hi Joseph,

I checked the show event manager output and there were 16 pending events after clearing with event manager scheduler clear all tried to trigger the event, again result was same still no available thread error :(  any option other than reload ?

Unfortunately not.  You will need to reload.

Is there anyone who knows whether this is a bug or a limitation.

I don't know your version of code nor which policies were wedged in the queue, but if the policy is this one applet, my guess is it's a bug.  We have seen when one specifies an SMTP server by hostname the policy can wedge.  Therefore, I always recommend you use an IP address for the SMTP server.

I am using hostname also thanks for the tip I ll check with the ip address

Level 1
Level 1

Reload should fix the problem. Another possible solution would be to increase the pool of available threads for script execution.

R1#show event manager scheduler thread detailed


Increase the total amount of threads for one of the service classes.

R1(config)#event manager scheduler script thread class default number 10

Best regards, Arseniy S. Ivanov