cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
782
Views
0
Helpful
4
Replies
questit.srl
Beginner

Help for Cisco configuration

Hi all,

we brought a Cisco 881W-GN-E-K9 and we use it as main router.

We have this network architecture:

- the WAN (FastEthernet4 interface) is connected to the 192.168.0.x network

- all the ethernet interfaces (FastEthernet 0-3) and the wlan are in 10.0.0.0 network using a VLan

We have some problems:

- we set static DNS entries in the Router:

ip host Waters 10.0.0.1

ip host Barrett 10.0.0.2

ip host Mason 10.0.0.20

ip host Wright 10.0.0.21

However, the ping Mason it's not working....

- we activate a NAT for the 8080 port on the 10.0.0.21 pc but it does not works:

ip nat inside source static tcp 10.0.0.21 8080 A.B.C.D 8080 extendable

someone can explain were we are falling?

Following the router configuration:

--------------------------

Current configuration : 6948 bytes

!

version 15.1

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Waters

!

boot-start-marker

boot-end-marker

!

!

logging buffered 51200 warnings

!

no aaa new-model

memory-size iomem 10

crypto pki token default removal timeout 0

!

crypto pki trustpoint TP-self-signed-1382020822

REMOVED!!!

!

!        

crypto pki certificate chain TP-self-signed-1382020822

REMOVED!!!

ip source-route

!

!

!

ip dhcp excluded-address 10.0.0.1

ip dhcp excluded-address 10.0.0.1 10.0.0.99

!

ip dhcp pool DHCP

import all

network 10.0.0.0 255.0.0.0

default-router 10.0.0.1

dns-server 10.0.0.1

lease 0 10

!

!

ip cef

ip host CiscoRouter 10.0.0.1

ip host Mason 10.0.0.20

ip host Wright 10.0.0.21

ip host SamsungML3050 10.0.0.91

ip host CiscoAP 10.0.0.2

ip host EpsonSX440W 10.0.0.90

ip host RouterAP 10.0.0.2

ip host Waters 10.0.0.1

ip host Router 10.0.0.1

ip host Barrett 10.0.0.2

ip name-server 192.168.0.1

ip name-server 8.8.8.8

ip name-server 10.0.0.1

no ipv6 cef

!

!

vpdn enable

!

vpdn-group 1

REMOVED!!!

!

license udi pid CISCO881W-GN-E-K9 sn REMOVED!!!

!

!

username routeradmin privilege 15 secret REMOVED!!!

!

!

!

!

!

!

!

!

!

!

!

interface FastEthernet0

no ip address

!

interface FastEthernet1

no ip address

!

interface FastEthernet2

no ip address

!

interface FastEthernet3

no ip address

!

interface FastEthernet4

ip address 192.168.0.253 255.255.255.0

ip nat outside

ip virtual-reassembly in

duplex auto

speed auto

!

interface Virtual-Template1

ip unnumbered Vlan1

ip nat inside

ip virtual-reassembly in

peer default ip address dhcp-pool DHCP

no keepalive

ppp encrypt mppe 128

ppp authentication ms-chap ms-chap-v2

!

interface wlan-ap0

description Service module interface to manage the embedded AP

ip unnumbered Vlan1

ip nat inside

ip virtual-reassembly in

arp timeout 0

!

interface Wlan-GigabitEthernet0

description Internal switch interface connecting to the embedded AP

no ip address

!

interface Vlan1

description BLABLABLA

ip address 10.0.0.1 255.0.0.0

ip nat inside

ip nat enable

ip virtual-reassembly in

ip tcp adjust-mss 1452

!

ip local pool PPTP-Pool 10.0.1.10 10.0.1.99

ip default-gateway 10.0.0.1

ip forward-protocol nd

no ip http server

ip http access-class 23

ip http authentication local

ip http secure-server

ip http timeout-policy idle 60 life 86400 requests 10000

!

ip dns server

ip nat inside source list 1 interface FastEthernet4 overload

ip nat inside source static tcp 10.0.0.21 8080 A.B.C.D 8080 extendable

ip default-network 192.168.0.0

ip route 0.0.0.0 0.0.0.0 192.168.0.1

!        

access-list 1 permit 10.0.0.0 0.255.255.255

access-list 23 permit 10.0.0.0 0.255.255.255

no cdp run

!

4 REPLIES 4
mfurnival
Enthusiast

Leonardo,

What do you mean when you say the static entry for Mason is not working? Do you mean that when you type "ping Mason" it times out? What happens when you try and ping the actual IP address of Mason ( 10.0.0.20 ) - does that work?

Regarding the NAT - I assume that the outside address (removed from config above) is in the 192.168.0.x range?

If you try and hit the outside NAT address and do "show ip nat translations" and "debug ip nat" do you see anything?

Hi mfurnival,

thank for your answer...

inline my outlines:

What do you mean when you say the static entry for Mason is not working? Do you mean that when you type "ping Mason" it times out? What happens when you try and ping the actual IP address of Mason ( 10.0.0.20 ) - does that work?

yes, the ping to 10.0.0.20 works ok while ping mason times out....

Regarding the NAT - I assume that the outside address (removed from config above) is in the 192.168.0.x range?

hooo... thanks, this issue was solved: i was mapping the outside ip address (156.x.y.z) and not the 192.168.0.x... thank you.

Leonardo

Seems weird. Can you do the following and post the output please?

#show hosts

#ping Mason

#sh arp

#ping 10.0.0.20

#sh arp

Hi, after several attepts, I discover that:

ping mason. ==> works (note the final dot !!!)

So, I think that it depends on domain name: in our network the default domain is not set...

so I have that:

ping mason ==> doesn't work

ping 10.0.0.20 ==> works

ping mason. ==> works (note the final dot !!!)

I think that since the domain is not set, the name that the router is able to resolve is mason.[empty]

and it does not resolve mason (without final dot)