cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1396
Views
0
Helpful
5
Replies

I have two DHCP pools, one works and one does not

mwester01
Level 1
Level 1

First time posting here, but I am having a hard time figuring this out. I have two DHCP pools managing two separate VLANs on my router, one for user laptop workstations and one for phones (cisco 8841 voips). My voip DHCP pool is working fine, and each phone pulls an IP that I can ping from the router. The laptop DHCP pool is not working at all though, and I am not sure why. All of the laptops are running windows 10, and are set to automatically assign its IP from the network. I have searched the forums and verified that it is configured properly to my knowledge. I left out our dns server, domain name, and call manager, but they have been verified as correct, and I can ping them. Here is what I have on the router:

ip dhcp pool PHONE
network 10.110.10.128 255.255.255.224
dns-server x.x.x.x x.x.x.x 
default-router 10.110.10.129 255.255.255.224
domain-name xxxxxxxxx
option 150 ip x.x.x.x

ip dhcp pool LAPTOP
network 10.110.10.0 255.255.255.128
default-router 10.110.10.1 255.255.255.128
domain-name xxxxxxxxx
dns-server x.x.x.x x.x.x.x
lease 0 3

I am using sub-interfaces instead of interface VLANs:

interface GigabitEthernet0/0/1.15
description *LAPTOP*
encapsulation dot1Q 15
ip address 10.110.10.1 255.255.255.128

interface GigabitEthernet0/0/1.16
description *PHONE*
encapsulation dot1Q 16
ip address 10.110.10.129 255.255.255.224

Each port that the laptops are connected to are properly configured to access VLAN 15, and the workstations work properly if I manually enter an IP on the laptop. I am just not sure how to go about troubleshooting this and could really use some help on this one. Thanks in advance

5 Replies 5

@mwester01 use below two commands to debug at router. it will give idea about DORA process and where is the issue.

debug ip dhcp server packet

debug ip dhcp server events

Please rate this and mark as solution/answer, if this resolved your issue
Good luck
KB

TotallyTodd
Level 1
Level 1

have you excluded the addresses from the dhcp pool totally ?

I have not excluded any addresses from the pool

You should totally exclude the addresses from the pool by using the ip dhcp excluded-address command in global configuration mode and manually set their addresses if that is an option totally. 

Manually setting the addresses works fine, however we have over 100 workstations that need to be configured. I am more inclined right now to figure out why exactly the dhcp is not working