Showing results for 
Search instead for 
Did you mean: 

LMS 3.2 (Solaris) db/backup problem


Hi team!
I have a LMS 3.2 on Solaris 10, and I have some problems after trying to install the last few DevicePackage:
1) several processes are not up, then I tried to restart DaemonManager from the console:
bash-3.00 # /etc/init.d/dmgtd stop
Daemon Management is not running.
INFO: Stopping DBEngine processes registered to Daemon Manager
WARNING: Daemon Manager could not stop DBEngine processes.
WARNING: Please run the command "/opt/CSCOpx/bin/ all"
WARNING: to stop DBEngine processes manually.
bash-3.00 # /opt/CSCOpx/bin/ all
Error retrieving dsns Can not open directory /opt/CSCOpx/backup/manifest;
bash-3.00 #
bash-3.00 # ps-ef | grep CSCOpx
casuser 28450 1 0 14:02:43? 3:04 /opt/CSCOpx/objects/db/bin64/dbsrv10-x tcpip (HOST = localhost; DOBROADCAST = NO; Ser
casuser 28587 1 0 14:05:51? 13:38 /opt/CSCOpx/objects/db/bin64/dbsrv10-x tcpip (HOST = localhost; DOBROADCAST = NO; Ser
casuser 28465 1 0 14:02:51? 1:27 /opt/CSCOpx/objects/db/bin64/dbsrv10-x tcpip (HOST = localhost; DOBROADCAST = NO; Ser
casuser 28298 1 0 14:01:59? 30:15 /opt/CSCOpx/objects/db/bin64/dbsrv10-x tcpip (HOST = localhost; DOBROADCAST = NO; Ser
    root 605 21740 0 17:37:32 pts / 1 0:00 grep CSCOpx
casuser 28319 1 0 14:02:23? 0:29 /opt/CSCOpx/objects/db/bin64/dbsrv10-x tcpip (HOST = localhost; DOBROADCAST = NO; Ser
casuser 28439 1 0 14:02:35? 1:06 /opt/CSCOpx/objects/db/bin64/dbsrv10-x tcpip (HOST = localhost; DOBROADCAST = NO; Ser
casuser 28309 1 0 14:02:19? 29:07 /opt/CSCOpx/objects/db/bin64/dbsrv10-x tcpip (HOST = localhost; DOBROADCAST = NO; Ser
casuser 28361 1 0 14:02:31? 2:25 /opt/CSCOpx/objects/db/bin64/dbsrv10-x tcpip (HOST = localhost; DOBROADCAST = NO; Ser
casuser 28480 1 0 14:02:59? 0:38 /opt/CSCOpx/objects/db/bin64/dbsrv10-x tcpip (HOST = localhost; DOBROADCAST = NO; Ser
bash-3.00 # kill -9 28450 28587 28465 28298 28319 28439 28309 28361 28480
bash-3.00 # ps-ef | grep CSCOpx
    root 607 21740 0 17:38:29 pts / 1 0:00 grep CSCOpx
bash-3.00 # /etc/init.d/dmgtd start
INFO: backed up /var/adm/CSCOpx/log/daemons.log to /var/adm/CSCOpx/log/daemonsbackup.log
Daemon Management 3.9 starting. Log = (syslog) /var/adm/CSCOpx/log/dmgtd.log
bash-3.00 #

2) SelfTest Information:
WARN No Data Source Found, No Database Self Test is performed

3) Directory "manifest"  - not exist (/opt/CSCOpx/backup/manifest).

How to fix the database?

How to rebuild the directory "manifest" (/opt/CSCOpx/backup/manifest)?

Can some one help me?


Accepted Solutions

If you don't define the generation to restore from, the restore scripts looks for the latest which is associated with "0".  Like the discussion stated, rename the directory to 0 or define the generation to use.

   To run the restore command, the command syntax is:

   /opt/CSCOpx/bin/perl /opt/CSCOpx/bin/ <-d BackupDirectory> [-gen GenerationNumber]  [-t TempDirectory] [-help]

   BackupDirectory : Directory where the backup archive is present

   GenerationNumber: Generation to be restored

   TempDirectory   : Temporary directory for the restore program

                     Default TempDirectory for this restore program:


                     Use -t TempDirectory to define your own temp directory


   To see a list of the Backed Up generations available, use the following command line:

   /opt/CSCOpx/bin/perl /opt/CSCOpx/bin/ -h -d BackupDirectory

And then restore from the list of available backup generations.

View solution in original post

As stated previously, you can't use the LMS 3.0 manifest directory on a LMS 3.2 system then run a backup and try to do a restore from the successful backup of LMS 3.2.  Also when doing a restore, you need to ensure that you have the same applications installed on the new server.

The backup and restore works across any version assuming the directory structure of each respective system has not been altered in anyway and if it has, reinstall the LMS application.

View solution in original post


Nael Mohammad

Does the /opt/CSCOpx/backup/manifest exists and is it readable?

What happens you attempt to manually start the backup from the CLI after stopping LMS and killing running processes using "/opt/CSCOpx/bin/perl /opt/CSCOpx/bin/ /opt/CSCOpx/backup /var/tmp/backup.log"?  If the backup fails, post the backup.log from the previous backup attempt.

If the above fails, try the following steps:

1. Stop the LMS Daemon Manager using "/etc/init.d/dmgtd stop".

2. Do a "ps -ef | grep CSCOpx" and kill any process that is running.

3. Go to /opt/CSCOpx/databases directory and locate the subdirectory for each database.

4. Remove the transaction log file from each db directory. (i.e. "mv /opt/CSCOpx/databases/cmf/cmf.log /var/tmp"). Do this repeatedly for each db directory.

5. Restart the services LMS Daemon Manager and post the dmgtd.log, daemons.log, and daemonsbackup.log if the above does not resolve the issue.

Thanks Nael for the answer!

1) Directory "manifest" does not exist.

2) In the directory there is a several previos successful backup`s, but last backup - fail. (backup.log - in attachment).

3) Flowing issue has not solved a problem.

Files dmgtd.log, daemons.log, and daemonsbackup.log - in attachment.

In addition I have attach transaction log files from each db directory.

I expect your next helps actions.