Showing results for 
Search instead for 
Did you mean: 

LMS 4.1 User defined groups empty.


I have seen some discussion in the forums regarding user defined groups being empty in LMS 4.0 but not 4.1.  I am having this issue in 4.1.

Under User Defined groups, I have created 2 logical groups named "Physical Location" and "Switches".  These do not contain any actual devices, they are just containers for other groups.  Under the Physical Location logical group I have created 2 other groups, Acuna and Hampton.  Under the Switches group I have also created 2 groups, HDM and HHC.  The criterion for the Physical Location group is based on the first 3 characters of the hostname:

Device.System.Name startswith "hdm"

The criterion for the Switches group is based on the value of a user defined field, Admin_responsibility:

Device.Admin_responsibility equals "HDM"

The Physical Location groups work - the Switches group does not.  Both the HDM and the HHC group should contain several devices.  The HDM group contains 2, the HHC contains none.  If I edit the groups and click "next" until I get to step 3, Membership: Edit, the "objects matching criteria" list is fully populated - it contains the devices that it should contain.  However, after I click "Finish" and go to Inventory => Add / Import / Manage Devices there is no change in group membership - the HDM group contains 2 devices and the HHC group contains none.

Any ideas?


4 Replies 4

Michel Hegeraat
Rising star
Rising star

As far as I know if the parent group is empty then so will the child groups.

If these are just placeholder make sure they contain all devices you need in the child groups.



I don't know about that.  I am coming from an LMS 2.6 system and this is exactly how I have it defined there.  It is interesting that one of the groups actually shows 2 of the devices, and those are a different model switch than the rest.  Perhaps a device package update would help?  At this point I can't get those to work either.


Can you post the rules for the groups "Physical Location",  "Switches", Acuna, Hampton, HDM and HHC.

As these group marked as dynamic?



Hi Michel and thanks for the reply.

The "Physical Location" groups magically started working.  I had tried to apply a bunch of device update packages a couple of days ago.  I thought they all failed but maybe some of them actually applied.  I have no idea but the 2 groups with a rule like this one are now populating:

Device.Hostname startswith "XYZ"

However, the groups with the rule below are still failing to populate in the device selector even though if I edit the group the "Objects matching criteria" list contains the correct members:

Device.Admin_responsibility equals "XYZ"

Admin_responsibility is user defined field 1 (Admin => Device Credential Settings => User Defined Fields).

If you mean "dynamic" in that they are supposed to automatically update then yes these are dynamic public groups.  I had them defined this way for years in LMS 2.6, though the "dynamic" part never worked.  I always had to go into group admin and manually refresh to get the groups to update.  I have tried that several times in 4.1 with no luck.


Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community:

Recognize Your Peers