cancel
Showing results for 
Search instead for 
Did you mean: 
cancel

LMS 4.2.1 - Tunnels missing in Topology view

savic.marija
Beginner
Beginner

Hello,

I have problem with topology view in LMS 4.2.1, it doesn't show the tunnels connecting branches, though both devices are shown in sh cdp neighbour command output. If I choose Show Devices in Admin > Collection Settings > Data Collection, it is showing cdp neighbours correctly.

Any ideas why campus manager is not drawing tunnels?

Thanks!

Marija

4 REPLIES 4

Michel Hegeraat
Rising star
Rising star

This once worked in my lab using LMS 3.0 or LMS 2.6

The key there was that cdp was enabled explicitly on both sides in the interface config. The tu interfaces had a CDP enable command.

The 'sh cdp' on both sides show the other router behind the tunnel interface.

You have this too?

Maybe cisco decided not include certain interface types anymore rather then check for CDP neighbors....would be silly if that was the case though.

Cheers,

Michel

Yes, cdp is enabled in on tunnels:

WAN2_c3945#sh cdp neig

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID

Rtr-Svilajnac-c2901.srpskad.domen

                 Tunnel1            153            R S I  CISCO2901 Tunnel1

Rtr-Bacvanska-c2901.srpskad.domen

                 Tunnel1            138            R S I  CISCO2901 Tunnel1

Rtr-Svilajnac-c2901#sh cdp neigh

Capability Codes: R - Router, T - Trans Bridge, B - Source Route Bridge

                  S - Switch, H - Host, I - IGMP, r - Repeater, P - Phone,

                  D - Remote, C - CVTA, M - Two-port Mac Relay

Device ID        Local Intrfce     Holdtme    Capability  Platform  Port ID

WAN1-c3945.srpskad.domen

                 Tunnel0            130           R T S I CISCO3945 Tunnel0

WAN2_c3945.srspkad.domen

                 Tunnel1            171           R T S I CISCO3945 Tunnel1

WAN3_c3945.srpskad.domen

                 Tunnel2            162            R S I  CISCO3945 Tunnel2

Sw-Svilajnac-c2960.srpskabanka.rs

                 Gig 0/1            168             S I   WS-C2960- Gig 0/2

WAN2_c3945#sh run interface tunnel 1

Building configuration...

Current configuration : 332 bytes

!

interface Tunnel1

bandwidth 1000000

ip address 172.20.102.1 255.255.255.0

no ip redirects

ip mtu 1420

ip nhrp map multicast dynamic

ip nhrp network-id 11

ip tcp adjust-mss 1360

delay 10

qos pre-classify

cdp enable

tunnel source GigabitEthernet0/0

tunnel mode gre multipoint

tunnel protection ipsec profile DMVPN

end

Rtr-Svilajnac-c2901#sh run interface tunnel 1

Building configuration...

Current configuration : 383 bytes

!

interface Tunnel1

bandwidth 1000000

ip address 172.20.102.120 255.255.255.0

ip mtu 1420

ip nhrp map 172.20.102.1 192.168.255.166

ip nhrp map multicast 192.168.255.166

ip nhrp network-id 11

ip nhrp nhs 172.20.102.1

ip tcp adjust-mss 1360

delay 50

cdp enable

tunnel source GigabitEthernet0/0

tunnel destination 192.168.255.166

tunnel protection ipsec profile DMVPN

end

Regards,

Marija

The only difference I see with what I had back then is that I did not use the tunnels for the actuall traffic.

My tunnels were just there to 'connect' via CDP the remote sites while MPLS was routting the real traffic.

My guess is that the TU interface type is no longer included. Best ask cisco TAC about this.

There are various xml files that tell campus what it should do.

Cheers,

Michel

I got the answer from TAC engineer that DMVPN tunnles are not supported in topology view and that we can raise the request for enhancement to support this.

Regards,

Marija

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: