cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1320
Views
8
Helpful
5
Replies
ghenning.mil
Beginner

LMS: 4.2.3/4 patch install hangs at Copying files

                  On multiple installation attempts of LMS 4.2.3 and 4.2.4 onto an existing (stable) LMS 4.2.2 the installation starts running OK, but then hangs at some point in the copying files section.  There are no error messages and we can't find any log entries that state what the last successful file copy was nor if there is a file that is being prevented from overwriting, it just sits there and churns.  CPU usage is about 48% (+/-5%) and will keep on doing that for as long as we let it.  Actually allowed this to run for 24 hours, and it maintained the same conditions.  We kill the update processes, and do a daemon start.  Everything comes up and appears to operate correctly.  The Software Update within LMS still shows version 4.2.2, but if we attempt to re-install 4.2.4, it says it is already installed.  We have tried to do a re-installation, and get the same results: hang during "copying files".

Details on installation enviroment:

- Windows 2008 (RTM and R2 versons) OS 64-bit fully patched and joined to AD domain.  GPOs are supposed to be kept to bare minimum and only address mandatory organizational security compliance on the server's OU, but we have experienced the same problems with non-AD-joined test attempts as well.  AV service has been disabled during upgrade attempts (not just stopped from doing on-demand scans).  Running McAfee HBSS framework, patched, but with AV service disabled during upgrade.  Verified service is still disabled when hang happens.

- LMS 4.2 installed OK, LMS 4.2.2 patch installed OK, system allowed to discover network, jobs run, reports operating as expected.  All under the same AD/GPO/McAfee configuration as the 4.2.3/4 attempts that hang.

- Have attempted fresh builds going LMS 4.2 -> 4.2.2 -> 4.2.4 without allowing the system to settle/discover or do any tasks.  Still get the hang.

- Have even tried putting "everyone" group full access on the CSCOpx directory just to see if it's a file permissions issue, and I get the same hang.

- Have validated that all LMS-related tasks were stopped prior to beginning upgrade attempts.

- Have rebooted server with LMS daemon set to manual so no LMS services start before attempting upgrade.

This has happened on multiple campuses within this organization with different local admins working the keyboard and different physical hardware, all following the same build process that produced working LMS 4.2.2 builds.  I can get these installations to 4.2.2 every single time, but they just don't seem to want to take 4.2.3 or 4.2.4.

Any got an idea?

5 REPLIES 5
Vinod Arya
Cisco Employee

There are a couple more things you can do/check prior to upgrade which could prevent the extended "copying in progress" state when upgrading to LMS 4.2.4

1.             Change the TEMP and TMP variables to be a short path (e.g C:/temp or C:/tmp). This is done via My Computer > Properties > Advanced > Environment Variables > User variables for Administrator, selected TEMP, edit, changed Variable value from %USERPROFILE%\Local Settings\Temp to "C:\temp"; do the same to Variable TMP. From System variables > TEMP, edit, changed from %SystemRoot%\TEMP to "C:\temp"; do the same for TMP under System variables.

2. LMS generally need Naming convention to handle long names/path etc. By default C: has 8.3 Naming convention enabled. However if you installed on different drive (for eg E:), for which this may be disabled.

To check naming convention you can run the following command from Windows Command prompt:

                                   cmd>fsutil.exe 8dot3name query

---------------------------------------

Example:

C:\Users\winlau>fsutil 8dot3name query C:

The volume state for Disable8dot3 is 0 (8dot3 name creation is enabled).

The registry state of NtfsDisable8dot3NameCreation is 2, the default (Volume level setting).

Based on the above two settings, 8dot3 name creation is enabled on C:.

---------------------------------------

8dot3 needs to be enabled for all drives LMS will potentially use, including:

Drive where TEMP/TMP is located

The drive LMS is installed to

The drive LMS backs up to

Drive used for a relocated RME Shadow directory or other nonstandard paths written to.

In some cases, altering the TEMP and TMP variables to be a short path (eg C:/temp or C:/tmp) may avoid the issue, but not always.

Hence, to be safe, it is best to enable 8dot3name creation globally, either via the registry or Windows CLI

Sample command to enable globally:

  "fsutil 8dot3name set 0"    

Sample command to enable on one volume:

  "fsutil 8dot3name set X: 0

Note that this needs a reboot to take effect.  You should not disable 8dot3name creation which already has it enabled, especially the system volume (usually C:).

For further information  http://technet.microsoft.com/en-us/library/cc778996%28v=ws.10%29.aspx

Also check below as well

https://supportforums.cisco.com/docs/DOC-9132

-Thanks
Vinod
**Support COntributors. RATE them. **

-Thanks Vinod **Rating Encourages contributors, and its really free. **
AFROJ AHMAD
Cisco Employee

Hi Gary,

Can you try the insatllation again ,keeping these thing in consideration:

  • •1.       You should be logged in as a LOCAL ADMINISTRATOR account.

2.       Only the Essential windows program and services should be checked on the Server for DEP

. See the attached Image

  • •3.       Have the TEMP and TMP variables set with a short length. It is required because the normal default variables sometimes exceeds 32bit character length and have the installed hampered which uses command prompt at the background to invoke various tasks (they should be made sort such as C:\WINDOWS\TEMP and C:\WINDOWS\TMP):

see the attached image

  • •4.       Please have almost all the 3rd party software’s services disabled till the time updates/install is in progress, specially Avti-Virus programs.

Note: if the installation hangs again then open the TASK Manager and look for any thing from LMS service hanging there ... then kill it Manually and retry

Thanks-
Afroz
[Do rate the useful post]
****Ratings Encourages Contributors ****

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Vinod Arya
Cisco Employee

Did it resolved? Is the install successful or still you have issue?

-Thanks
Vinod
**Rating Encourages contributors, and its really free. **

-Thanks Vinod **Rating Encourages contributors, and its really free. **

Waiting on feedback from two remote locations.  Since both these sites already had the patch attempts tie up their systems for long periods of time, they don't want to be down (or risk having to rebuild after a corruption) at the moment.  I am able to get 4.2.4 installed in a test VMWare enviroment, so we know the files are OK.

Sounds something positive! Hope rest all would work properly as well.

-Thanks
Vinod
**Rating Encourages contributors, and its really free. **

-Thanks Vinod **Rating Encourages contributors, and its really free. **