cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
858
Views
0
Helpful
2
Replies
Highlighted
Beginner

LMS 4.2.5 Syslog/Automated Action/Config mgmt issue

LMS 4.2.5 on Windows

We use the server as it's own Syslog server. The Syslog collector status is fine. I see syslogs coming into the server. However, I just made some changes on a router so ran a syslog report on it, but nothing was returned. I Tested the Collector Subscription and everything was fine.

We also have Automated Actions configured on certain syslog messages (duplex mismatch for example). There is an AA configured to send my team e-mails when this event occurs. There was a device that had two days worth of syslog messages complaining about this issue. Yet, we only received about 10 e-mails from the LMS system on it.

Another issue is with Configuration Mgmt. I fixed the duplex mismatch listed above and went to check the config tree to see if or when something changed. The last config archive was pretty old and I know changes were made on the device since then. This tells me that the LMS server didn't get notified of the config change or it would have gone out and checked it.

The one thing in common on all of the above is Syslog messages. LMS will take actions based on receiving these messages and those actions don't seem to be firing.

Any ideas would be greatly appreciated.

Thanks,

Mike S.

2 REPLIES 2
Highlighted
Cisco Employee

To confirm if the device is sending the syslogs and they are being received by LMS server properly, check the $NMSROOT/log/syslog.log and see it has the syslog from the device.

Unless syslog is there on syslog.log, we don't expect LMS to react on any AA. 

For configuration backup, try to sync the device config by initiating a manual job to update the latest configuration from device. Even if there is no Automated Action working, you should still have a reoccurring/scheduled job configured to archive configuration backup periodically.

Following is a document I created for Syslog troubleshooting :

Ciscoworks LMS : Syslog in a Nutshell!

-Thanks

Vinod

**Encourage Contributors. RATE Them.**

-Thanks Vinod **Rating Encourages contributors, and its really free. **
Highlighted

My syslog.log file is currently 706,386 KB. The following syslog.log entries are also listed;

sylog.log.0.gz = 120,951 KB

sylog.log.1.gz = 126,580 KB

sylog.log.2.gz = 111,746 KB

Since the current log file is 7 times the size of the backups, I tried to run the DBSpaceReclaimer script. I stopped the processes with net stop crmdmgtd, waited for them to stop and then ran the below.

D:\CSCOpx\MDC\tomcat\webapps\rme\WEB-INF\debugtools\dbcleanup>DBSpaceReclaimer.pl

It appears to be working, but there are no status messages or anything. It's been running for about 20 minutes and still no status at all.

How long should this script take to run? Did I run it properly?

Thanks,

 

Content for Community-Ad