cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
1831
Views
0
Helpful
5
Replies
david de sousa
Beginner

LMS 4.2 Fault device details : unknown device type

                   Hi guys,

I'm experiencing a problem with LMS 4.2 Fault device details,

When  i did a discovery, all my devices were added to the inventory. I can see the type of device, when it was discovered and when it was added to inventory.

SO, i can change the monitoring of switch's interfaces BUT after some days,when i return to the fault device detail, i see all of my devices in unknown device type and i can't change the interface monitoring, or anything else.

If i do an another discovery, all my devices will return to learning state and often return in unknown device type. but if they come back, i lose the change i did before (like unmonitoring the interface vlan X).

i have a big number of devices and if i have to do that all three days, it become a big work.

anyone can help?

Thanks

David

5 REPLIES 5
secureIT
Enthusiast

run a wireshark > go to options > enter host x.x.x.x, where x.x.x.x is the ip address of any of the problematic router/switch. Then run the wireshark. See if you are getting proper response for the snmp get request.

Pls check if you have added the similar lines under Start >Run>drivers>hosts

open the hosts file...

add the below lines in the end.

x.x.x.x hostname

where x.x.x.x is the router ip address, hostname is the hostname of the router/switch.

Post which, if you have enabled the auto allocation in Dfm, then simply rediscover it., Else delete and add it in Dfm devices and wait for few seconds.

regards

Rajesh

Hello,

Well, i didn't run wireshark but i think SNMP is good.

Effectively, i deleted a device, then re added, and after few minutes, i can manage it like before. But it's not the first time, at first, i add the device with discovery and i have all of them, but after few days, they becomes unavailable (unknown).

So for the moment, i re added the problematics devices, but i'm sure it will be the same problems in few days. Has you met the problem before? is there any reason?

thank's for help

I got your problem...

while adding the devices in common service, do not select the device type. Device type will be pulled by snmp from Rme inventory collection, it is Rmes job to get the device type.

if u experience such problems, it could be that either the snmp agent in routers/switches are not updating to ciscoworks.

you will have to run snmpwalk from ciscoworks server to one of the problematic router/switch when the device type is showing as unknown... such problems have to be closely monitored rather than deleting/adding devices in CS. this is only a temporary solution. if all of your IOS images are standarized, you will have to check from IOS bug point of view as well.

you can try updating the device updates in common services as well, to get the new updates from cisco...

regards

Rajesh

hello,

Well, at start, it worked as you said, i don't select the device type, then rme does his work, and i can manage the switch and interfaces fault. but few days later, like today, it doesn't work, again...

my devices are all in unknown device type and i can't make any change on it. so my problem is still here :s

i'm continuing to search cause i think the prime and the snmp cause many problems to my network..

thank's for help

david de sousa
Beginner

hi,

i don't get the solution, but, you said to run a wireshark with the IP of a switch who's failing. but how do you do that? i tried to add a remote host, with authentication, but i'm not able to sniff the interface.

Can you explain a little more?

Thanks