cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
788
Views
4
Helpful
7
Replies
Ditlev Weinreich
Beginner

Non-existing connections in Cisco Prime LMS 4.2.4

        Hi

We have experienced weird connections in LMS 4.2.4 and earlier versions, even back to LMS 3.2.1. Even if I delete the connections, they reappear as if the connection was present.

but-why.JPG

but-why 2.JPG

Sometimes it is related to a change of interface from 1G to 10G and in some cases other device ...but not always.

It hurts my eyes, watching this, so I hope some of you might know the reason or even better, the solution.

Thanks in advance ;-)

1 ACCEPTED SOLUTION

Accepted Solutions

Hi ,

Seems to be corrupted database for ANI.   what I would suggest is to Reintialize the database for ANI.

Note: ANI database does not contain any historical data ,so reintilalizing it will not be a problem.

steps are :

1.stop the daemon manager

2.

windows:
NMSROOT\bin\perl.exe NMSROOT\bin\dbRestoreOrig.pl dsn=ani dmprefix=ANI

solaris\linux:

/opt/CSCOpx/bin/dbRestoreOrig.pl dsn=ani dmprefix=ANI

3. start the daemon manager

wait for 10-15 min then start a new DATACOLLECTIOn followed by user tracking Acquistion.

Hope it will take care of the issue

Thanks-
Afroz
[Do rate the useful post]
****Ratings Encourages Contributors ****

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

View solution in original post

7 REPLIES 7
AFROJ AHMAD
Cisco Employee

Hi,

Topology Map  does not show the Real time topology of the network. it  shows the devices and link status collected during

the Last DATA COLLECTION.

Check the status of your last data collection time stamp ? Is it the current date and time ? ( Go to Inventory > Acquistion Summary)  check " Last campus data collection completed at " ?

If it is updated even then you are not getting the correct data then RUN a new Data collection and re-check the issue.

Thanks-
Afroz
[Do rate the useful post]
****Ratings Encourages Contributors ****

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

Hi Afroj

Thanks for your reply

I've just tried your suggestion. This is the result.

Acquisition start time 27 Feb 2014, 10:00 CET

Last Acquisition end time 27 Feb 2014, 09:20 CET

(output is old, I know)

From  that I conclude, that i does acquire data. The weird part is that it  sometimes "forget" that a connection is moved or removed and therefore  it sometimes seems that 3 devices are connected on the same media/cable.

I've tried to run a datacollection, but with no  result. I does collect data as expected on new devices. If I physically  move a device, LMS sometimes moves the connection as well.  Other times, it just add the connection, so three devices share the same  media, ...even if I delete all the devices and asks it to collect  again.

Weeeeird.

Hi ,

Seems to be corrupted database for ANI.   what I would suggest is to Reintialize the database for ANI.

Note: ANI database does not contain any historical data ,so reintilalizing it will not be a problem.

steps are :

1.stop the daemon manager

2.

windows:
NMSROOT\bin\perl.exe NMSROOT\bin\dbRestoreOrig.pl dsn=ani dmprefix=ANI

solaris\linux:

/opt/CSCOpx/bin/dbRestoreOrig.pl dsn=ani dmprefix=ANI

3. start the daemon manager

wait for 10-15 min then start a new DATACOLLECTIOn followed by user tracking Acquistion.

Hope it will take care of the issue

Thanks-
Afroz
[Do rate the useful post]
****Ratings Encourages Contributors ****

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****

View solution in original post

I get:

C:\Program Files (x86)\CSCOpx\bin>NMSROOT\bin\perl.exe NMSROOT\bin\dbRestoreOrig

.pl dsn=ani dmprefix=ANI

The system cannot find the path specified.

I've created following system variable:

NMSROOT

C:\Program Files (x86)\CSCOpx

What have I done wrong?

Damn. Too fast. It's running now. I'll be back when it's done.

Thanks a lot. It worked. You've just been nominated to be my new personal hero.

I am glad to hear that issue is resolved.. 

Thanks for updating the thread..

Thanks-
Afroz
[Do rate the useful post]
****Ratings Encourages Contributors ****

Thanks- Afroz [Do rate the useful post] ****Ratings Encourages Contributors ****
Content for Community-Ad