cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
14491
Views
39
Helpful
58
Replies
Highlighted
Beginner

Prime Infrastructure 1.2 Syslog

Hi,

We are currently working on a solution comprising Cisco Prime Infrastructure 1.2 and we can't understand if Prime Infrastructure can work as a syslog collector, since we can't get it to show us any syslog messages sent from the network devices in its the Alarms & Events section. Is this a normal behavior? Is it necessary to use a remote syslog collector on another machine?

Best regards!

58 REPLIES 58
Highlighted
Frequent Contributor
Frequent Contributor

Hi Marvin,

Thanks a lot for you note regarding the logs. However, I need your orientation regarding the following:

I do not remember the root patch password in order to get the ADE# prompt and check the file. Do I have to create a bootable DVD with the ISO and then apply a password recovery???. 

If I am not wrong, the ncs password root password VALUE only applies for the GUI Access to the box. I changed this one and tried again but it does not work.

tdsbncs01/admin# root
Enter root patch password : 
% Error : invalid root patch password

thanks

 

Highlighted

You should be able to reset the root password as described in the admin guide. Link.

Highlighted
Frequent Contributor
Frequent Contributor

Hi Marvin,

If I am not wrong, I reset the "root" password as indicated in the admin guide using the command:

ncs/admin#ncs password root password VALUE

But looks like this command only applies for root user when you access the NCS via GUI as I mentioned above.

I clicked on the link you sent me but it does not work for me based on my CCO account privileges.

I was wondering if the "root" account (root shell) which requires "root patch password" is a low level account different to the previous one and allows you to go into ADE# prompt for shell configuration/directory management.

thanks in advance for any other clarification,

regards

AC

 

 

Highlighted

Sorry - that link had "partner" in the URL. If you ever come across them, 99 out of 100 times you can simply substitute "customer" for "partner" in the URL and it will work fine. 

You are right though - it is the same place you were looking when running the "ncs password root password VALUE" command and that is indeed for the GUI root user.

I don't remember off the top of my head how to change / recover the low level OS root account password and the PI I usually refer to is offline at the moment. The ADE-OS root user should be able to do it though from the cli.

Highlighted

Update - PI 2.2 opened up the syslog filter to include all severity levels. 

Here's the controlling file from a PI 2.2. server:

ade # pwd
/opt/CSCOlumos/conf
ade # 
ade # more syslog_sev_filter.xml
<condition field='severity' op='IN' value='0,1,2,3,4,5,6,7' />
ade # 
Highlighted

Hi Aijaz

Thanks a lot for this information.

I tested. Indeed it works.

You need to restart Prime after editing the file.,

Regards

Michel Misonne

Highlighted

Hi Michel,

You are welcome... Yes you need to restart prime after this file modification.

Regards

Aijaz

Highlighted

Could anyone let me know aijazbeigh's detection can work on PI 1.3 or NOT?

In addtion, with the syslog message with severity from 3 to 6, could we make PI raise up Events/Alarms?

Thanks.

Highlighted

Hi
I don't have prime 1.3 but it should work on it as well.


Sent from Cisco Technical Support iPhone App

Highlighted

Thanks.

But could you make Events/Alarms from syslog messages with severity 3 - 6?

Regards

Highlighted

Hi aijazbeigh,

I have the problem with my PI 2.0. Syslog message are not display

How do you change the file in cli mode, don't see the :

/opt/CSCOlumos/conf/syslog_sev_filter.xml file

Don't see too in my browser the lines to add

Regards.

Yves

 

Highlighted

HI

You need to go into shell:

and than, go to dir:

ade# cd /opt/CSCOlumos/conf

Than, you have to edit the file with vi.

 

Michel Misonne.

 

 

Prime20Express/admin# root_enable
% Error : root password already set
Prime20Express/admin#
Prime20Express/admin# root
Enter root password :
Starting root bash shell ...
ade # cd /opt/CSCOlumos/conf

 

Highlighted

Thanks,

After some search and read another time the Marvin post, I have yet the first syslog trap display in my PI.

For information,

Add the line <condition field='severity' op='EQUALS' value='3' />, and <condition field='severity' op='EQUALS' value='4' /> intoo the xml file.

Regards

Yves

Highlighted

Thanks for this information. My Prime was able to see logs in the syslog after adding the value. 

Highlighted

Hi, I also modified /opt/CSCOlumos/conf/syslog_sev_filter.xml and restarted PI. Now it works. Thanks!
Content for Community-Ad