cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
580
Views
0
Helpful
1
Replies

Routing vlans through router

cgarlick1972
Level 1
Level 1

I know my config is messy, I have tried everything I can think of to get this to work.

Could someone tell me why my vlans will not route to the internet?

(Also if you see anything that needs to be removed I would welcome that too)

870 Router

Current configuration : 4095 bytes
!
! Last configuration change at 18:06:58 UTC Sat Aug 3 2002 by cgarlick
version 15.1
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname AvatarRt01
!
boot-start-marker
boot-end-marker
!
!
enable secret 5 XXXXXXXXXXXXXXXXXXXXX
enable password 7 XXXXXXXXXXXXXXXXXXXXX
!
no aaa new-model
no process cpu autoprofile hog
!

dot11 syslog
ip source-route
ip dhcp excluded-address 10.0.10.1
ip dhcp excluded-address 10.0.20.1
ip dhcp excluded-address 10.0.30.1
ip dhcp excluded-address 10.0.40.1
ip dhcp excluded-address 10.0.10.2
ip dhcp excluded-address 10.0.20.2
ip dhcp excluded-address 10.0.30.2
ip dhcp excluded-address 10.0.40.2
!
ip dhcp pool Vlan1_DHCP
network 10.0.10.0 255.255.255.0
default-router 10.0.10.1
dns-server 8.8.8.8 8.8.4.4
domain-name Avatar.public
!
ip dhcp pool Vlan2_DHCP
network 10.0.20.0 255.255.255.0
default-router 10.0.20.1
dns-server 8.8.8.8 8.8.4.4
domain-name Avatar.public
!
ip dhcp pool Vlan3_DHCP
network 10.0.30.0 255.255.255.0
default-router 10.0.30.1
dns-server 8.8.8.8 8.8.4.4
domain-name Avatar.public
!
ip dhcp pool Vlan4_DHCP
network 10.0.40.0 255.255.255.0
dns-server 8.8.8.8 8.8.4.4
domain-name Avatar.public
default-router 10.0.40.1
!
!
!
ip cef
ip domain name AvatarDomain.local
!
!
!
!
vtp domain AvatarDomain.local
vtp mode transparent
username cgarlick privilege 15 password 7 XXXXXXXXXXXXXXXXX
!
!
vlan 2
!
!
!
interface FastEthernet0
no ip address
!
interface FastEthernet1
no ip address
!
interface FastEthernet2
no ip address
!
interface FastEthernet3
no ip address
!
interface FastEthernet4
mac-address 000f.8f38.6289
ip address 24.49.13.49 255.255.254.0
duplex auto
speed auto
!
interface Vlan1
ip address 10.0.10.1 255.255.255.0
ip nat inside
ip virtual-reassembly in
!
no ip forward-protocol nd
no ip http server
no ip http secure-server
!
ip route 0.0.0.0 0.0.0.0 24.49.12.1
!
ip access-list extended Internet
permit ip 10.0.0.0 0.0.0.255 any
!
access-list 1 permit any
!
!
!
snmp-server community Avatar_RT01_SNMP RO
!
control-plane
!
!
line con 0
logging synchronous
login local
no modem enable
line aux 0
line vty 0 4
privilege level 15
password 7 XXXXXXXXXXXXXXXXXXXXXXXXXXXXX
login local
transport input all
!
scheduler max-task-time 5000
end
####################################################################
3550 Switch

Current configuration : 5200 bytes
!
version 12.2
no service pad
service timestamps debug datetime msec
service timestamps log datetime msec
service password-encryption
!
hostname AvatarSW1
!
enable secret 5 XXXXXXXXXXXXXXXXXXXXXXXX
enable password 7 XXXXXXXXXXXXXXXXXXXXXXXXXXXXX
!
username cgarlick password 7 XXXXXXXXXXXXXXXXXXXXXXXXXX
no aaa new-model
ip subnet-zero
ip routing
ip domain-name Avatar-Switch
!
!
!
!
spanning-tree mode pvst
spanning-tree etherchannel guard misconfig
spanning-tree extend system-id
!
vlan internal allocation policy ascending
!
!
!
interface FastEthernet0/1
description To 870 router
switchport trunk encapsulation dot1q
switchport mode dynamic desirable
spanning-tree portfast
!
interface FastEthernet0/2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/3
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/4
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/5
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/6
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/7
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/8
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/9
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/10
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/11
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/12
switchport access vlan 2
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/13
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/14
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/15
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/16
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/17
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/18
switchport access vlan 3
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/19
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/20
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/21
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/22
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/23
switchport mode access
spanning-tree portfast
!
interface FastEthernet0/24
switchport access vlan 4
switchport mode access
spanning-tree portfast
!
interface GigabitEthernet0/1
switchport mode dynamic desirable
!
interface GigabitEthernet0/2
switchport mode dynamic desirable
!
interface Vlan1
ip address 10.0.10.2 255.255.255.0
!
interface Vlan2
ip address 10.0.20.2 255.255.255.0
!
interface Vlan3
ip address 10.0.30.2 255.255.255.0
!
interface Vlan4
ip address 10.0.40.2 255.255.255.0
!
ip classless
ip route 10.0.0.0 255.0.0.0 10.0.10.1
ip http server
ip http secure-server
!
!
control-plane
!
!
line con 0
logging synchronous
login local
line vty 0 4
password 7
login local
transport input ssh
line vty 5 15
login
!
end

1 Reply 1

Marvin Rhoads
Hall of Fame
Hall of Fame

If you want the VLAN traffic to access the Internet via the router then your switch needs to route "0.0.0.0" to it - you currently have an incorrect route for 10.0.0.0. 

To use the router as your DHCP server the switch's VLAN interfaces need an ip helper statement referencing the router's address. 

Finally, your NAT is incompletely setup. Here's a good short article on setting it up:

http://www.firewall.cx/cisco-technical-knowledgebase/cisco-routers/260-cisco-router-nat-overload.html

You don't have the ip nat outside interface defined or the ip nat statement with ACL referenced as described in the article I linked. 

Getting Started

Find answers to your questions by entering keywords or phrases in the Search bar above. New here? Use these resources to familiarize yourself with the community: