cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3478
Views
0
Helpful
3
Replies
dmcclain34
Beginner

SNMP Trap Question regarding Uplinks

I have Cisco 2960's, 3750's and 3750x's all running IOS on the access layer.  I have Cisco 6504's running IOS on the Distribution and Core layers.  I am looking to monitor redundant links through Spectrum by having specific ports send traps but I have run into trouble finding how to configure it. 

I would like to have:

1. Logging enabled for all links (Fiber and Copper) so that I see all links up/down messages in the syslog

2. SNMP traps sent for linkup/linkdown messages only for redundant links (ex. Dual Uplinks from Access Layer or Redundant Etherchannel Links on Dist Layer)

3. SNMP traps should be ignored/not sent for all copper ports.

Please let me know if you can help with this configuration.

3 REPLIES 3
Martin Ermel
Collaborator

1. enable logging to get all link-up link-down messages

    service timestamps log datetime localtime show-timezone

    logging host

    logging trap informational

    logging source-interface

    logging buffered 65536

2. / 3. enable SNMP traps for link-up / link-down events globaly and disable them on a per interface basis

    snmp-server host traps

    snmp-server enable traps snmp link-up link-down

    snmp-server trap-source

on the copper interfaces:

    no snmp trap link-status

(or just enable it on the fiber interfaces and do not use the global command)

on fiber interfaces:

    snmp trap link-status

Hi Martin and Thank you for your response!

I setup my devices as you stated, Enabling link traps globally and shutting off traps on each copper interface.  When I test, I am getting two traps:

1.  First trap is from the 2960 device stating Link Down.

2.  Second trap is from the CiscoLogMibNotification stating Link Down.

The second trap is what is causing the erroneous traps.  I would like to enable this all over my network but I get the CiscoLogMibNotification for each device where the link is connected.  Your help is much appreciated.

have you the follwoing command in your config?:

    snmp-server enable traps syslog

if so, disable it with

    no snmp-server enable traps syslog

and test again; if you still have problems, please post the traps as an example