cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
2345
Views
5
Helpful
3
Replies

SSH access to Server via cisco router

isaiahchikuse
Level 1
Level 1

Hello,

I have a server(Linux)on my local network that I want to access on the internet.

I tried doing port forwarding on my router but still I cant access it from outside.

 

what kind of configuration is need to achieve this?

 

Your assistance is highly appreciated 

Regards,

 

1 Accepted Solution

Accepted Solutions

try this :

 

ip nat inside source static tcp Linux-IP 22 External-IP 22 extendable  ( replace internal linux ip and external-ip)

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

View solution in original post

3 Replies 3

balaji.bandi
Hall of Fame
Hall of Fame

Post the router config here, what port you trying to access SSH ? or https?

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help

Am trying to access SSH on this server 

 

ip tftp source-interface GigabitEthernet0
!
!
!
!
interface Loopback0
 ip address 169.x.x.x 255.255.255.255
!
interface GigabitEthernet0/0/0
 no ip address
 negotiation auto
!
interface GigabitEthernet0/0/1
 no ip address
 shutdown
 negotiation auto
!
interface GigabitEthernet0/0/2
 description To LAN
 ip address 10.100.100.1 255.255.255.252
 ip nat inside
 negotiation auto
!         
interface GigabitEthernet0/0/3
 description Link to internet
 ip address 105.x.x.x 255.255.255.252
 ip nat outside
 negotiation auto
!
interface GigabitEthernet0
 vrf forwarding Mgmt-intf
 no ip address
 shutdown
 negotiation auto
!

ip nat translation tcp-timeout 10800
ip nat translation max-entries 2147483647
ip nat pool Africa-Nat 169.x.x.x 169.x.x.x netmask 255.255.255.0
ip nat inside source list 10 pool Africa-Nat overload
ip nat inside source static 10.10.1.71 169.x.x.x
ip forward-protocol nd
!
no ip http server
no ip http secure-server
ip route 10.3.0.0 255.255.255.0 10.100.100.2
ip route 10.10.1.0 255.255.255.0 10.100.100.2
ip route 10.16.0.0 255.240.0.0 10.100.100.2
ip route 102.x.x.x 255.255.252.0 100.64.8.121
ip route 168.x.x.x 255.255.255.0 100.64.8.121
ip route 169.x.x.x 255.255.252.0 10.100.100.2
ip route 169.x.x.x255.255.255.0 Null0
ip route 169.x.x.x 255.255.255.0 10.100.100.2
ip route 169.x.x.x 255.255.255.255 10.16.6.79
ip route 169.x.x.x 255.255.255.252 10.100.100.2
ip route 169.x.x.x 255.255.255.252 10.100.100.2
ip route 172.31.1.0 255.255.255.252 10.100.100.2
ip route 192.168.1.0 255.255.255.0 10.100.100.2
ip route 192.168.10.0 255.255.255.0 10.100.100.2
ip route 192.168.202.0 255.255.255.0 192.168.202.1
ip route 192.168.210.0 255.255.255.0 192.168.210.1
!
ip access-list extended SSH-ACCESS
 permit ip 10.10.1.0 0.0.0.255 any
 permit ip host 10.16.5.164 any
 deny   ip any any
!

access-list 1 permit any
access-list 10 permit 10.3.0.0 0.0.0.255
access-list 10 permit 10.10.1.0 0.0.0.255
access-list 10 permit 10.16.0.0 0.15.255.255
access-list 10 permit 10.100.100.0 0.0.0.255
access-list 10 permit 172.31.1.0 0.0.0.3
access-list 10 permit 192.168.1.0 0.0.0.255
access-list 10 permit 192.168.10.0 0.0.0.255
!
snmp-server community public RW
!
!
control-plane
!
!
line con 0
 logging synchronous
 stopbits 1
line aux 0
 stopbits 1
line vty 0 5
 session-timeout 5 
 access-class SSH-ACCESS in
 exec-timeout 5 0
 login local
 transport input telnet ssh
!
end

try this :

 

ip nat inside source static tcp Linux-IP 22 External-IP 22 extendable  ( replace internal linux ip and external-ip)

BB

***** Rate All Helpful Responses *****

How to Ask The Cisco Community for Help