cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
107
Views
0
Helpful
3
Replies
Highlighted
Beginner

Sub-interface and Vlan tagging

Hi all

I have a Cisco 1841 router and Cisco 2800 series router.

I am trying to setup a pppoe session with vlan tagging, however I have a challenge when I need to insert the below command into the sub-interface " pppoe-client dial-pool-number 1"

 

NAMIB(config)#int g0/1.200
NAMIB(config-subif)#enc
NAMIB(config-subif)#encapsulation do
NAMIB(config-subif)#encapsulation dot1Q 200
NAMIB(config-subif)#ppp
NAMIB(config-subif)#pppoe en
NAMIB(config-subif)#pppoe enable
NAMIB(config-subif)#ppp
NAMIB(config-subif)#pppoe en
NAMIB(config-subif)#pppoe enable gro
NAMIB(config-subif)#pppoe enable group glo
NAMIB(config-subif)#pppoe enable group global
NAMIB(config-subif)#ppp
NAMIB(config-subif)#pppoe-client dial-poo
NAMIB(config-subif)#pppoe-client dial-pool-number 1
^
% Invalid input detected at '^' marker.

NAMIB(config-subif)# "

 

The command is not allowed, is the a reason for this or am i doing something wrong. Now I am unable to obtain the public static IP address from ISP without the vlan configured.

 

 

my current configuration is as follows:

 

NAMIB#show run
Building configuration...

Current configuration : 1310 bytes
!
version 12.4
service timestamps debug datetime msec
service timestamps log datetime msec
no service password-encryption
!
hostname NAMIB
!
boot-start-marker
boot-end-marker
!
!
no aaa new-model
!
!
ip cef
!
!
!
!
voice-card 0
no dspfarm
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
!
interface GigabitEthernet0/0

ip address 192.168.15.1 255.255.255.0

description LAN network
duplex auto
speed auto
!
!

!

!interface GigabitEthernet0/1
no ip address

description ISP facing
duplex auto
speed auto

!

!

!
interface GigabitEthernet0/1.200

description ISP facing
encapsulation dot1Q 200
pppoe enable group global
!

!

!
interface Dialer1
ip address negotiated

description ISP facing
ip mtu 1492
ip nat outside
ip virtual-reassembly
encapsulation ppp
dialer pool 1
dialer-group 1
no cdp enable
ppp authentication chap callin
ppp chap hostname 46573@static.broadband.co.za
ppp chap password 0 broadband
!
!
!
no ip http server
no ip http secure-server
!
!
!
!
!
control-plane
!
!
!
!
!
!
!
!
!
!
line con 0
line aux 0
line vty 0 4
login
!
scheduler allocate 20000 1000
!
end

 

Thank you,

Tebza

 

3 REPLIES 3
Hall of Fame Expert

Re: Sub-interface and Vlan tagging

Hello Tebza35,

 

the PPPoE client started ad supported on physical interface only.

Support for tagged subinterface was added later.

 

You can try to update to a newer version of IOS and see if the pppoe client is supported.

 

Otherwise if you have a LAN switch you can define Vlan 200 over it, use an access port in vlan 200 towards the router and a trunk port towards the ISP that allows Vlan 200. In this way the ISP wil see Vlan tag 200 and you should be able to use your device with current IOS image.

 

Note:

the command pppoe enable group global should be to enable PPPoE server not client.

 

Hope to help

Giuseppe

 

Beginner

Re: Sub-interface and Vlan tagging

Hi Larosa

Thank you for this I will give it a try and let you know
Beginner

Re: Sub-interface and Vlan tagging

Hi

 

Are you able to send me a config with "Otherwise if you have a LAN switch you can define Vlan 200 over it, use an access port in vlan 200 towards the router and a trunk port towards the ISP that allows Vlan 200"

 

This would be greatly appreciated.

 

Thank you 

CreatePlease to create content
Content for Community-Ad