cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
625
Views
10
Helpful
13
Replies
JGoyonan
Beginner

TTL Expired in Transit - Cisco Catalyst

Good day Sir,

I would like to seek your assistance please. I can't connect to the other VLAN.

Here are the details.

 

Two VLAN configured in our Core Switch (VLAN10 & VLAN30). I am in the VLAN10 (172.16.10.20). I was trying to ping the other IP in VLAN30 (172.16.30.1) but I only got this message from CMD

 

C:\Users\admin>ping 172.16.30.1

Pinging 172.16.30.1 with 32 bytes of data:
Reply from 192.168.1.1: TTL expired in transit.
Reply from 192.168.1.1: TTL expired in transit.
Reply from 192.168.1.1: TTL expired in transit.
Reply from 192.168.1.1: TTL expired in transit.

Ping statistics for 172.16.30.1:
    Packets: Sent = 4, Received = 4, Lost = 0 (0% loss),

-----------------------------------------------------------------------

Also, their is no light for the SFP Port in the Core Switch. (VLAN30 configured in SFP Port gi1/0/26).

 

Here is the Interface Status from Core Switch.

 

DLA_CORE_SW#show interfaces status

Port     Name             Status     Vlan     Duplex Speed Type
Gi1/0/1 **********CONNECTI connected   routed     full 1000 10/100/1000BaseTX
Gi1/0/2                     notconnect 1           auto auto 10/100/1000BaseTX
Gi1/0/3 **********UNASSIGN disabled   1           full   100 10/100/1000BaseTX
Gi1/0/4 **********UNASSIGN disabled   1           full   100 10/100/1000BaseTX
Gi1/0/5 **********UNASSIGN notconnect 10         auto auto 10/100/1000BaseTX
Gi1/0/6 **********UNASSIGN disabled   1           auto auto 10/100/1000BaseTX
Gi1/0/7 **********UNASSIGN disabled   1           auto auto 10/100/1000BaseTX
Gi1/0/8 **********UNASSIGN disabled   1           auto auto 10/100/1000BaseTX
Gi1/0/9 **********UNASSIGN disabled   1           auto auto 10/100/1000BaseTX
Gi1/0/10 **********UNASSIGN disabled   1           auto auto 10/100/1000BaseTX
Gi1/0/11 **********UNASSIGN disabled   1           auto auto 10/100/1000BaseTX
Gi1/0/12 **********UNASSIGN disabled   1           auto auto 10/100/1000BaseTX
Gi1/0/13 **********UNASSIGN disabled   1           auto auto 10/100/1000BaseTX
Gi1/0/14 **********UNASSIGN disabled   1           auto auto 10/100/1000BaseTX
Gi1/0/15 **********UNASSIGN disabled   1           auto auto 10/100/1000BaseTX
Gi1/0/16 **********UNASSIGN disabled   1           auto auto 10/100/1000BaseTX
Gi1/0/17 **********UNASSIGN disabled   1           auto auto 10/100/1000BaseTX
Gi1/0/18 **********UNASSIGN disabled   1           auto auto 10/100/1000BaseTX
Gi1/0/19 **********UNASSIGN disabled   1           auto auto 10/100/1000BaseTX
Gi1/0/20 **********CONNECTI notconnect 99         auto auto 10/100/1000BaseTX
Gi1/0/21 **********CONNECTI notconnect 50         auto auto 10/100/1000BaseTX
Gi1/0/22 **********CONNECTI notconnect 50         auto auto 10/100/1000BaseTX
Gi1/0/23 **********ETHERCHA connected   trunk       full 1000 10/100/1000BaseTX
Gi1/0/24 **********ETHERCHA notconnect 1           full 1000 10/100/1000BaseTX
Gi1/0/25 **********FIBER CO notconnect 1           auto auto 1000BaseLX SFP
Gi1/0/26 **********FIBER CO notconnect 1           auto auto 1000BaseLX SFP
Gi1/0/27                   notconnect 1           auto auto Not Present
Gi1/0/28                   notconnect 1           auto auto Not Present
Po1     **********ETHERCHA notconnect unassigned auto auto
DLA_CORE_SW#
-----------------------------------------------------------------------

 

Here is also the result for tracert

 

C:\Users\admin>tracert 172.16.30.1

Tracing route to 172.16.30.1 over a maximum of 30 hops

1 <1 ms <1 ms <1 ms 172.16.10.1
2 <1 ms <1 ms <1 ms 192.168.1.1
3 <1 ms <1 ms <1 ms 192.168.1.2
4 2 ms 1 ms <1 ms 192.168.1.1
5 <1 ms <1 ms 2 ms 192.168.1.2
6 <1 ms <1 ms <1 ms 192.168.1.1
7 <1 ms <1 ms <1 ms 192.168.1.2
8 <1 ms <1 ms <1 ms 192.168.1.1
9 <1 ms <1 ms <1 ms 192.168.1.2
10 <1 ms <1 ms <1 ms 192.168.1.1
11 39 ms <1 ms <1 ms 192.168.1.2
12 1 ms <1 ms <1 ms 192.168.1.1
13 1 ms 1 ms 2 ms 192.168.1.2
14 1 ms <1 ms <1 ms 192.168.1.1
15 <1 ms <1 ms 1 ms 192.168.1.2
16 1 ms 1 ms 1 ms 192.168.1.1
17 <1 ms <1 ms <1 ms 192.168.1.2
18 1 ms <1 ms <1 ms 192.168.1.1
19 <1 ms <1 ms <1 ms 192.168.1.2
20 <1 ms <1 ms <1 ms 192.168.1.1
21 1 ms <1 ms <1 ms 192.168.1.2
22 <1 ms <1 ms <1 ms 192.168.1.1
23 1 ms 1 ms <1 ms 192.168.1.2
24 <1 ms <1 ms <1 ms 192.168.1.1
25 1 ms 1 ms 1 ms 192.168.1.2
26 1 ms 1 ms <1 ms 192.168.1.1
27 1 ms 1 ms 1 ms 192.168.1.2
28 1 ms <1 ms <1 ms 192.168.1.1
29 1 ms 1 ms 1 ms 192.168.1.2
30 1 ms <1 ms <1 ms 192.168.1.1

Trace complete.


What would be the cause for this problem and how do I solve this

 

Thank you in advance.

1 ACCEPTED SOLUTION

Accepted Solutions

There may be several layers to this problem. But I believe that the first issue to resolve is shown in this line from the original post

Gi1/0/26 **********FIBER CO notconnect 1           auto auto 1000BaseLX SFP

The switch is saying that Gi1/0/26 is not connected. Investigate and solve this first. Perhaps it is a problem with the physical connection on this switch. Perhaps it is a problem in the fiber that connects this switch to the other end. Perhaps it is a problem with the physical connection at the other end. Until this is resolved it is not worth effort to look for other problems.

HTH

Rick

View solution in original post

13 REPLIES 13
pieterh
VIP Collaborator

this behavior is called a routing loop, and should be investigated and corrected so you get a more meaningful status
in the end it means there is no router that has an active route to the subnet that 172.16.30.1 resides which also must be investigated
it may be that Gi1/0/26 is involved, but without more information about your network, we cannot tell for sure

 

about the routing loop

you've got two routers, where each thinks the destination CAN STILL be reached using a path through the other router
that's why the packets keep bouncing between the two of them
ping and traceroute uses a field in the packet called TTL, that is a counter that is decremented every time it is forwarded to another router
finally the counter is decremented to zero and the process stops

 

 

Hi @pieterh,
It was working before not until yesterday. Also their is no light is Port 26 in which the SFP Port inserted.

192.168.1.1 is the IP address of the Router while the IP address of the Core Switch is 192.168.1.2.

 

Is it possible to resolve this problem if we replace the SFP Transceiver?

 

Here is the result for IP Route

 

DLA_CORE_SW#show ip route


Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

 

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

172.16.0.0/24 is subnetted, 4 subnets
C 172.16.50.0 is directly connected, Vlan50
C 172.16.10.0 is directly connected, Vlan10
C 172.16.100.0 is directly connected, Vlan100
C 172.16.99.0 is directly connected, Vlan99
10.0.0.0/24 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Vlan998
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, GigabitEthernet1/0/1
S* 0.0.0.0/0 [1/0] via 192.168.1.1


Here is also the details for g1/0/26

 

!
interface GigabitEthernet1/0/26
description **********FIBER CONNECTION TO HOUSE SWITCH***********
switchport trunk encapsulation dot1q
switchport trunk native vlan 30
switchport trunk allowed vlan 1,10,20,30,40,50,60,70,99,100,998
switchport mode trunk
switchport nonegotiate
!


 

Thank you

pieterh
VIP Collaborator

if the device with address 172.16.30.1 is assigned to the house switch , then yes this link will be the problem
either this SFP, the SFP in house-switch, the cabling in between or the house switch itself

apparently the core switch has it's own interface in subnet  172.16.10.0 is / Vlan10 (C 172.16.10.0 is directly connected, Vlan10)

(and for other subnets, )

so it does not need the gateway 192.168.1.1 to reach  172.16.10.0 is / Vlan10

check if "ip routing" is enabled on the core switch

 

 

Hi @pieterh ,

How can I check if the "ip routing" is enabled? How about this

DLA_CORE_SW#show ip route


Codes: C - connected, S - static, R - RIP, M - mobile, B - BGP
D - EIGRP, EX - EIGRP external, O - OSPF, IA - OSPF inter area
N1 - OSPF NSSA external type 1, N2 - OSPF NSSA external type 2
E1 - OSPF external type 1, E2 - OSPF external type 2, E - EGP
i - IS-IS, su - IS-IS summary, L1 - IS-IS level-1, L2 - IS-IS level-2
ia - IS-IS inter area, * - candidate default, U - per-user static route
o - ODR, P - periodic downloaded static route

 

Gateway of last resort is 192.168.1.1 to network 0.0.0.0

172.16.0.0/24 is subnetted, 4 subnets
C 172.16.50.0 is directly connected, Vlan50
C 172.16.10.0 is directly connected, Vlan10
C 172.16.100.0 is directly connected, Vlan100
C 172.16.99.0 is directly connected, Vlan99
10.0.0.0/24 is subnetted, 1 subnets
C 10.0.0.0 is directly connected, Vlan998
192.168.1.0/30 is subnetted, 1 subnets
C 192.168.1.0 is directly connected, GigabitEthernet1/0/1
S* 0.0.0.0/0 [1/0] via 192.168.1.1

 

 

Also, I've already checked the House Switch and its connected properly. 

192.168.1.0/30, 
I see this ip subnet in routing table with 
C and there is no L ??
this meaning that the interface is not assign IP or the IP is not correct input, please can you share the show ip interface brief ?

Hi @MHM Cisco World ,

Yes, here is the result for IP INT BR

 

Interface IP-Address OK? Method Status Protocol
Vlan1 unassigned YES NVRAM administratively down down
Vlan10 172.16.10.1 YES NVRAM up up
Vlan20 172.16.20.1 YES NVRAM up down
Vlan30 172.16.30.1 YES NVRAM up down
Vlan40 172.16.40.1 YES NVRAM up down
Vlan50 172.16.50.1 YES NVRAM up up
Vlan60 172.16.60.1 YES NVRAM up down
Vlan70 172.16.70.1 YES NVRAM up down
Vlan99 172.16.99.1 YES NVRAM up up
Vlan100 172.16.100.1 YES NVRAM up up
Vlan998 10.0.0.1 YES NVRAM up up
GigabitEthernet1/0/1 192.168.1.2 YES NVRAM up up
GigabitEthernet1/0/2 unassigned YES unset down down
GigabitEthernet1/0/3 unassigned YES unset administratively down down
GigabitEthernet1/0/4 unassigned YES unset administratively down down
GigabitEthernet1/0/5 unassigned YES unset down down
GigabitEthernet1/0/6 unassigned YES unset administratively down down
GigabitEthernet1/0/7 unassigned YES unset administratively down down
GigabitEthernet1/0/8 unassigned YES unset administratively down down
GigabitEthernet1/0/9 unassigned YES unset administratively down down
GigabitEthernet1/0/10 unassigned YES unset administratively down down
GigabitEthernet1/0/11 unassigned YES unset administratively down down
GigabitEthernet1/0/12 unassigned YES unset administratively down down
GigabitEthernet1/0/13 unassigned YES unset administratively down down
GigabitEthernet1/0/14 unassigned YES unset administratively down down
GigabitEthernet1/0/15 unassigned YES unset administratively down down
GigabitEthernet1/0/16 unassigned YES unset administratively down down
GigabitEthernet1/0/17 unassigned YES unset administratively down down
GigabitEthernet1/0/18 unassigned YES unset administratively down down
GigabitEthernet1/0/19 unassigned YES unset administratively down down
GigabitEthernet1/0/20 unassigned YES unset down down
GigabitEthernet1/0/21 unassigned YES unset down down
GigabitEthernet1/0/22 unassigned YES unset down down
GigabitEthernet1/0/23 unassigned YES unset up up
GigabitEthernet1/0/24 unassigned YES unset down down
GigabitEthernet1/0/25 unassigned YES unset down down
GigabitEthernet1/0/26 unassigned YES unset down down
GigabitEthernet1/0/27 unassigned YES unset down down
GigabitEthernet1/0/28 unassigned YES unset down down
Port-channel1 unassigned YES unset down down

 

Now I see the interface is config and is up/up

the other side of this interface must be 198.168.1.1 not 1982.168.1.0 because this network ip not host ip.

please change it and see result

Hi @MHM Cisco World ,

 

The IP of the Router is 192.168.1.1 and the IP of Core Switch is 192.168.1.2.

I think theirs no need to change the IP, am I right?

 

Thank you

Sorry I was think that you try ping other ip so I suspect in default route,

friend from show ip interface brief the vlan 30 is down,

first no shut vlan 30

second make any port L2 as vlan 30 access to make it up, if you don’t have port make trunk allow vlan 30

pieterh
VIP Collaborator

the output you provided

i

=======================

nterface GigabitEthernet1/0/26
description **********FIBER CONNECTION TO HOUSE SWITCH***********
switchport trunk encapsulation dot1q
switchport trunk native vlan 30
switchport trunk allowed vlan 1,10,20,30,40,50,60,70,99,100,998
=======================

Vlan30 172.16.30.1 YES NVRAM up down

===================================

and

GigabitEthernet1/0/26 unassigned YES unset down down

 

all indicate that VLAN30 should be active on the interface  Gi1/0/26 labelled house switch but at this time is DOWN
>>> I've already checked the House Switch and its connected properly. <<<
is it connected to Gi1/0/26 ? if not to what port on the core ? and what is the configuration of that port on both sides?

There may be several layers to this problem. But I believe that the first issue to resolve is shown in this line from the original post

Gi1/0/26 **********FIBER CO notconnect 1           auto auto 1000BaseLX SFP

The switch is saying that Gi1/0/26 is not connected. Investigate and solve this first. Perhaps it is a problem with the physical connection on this switch. Perhaps it is a problem in the fiber that connects this switch to the other end. Perhaps it is a problem with the physical connection at the other end. Until this is resolved it is not worth effort to look for other problems.

HTH

Rick

View solution in original post

Hi @Richard Burts ,

After checking the fiber cable physically, I found out that someone cut the fiber cable intentionally. 

I also check the switch on the other side, its working and in good condition.

Now, we are going repair that cable......arghhh 

 

Thank you guys for all your replies.

Stay Safe, God Bless

Thank you for the update. Glad to know that you have found that the problem was cut fiber. Thank you for marking this question as solved. This will help other participants in the community to identify discussions which have helpful information. This community is an excellent place to ask questions and to learn about networking. I hope to see you continue to be active in the community.

HTH

Rick