cancel
Showing results for 
Search instead for 
Did you mean: 
cancel
3928
Views
0
Helpful
2
Replies

ASA 5505 DSL Config

Lajja1234
Level 1
Level 1

Hi!

I am setting up an ASA 5505 for a customer. I am not sure how to config the firewall when it is connected to a dsl modem. I tried to do a ordinary config just like the ones thats connected to a ordinary router.

The topology is:

ISP - DSL Modem (Bridged) - ASA5505 - AP/Klients/Server

My config is obviously wrong, can someone assist me?

Config :

SA Version 8.4(4)1

!

hostname ciscoasa

domain-name

enable password

passwd

names

!

interface Ethernet0/0

switchport access vlan 2

!

interface Ethernet0/1

!

interface Ethernet0/2

!

interface Ethernet0/3

shutdown

!

interface Ethernet0/4

shutdown

!

interface Ethernet0/5

shutdown

!

interface Ethernet0/6

shutdown

!

interface Ethernet0/7

shutdown

!

interface Vlan1

nameif inside

security-level 100

ip address 192.168.1.1 255.255.255.0

!

interface Vlan2

nameif outside

security-level 0

ip address dhcp setroute

!

ftp mode passive

dns server-group DefaultDNS

domain-name Asbergs.local

object network NAT_regel

subnet 192.168.1.0 255.255.255.0

description NAT regel

object network objectname

subnet 192.168.1.0 255.255.255.0

object network inside-et

subnet 192.168.1.0 255.255.255.0

object network nat

object network obj_any

object network inside

subnet 192.168.1.0 255.255.255.0

object network SSLClientPool

subnet 192.168.5.0 255.255.255.0

object-group protocol TCPUDP

protocol-object udp

protocol-object tcp

object-group network DM_INLINE_NETWORK_1

network-object 192.168.1.0 255.255.255.0

network-object object inside

object-group service DM_INLINE_SERVICE_1

service-object ip

service-object tcp-udp destination eq www

service-object tcp destination eq https

access-list NONAT extended permit ip 192.168.1.0 255.255.255.0 192.168.100.0 255.255.255.0

access-list NONAT extended permit ip 192.168.1.0 255.255.255.0 10.0.0.0 255.255.255.0

access-list NONAT extended permit ip 192.168.5.0 255.255.255.0 192.168.5.0 255.255.255.0

access-list split-tunnel standard permit 192.168.1.0 255.255.255.0

access-list split-tunnel standard permit 192.168.5.0 255.255.255.0

access-list inside_access_in extended permit object-group DM_INLINE_SERVICE_1 object-group DM_INLINE_NETWORK_1 interface outside

pager lines 24

logging enable

logging asdm informational

mtu inside 1500

mtu outside 1500

ip local pool SSLClientPool 192.168.5.10-192.168.5.20 mask 255.255.255.0

icmp unreachable rate-limit 1 burst-size 1

icmp deny any outside

no asdm history enable

arp timeout 14400

nat (inside,outside) source static inside inside destination static SSLClientPool SSLClientPool

!

object network inside-et

nat (inside,outside) dynamic interface

access-group inside_access_in in interface inside

timeout xlate 3:00:00

timeout pat-xlate 0:00:30

timeout conn 1:00:00 half-closed 0:10:00 udp 0:02:00 icmp 0:00:02

timeout sunrpc 0:10:00 h323 0:05:00 h225 1:00:00 mgcp 0:05:00 mgcp-pat 0:05:00

timeout sip 0:30:00 sip_media 0:02:00 sip-invite 0:03:00 sip-disconnect 0:02:00

timeout sip-provisional-media 0:02:00 uauth 0:05:00 absolute

timeout tcp-proxy-reassembly 0:01:00

timeout floating-conn 0:00:00

dynamic-access-policy-record DfltAccessPolicy

user-identity default-domain LOCAL

aaa authentication http console LOCAL

aaa authentication ssh console LOCAL

http server enable

http 192.168.1.0 255.255.255.0 inside

http 0.0.0.0 0.0.0.0 inside

no snmp-server location

no snmp-server contact

snmp-server enable traps snmp authentication linkup linkdown coldstart warmstart

no crypto isakmp nat-traversal

crypto ikev1 policy 65535

authentication pre-share

encryption 3des

hash sha

group 2

lifetime 86400

telnet timeout 5

ssh 0.0.0.0 0.0.0.0 inside

ssh timeout 5

ssh key-exchange group dh-group1-sha1

console timeout 0

threat-detection basic-threat

threat-detection statistics access-list

no threat-detection statistics tcp-intercept

webvpn

enable outside

anyconnect image disk0:/anyconnect-win-2.5.3046-k9.pkg 1

anyconnect enable

tunnel-group-list enable

group-policy SSLClientPolicy internal

group-policy SSLClientPolicy attributes

dns-server value 10.0.0.1

vpn-tunnel-protocol ssl-client

split-tunnel-policy tunnelspecified

split-tunnel-network-list value split-tunnel

default-domain value Asbergs.local

address-pools value SSLClientPool

group-policy SSLCLient internal

group-policy SSLCLient attributes

split-tunnel-policy tunnelspecified

split-tunnel-network-list value split-tunnel

tunnel-group SSLClientProfile type remote-access

tunnel-group SSLClientProfile general-attributes

default-group-policy SSLClientPolicy

tunnel-group SSLClientProfile webvpn-attributes

group-alias SSLVPNClient enable

!

class-map inspection_default

match default-inspection-traffic

!

!

policy-map type inspect dns preset_dns_map

parameters

  message-length maximum client auto

  message-length maximum 512

policy-map global_policy

class inspection_default

  inspect dns preset_dns_map

  inspect ftp

  inspect h323 h225

  inspect h323 ras

  inspect ip-options

  inspect netbios

  inspect rsh

  inspect rtsp

  inspect skinny

  inspect esmtp

  inspect sqlnet

  inspect sunrpc

  inspect tftp

  inspect sip

  inspect xdmcp

!

service-policy global_policy global

prompt hostname context

no call-home reporting anonymous

call-home

profile CiscoTAC-1

  no active

  destination address http https://tools.cisco.com/its/service/oddce/services/DDCEService

  destination address email callhome@cisco.com

  destination transport-method http

  subscribe-to-alert-group diagnostic

  subscribe-to-alert-group environment

  subscribe-to-alert-group inventory periodic monthly

  subscribe-to-alert-group configuration periodic monthly

  subscribe-to-alert-group telemetry periodic daily

: end

2 Replies 2

Here is an example of a PPPoE-config for the ASA 5505:

interface Vlan2

  nameif outside

  security-level 0

  pppoe client vpdn group PPPOE-GROUP

  ip address pppoe setroute

vpdn group PPPOE-GROUP request dialout pppoe

vpdn group PPPOE-GROUP localname USERNAME

vpdn group PPPOE-GROUP ppp authentication pap

vpdn username USERNAME password PASSWORD store-local

You need to change USERNAME and PASSWORD with the ones your provider gave you.

-- 
Don't stop after you've improved your network! Improve the world by lending money to the working poor:
http://www.kiva.org/invitedby/karsteni

Thank you for quick response!

I will give it a try tomorrow

Review Cisco Networking for a $25 gift card